Clam TK can't find virus definitions

Bug #366572 reported by Adam Niedling on 2009-04-25
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Hardy Backports
Undecided
Unassigned
Karmic Backports
Undecided
Unassigned
clamtk (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: clamtk

I'm using Jaunty and clamtk 4.08-1.
Clam TK virus scanner can't find virus definitions. Please see attached screenshot. This is the same when I'm running clamtk with sudo. However it's possible to run scans, I just don't know if there is any use of it if there are no virus definitions.

Adam Niedling (krychek) wrote :

Please try the updated clamav package in jaunty-proposed and see if that
solves this issue.

Adam Niedling (krychek) wrote :

I installed the new package from jaunty-proposed. It still says Virus definitions: none found. One thing got improved, now I can check for updates at help -> update signatures and it says Signatures are current.

Scott Kitterman (kitterman) wrote :

Historically clamtk didn't have a good idea if it had signatures or not. Please install clamav-testfiles and see if you can find the test "virus". If you can, then this is clamtk being confused about signatures and not an actual lack of signatures.

Scott Kitterman (kitterman) wrote :

The clamav update you tested is in Jaunty updates now, so clamtk should have sufficient permissions to get signatures to update for each user (the single user option). I did test this and find that it had the signatures and could find the clamav test files.

If you look at the screenshot you provided, you can see a green check mark next to signatures. Also when you use the check updates function is will check and finds it has current signatures. So I see this as a user interface problem, the actual functioning of clamtk (and clamav) is fine.

The problem (as you point out) is the 'None Found'. This is inaccurate and will certainly confuse and concern users, but doesn't appear to affect clamtk's ability to find a virus.

Changed in clamtk (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Adam Niedling (krychek) wrote :

For some reason I don't get notifications when there is a reply for this bug. Thanks for looking into this.

The problem also exists in ClamTK 3.08 (Ubuntu Hardy LTS).
ClamTK says "Signaturen 0 ()", but

sudo freshclam
ClamAV update process started at Thu May 21 13:08:11 2009
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.94.2 Recommended version: 0.95.1
DON'T PANIC! Read http://www.clamav.net/support/faq
main.cld is up to date (version: 51, sigs: 545035, f-level: 42, builder: sven)
daily.cld is ...

Nevertheless, viruses are scanned and seem to be found (as TiKaey reports here:
http://www.ubuntu-forum.de/post/263217/clamtk-zeigt-signaturen-0.html#post263217

Once the bug is fixed, please backport to Hardy.

Dave M (dave-nerd) wrote :

This was fixed in 4.10, and 4.13 is available from the upstream website.

Added "Hardy Backports" to make sure, the fix is backported to Hardy (LTS).

Adam Niedling (krychek) wrote :

This is fixed in Karmic.

Changed in clamtk (Ubuntu):
status: Confirmed → Fix Released
Keith Calico (dboyd44) wrote :

Does not work

Dave M (dave-nerd) wrote :

Keith, can you verify the version you are running? 4.23?

Also, please try running "clamtk" (sans quotes) from the commandline to see if any error messages are being thrown out there.

Thanks,

dino99 (9d9) wrote :

Made a control today with Karmic32:

into console: sudo clamtk
- virus definitions outdated
- outdated clamtk: 4.15-1, latest is 4.25-1

need to reconfigure clamtk (clamtk menu) to update virus definitions. So there is something wrong with auto update. Both release and definitions might be automatic (4.25 have a major fix and a deb package is ready for ubuntu)

So, i have downloaded and installed 4.25 but left behind such security updates it's not serious.

tags: added: karmic
dino99 (9d9) wrote :

same problem with Jaunty: have to use clamtk menu to check for definitions updates, and interface is 4.20 (outdated)

dino99 (9d9) wrote :

clamav and other related packages might automatically check and/or run:

sudo dpkg-reconfigure clamav-base

new comers can't know easily they have to do that .

Scott Kitterman (kitterman) wrote :

You don't have to do that. As installed by the package manager, freshclam will keep the definitions up to date.

dino99 (9d9) wrote :

Sorry Scott,

update-manager does not install all the necessary stuff:

 - i confirm that definitions are not updated automatically: run clamtk into console and you will see it yourself
    ( have to use its menu to check if updates are available )
 - the clamav-daemon package is not installed too, might be a dependency of clamav, and there is no settings or scheduler for that daemon (cron / anacron is nor specific enough)

 - major bug fix or updates might reached automatically the repo, example with last clamtk.

So, please reconsider what is absolutly needed , what might be dependencies, and how to run smoothly all this in real time.

Dave M (dave-nerd) wrote :

@dino99, I cannot duplicate this. I can update signatures individually or using the signatures downloaded by freshclam. Also, the package which does updating (freshclam) is part of 'clamav-freshclam', not 'clamav-daemon'. Can you see if that is installed? If not, where did you get the clamtk package? From clamtk.sf.net, or from the official Debian packages? Also, have you tried using the option "rerun the AV wizard" in clamtk?

Thanks,

dino99 (9d9) wrote :

Thanks Dave,

all packages are from synaptic , ubuntu official repo, no ppa except clamtk updated from sourceforge as said into posts above.
To clarify:
- updates are done if user "rerun the AV wizard", it's ok but not resolve the "automatic" updates which are not done behind the scene as it should be.

- when user choose to install clamav for the first time, clamav-freshclam is installed too as a dependency, but nothing else, clamav-base is only recommanded.

That's what i have done some months ago, and the situation described into posts above is what i've seen: outdated virus signatures and outdated clamtk (not installed by default with ubuntu).
Try yourself and concluded as myself that important packages are missing as dependencies:
- clamav-base
- clamav-getfiles
- clamav-testfiles
- clamav-daemon
- clamtk

So i hope you now understand where the problem is.

dino99 (9d9) on 2011-08-29
Changed in karmic-backports:
status: New → Incomplete
Changed in hardy-backports:
status: New → Incomplete
Dave M (dave-nerd) wrote :

@dino99, are you still having trouble with this?

Thanks,
Dave M

Rolf Leggewie (r0lf) wrote :

karmic is no longer supported and receives no further updates

Changed in karmic-backports:
status: Incomplete → Invalid
dino99 (9d9) wrote :

can be closed now

dino99 (9d9) on 2012-08-30
Changed in hardy-backports:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers