package: clamsmtp (1.9-0ubuntu1); and clamav-base,clamav-daemon (both 0.94.dfsg.2-1ubuntu0.1~hardy1) - failed to install/upgrade: dependency problems - leaving unconfigured

Bug #327909 reported by nimbosa on 2009-02-11
4
Affects Status Importance Assigned to Milestone
clamsmtp (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: clamsmtp

package clamsmtp (1.9-0ubuntu1) and clamav-base,clamav-daemon (both 0.94.dfsg.2-1ubuntu0.1~hardy1) failed to install/upgrade: dependency problems - leaving unconfigured

Errors were encountered while processing:
 clamav-base
 clamav-daemon
 clamsmtp

Setting up clamav-base (0.94.dfsg.2-1ubuntu0.1~hardy1) ...
id: clamav: No such user
chown: invalid user: `clamav:clamav'
chown: invalid user: `clamav:clamav'
chown: invalid user: `clamav:clamav'
install: invalid user `clamav'
dpkg: error processing clamav-base (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of clamav-daemon:
 clamav-daemon depends on clamav-base (= 0.94.dfsg.2-1ubuntu0.1~hardy1); however:
  Package clamav-base is not configured yet.
dpkg: error processing clamav-daemon (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of clamsmtp:
 clamsmtp depends on clamav-daemon (>= 0.75.1); however:
  Package clamav-daemon is not configured yet.
dpkg: error processing clamsmtp (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 clamav-base
 clamav-daemon
 clamsmtp
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
Building tag database... Done

-:: i had to manually add clamav user and group to get going:

ubuntu:~$ sudo adduser --system --no-create-home --disabled-password --disabled-login --shell /bin/false --group --home /var/lib/clamav clamav
Adding system user `clamav' (UID 113) ...
Adding new group `clamav' (GID 126) ...
Adding new user `clamav' (UID 113) with group `clamav' ...

is there no script that automates this on installation of any of the above packages
this is the latest version available for Ubuntu 8.04.2 from Synaptic, here is my sources.list:

#
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository. This software is not part of Ubuntu, but is
## offered by Canonical and the respective vendors as a service to Ubuntu
## users.
deb http://archive.canonical.com/ubuntu hardy partner
deb-src http://archive.canonical.com/ubuntu hardy partner

deb http://packages.medibuntu.org/ hardy free non-free
deb http://ppa.launchpad.net/transmissionbt/ubuntu hardy main
deb-src http://ppa.launchpad.net/transmissionbt/ubuntu hardy main
deb http://ppa.launchpad.net/openoffice-pkgs/ubuntu hardy main
deb http://ppa.launchpad.net/awn-testing/ubuntu hardy main

# deb cdrom:[Ubuntu 8.04.1 _Hardy Heron_ - Release i386 (20080701)]/ hardy main restricted
deb http://tw.archive.ubuntu.com/ubuntu/ hardy main universe restricted multiverse
deb http://security.ubuntu.com/ubuntu/ hardy-security universe main multiverse restricted
deb http://tw.archive.ubuntu.com/ubuntu/ hardy-updates universe main multiverse restricted
deb http://tw.archive.ubuntu.com/ubuntu/ hardy-backports universe main multiverse restricted

ProblemType: Package
Architecture: i386
Date: Wed Feb 11 13:18:44 2009
DistroRelease: Ubuntu 8.04
ErrorMessage: dependency problems - leaving unconfigured
Package: clamsmtp 1.9-0ubuntu1
PackageArchitecture: i386
SourcePackage: clamsmtp
Title: package clamsmtp 1.9-0ubuntu1 failed to install/upgrade: dependency problems - leaving unconfigured
Uname: Linux 2.6.24-23-generic i686

nimbosa (darth-serious) wrote :
Scott Kitterman (kitterman) wrote :

If anything this is clamav related.

According to the log you have clamav previously installed, but on this upgrade, the clamav user was missing (and you added it manually). You can't install clamav without the clamav user. Any ideas what happened to it?

Changed in clamsmtp:
status: New → Incomplete
Scott Kitterman (kitterman) wrote :

I should have mentioned that I've tried to replicate this a couple of different ways and can't manage it.

i also had to add sane/scanner group/user back manually,
it seems the group and passwd files got corrupted OR overwritten by the
Users and Groups gui on systems settings, that was the last time things
worked properly

> ProblemType: Package
> Architecture: i386
> Date: Wed Feb 11 13:18:44 2009
> DistroRelease: Ubuntu 8.04
> ErrorMessage: dependency problems - leaving unconfigured
> Package: clamsmtp 1.9-0ubuntu1
> PackageArchitecture: i386
> SourcePackage: clamsmtp
> Title: package clamsmtp 1.9-0ubuntu1 failed to install/upgrade: dependency
> problems - leaving unconfigured
> Uname: Linux 2.6.24-23-generic i686
>

Scott Kitterman (kitterman) wrote :

It's clear this isn't a clamav specific bug, so I'm removing the assigned package. Hopefully someone working on more general triage will be able to help you figure it out.

Changed in clamav:
status: Incomplete → New
nimbosa (darth-serious) wrote :

okay,

so clamav packages are not supposed to check for clamav:clamav , clamav:adm
users when installing/upgrading?

should not clamav create them when missing?

They are and they do. Whatever caused the user to get messed up is likely
at the root of the error. This aspect of the clamav-base postinstall
script is unchanged for a long time and works well for virtually everyone.

Something else is wrong with your system. I don't know what.

Tom rooze.sen (tomrooze-sen) wrote :
Download full text (21.3 KiB)

, builder: sven)
daily.cvd is up to date (version: 9028, sigs: 13544, f-level: 38, builder: ccordes)
-------------------------------------- freshclam daemon 0.92.1 (OS: linux-gnu, ARCH: i386, CPU: i486)
ClamAV update process started at Mon Feb 23 11:03:34 2009
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.92.1 Recommended version: 0.94.2
DON'T PANIC! Read http://www.clamav.net/support/faq
Downloading main-46.cdiff [100%]
Downloading main-47.cdiff [100%]
Downloading main-48.cdiff [100%]
Downloading main-49.cdiff [100%]
Downloading main-50.cdiff [100%]
main.cvd updated (version: 50, sigs: 500667, f-level: 38, builder: sven)
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Current functionality level = 26, recommended = 38
DON'T PANIC! Read http://www.clamav.net/support/faq
WARNING: getfile: daily-5778.cdiff not found on remote server (IP: 212.71.0.71)
ERROR: getpatch: Can't download daily-5778.cdiff from db.local.clamav.net
WARNING: getfile: daily-5778.cdiff not found on remote server (IP: 130.59.10.36)
ERROR: getpatch: Can't download daily-5778.cdiff from db.local.clamav.net
WARNING: getfile: daily-5778.cdiff not found on remote server (IP: 212.71.0.71)
ERROR: getpatch: Can't download daily-5778.cdiff from db.local.clamav.net
WARNING: getfile: daily-5778.cdiff not found on remote server (IP: 212.71.0.71)
ERROR: getpatch: Can't download daily-5778.cdiff from db.local.clamav.net
WARNING: getfile: daily-5778.cdiff not found on remote server (IP: 130.59.10.36)
ERROR: getpatch: Can't download daily-5778.cdiff from db.local.clamav.net
WARNING: Incremental update failed, trying to download daily.cvd
Downloading daily.cvd [100%]
daily.cvd updated (version: 9028, sigs: 13544, f-level: 38, builder: ccordes)
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Current functionality level = 26, recommended = 38
DON'T PANIC! Read http://www.clamav.net/support/faq
Database updated (514211 signatures) from db.local.clamav.net (IP: 130.59.10.36)
WARNING: Clamd was NOT notified: Can't connect to clamd through /var/run/clamav/clamd.ctl
--------------------------------------
--------------------------------------
ClamAV update process started at Mon Feb 23 11:07:20 2009
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.92.1 Recommended version: 0.94.2
DON'T PANIC! Read http://www.clamav.net/support/faq
main.inc is up to date (version: 50, sigs: 500667, f-level: 38
ClamAV update process started at Mon Feb 23 11:38:47 2009
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.92.1 Recommended version: 0.94.2
DON'T PANIC! Read http://www.clamav.net/support/faq
main.inc is up to date (version: 50, sigs: 500667, f-level: 38, builder: sven)
daily.cvd is up to date (version: 9028, sigs: 13544, f-level: 38, builder: ccordes)
Received signal: wake up
ClamAV update process started at Mon Feb 23 12:04:02 2009
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.92.1 Recommended version: 0.94.2
DON'T PANIC! Read http://www.clamav.net/support/faq
main.inc is up to date (version: 50, sigs: 500667, f-level: 38, builder: sven)
Ig...

LinkedIn
------------

Bug,

I'd like to add you to my professional network on LinkedIn.

- seth

seth Nimbosa
Director - iCT Custodian at Myron Care & Employment Services, LTD
San Francisco Bay Area

Confirm that you know seth Nimbosa:
https://www.linkedin.com/e/-xnki4q-hqpcpaqi-3d/isd/19502763699/J7kh1xfw/?hs=false&tok=1giOSRrRGyAS41

--
You are receiving Invitation to Connect emails. Click to unsubscribe:
http://www.linkedin.com/e/-xnki4q-hqpcpaqi-3d/Tj1N-HVEW9DsCFUVYVc-4stE2N4QjhnCZf-ihbP/goo/327909%40bugs%2Elaunchpad%2Enet/20061/I6315953069_1/?hs=false&tok=1G6tsrykCyAS41

(c) 2012 LinkedIn Corporation. 2029 Stierlin Ct, Mountain View, CA 94043, USA.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers