[Natty] freshclam.conf has invalid characters and cannot be parsed

Bug #784797 reported by Scott Testerman on 2011-05-18
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
clamav (Debian)
Fix Released
Unknown
clamav (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: clamav-freshclam

Both postinst and manually running "sudo dpkg-reconfigure clamav-freshclam" leave an invalid /etc/clamav/freshclam.conf file, leaving freshclam unable to update. Running freshclam results in the following error:

"ERROR: Incorrect argument format for option HTTPProxyPort
ERROR: Can't open/parse the config file /etc/clamav/freshclam.conf"

When manually configuring via dpkg-reconfigure, the Proxy question cannot be left blank; the "http://" cannot be removed. In the generated freshclam.conf, the Proxy, HTTPProxyServer, and HTTPProxyPort lines all have invalid characters. Editing the file to correct or remove these lines results in a correctly functioning freshclam.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: clamav-freshclam 0.97+dfsg-2ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Wed May 18 15:07:46 2011
InstallationMedia: Kubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcEnviron:
 LANGUAGE=en_US
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: clamav
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Scott Moser (smoser) wrote :

Thank you for taking the time to help make Ubuntu better.

I apologize for not understanding. However, I'm not able to reproduce this bug.
On a fresh ec2 instance (i386), I've tried:
$ sudo apt-get install clamav-freshclam

No errors occur on installation.

$ sudo dpkg-reconfigure clamav-freshclam
# select 'daemon'
# select 'db.local.clamav.net'
# do not enter a proxy (just tab to 'ok')
# use the default '24' times per day
# take default 'No' that freshclam should be notified after updates.

I do not see any errors, nor do I see non ascii characters in /etc/clamav/freshclam.conf.

Could you provide some more information to help us reproduce the problem?

Changed in clamav (Ubuntu):
status: New → Incomplete

I purged clamav and freshclam, then purged downloaded packages. Then I switched my mirror from the default U.S. mirror to anl.gov, and reinstalled both packages.

On reinstallation, the freshclam dpkg configuration no longer has the proxy info autofilled, and the final configuration file has no errors. Looks like this was a case of a faulty package download, so thanks for the verification!

Marking the bug as invalid.

Changed in clamav (Ubuntu):
status: Incomplete → Invalid
quazgar (quazgar) wrote :

Unfortunately, I can confirm the original poster's problem, same error message, same symptoms.

Changed in clamav (Ubuntu):
status: Invalid → New
quazgar (quazgar) wrote :

One workaround to remove the "http://" part for me was to jump to the beginning of the line with C-a and then delete the line with C-k. I'm not certain if this is a bug in freshclam's config or maybe rather in the combination of debconf, bash and possibly konsole.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in clamav (Ubuntu):
status: New → Confirmed
Michael Tautschnig (mt-debian) wrote :

Hi,

Could those seeing this issue please send the part of their freshclam.conf file that has

# Proxy:

and the subsequent lines? This should help to understand what exactly ends up there as value. I'm guessing it is just white space, but that needs to be confirmed.

Best,
Michael

Changed in clamav (Debian):
status: Unknown → New
Changed in clamav (Debian):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package clamav - 0.97.5+dfsg-3ubuntu1

---------------
clamav (0.97.5+dfsg-3ubuntu1) quantal; urgency=low

  * Merge from Debian unstable. Remaining changes:
    - Drop build-dep on electric-fence (in Universe)
    - Add apparmor profiles for clamd and freshclam along with maintainer
      script changes

clamav (0.97.5+dfsg-3) unstable; urgency=low

  * Fix proxy port configuration handling in clamav-freshclam.postinst so that
    failure to specify port does not result in an invalid configuration
    (Closes: #678247), (LP: #784797)
 -- Scott Kitterman <email address hidden> Mon, 09 Jul 2012 19:22:18 -0400

Changed in clamav (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.