libclamav6: Some PDFs cause "Unknown error code ERROR"

Bug #658341 reported by Scott Kitterman on 2010-10-11
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ClamAV
Unknown
Unknown
Dapper Backports
Undecided
Unassigned
Hardy Backports
Undecided
Unassigned
Jaunty Jackalope Backports
Undecided
Unassigned
Karmic Backports
Undecided
Unassigned
clamav (Debian)
Fix Released
Unknown
clamav (Ubuntu)
High
Scott Kitterman
Lucid
Undecided
Unassigned
Maverick
High
Unassigned
Natty
High
Scott Kitterman

Bug Description

Binary package hint: clamav

Clamav-daemon now fails to scan specific PDF files with the message
"Unknown error code ERROR". I believe that only some PDFs are affected,
as we're only seeing this with (AFAICT) one message on one of several
low-volume mail servers we manage.

It appears to be the issue described in
  https://wwws.clamav.net/bugzilla/show_bug.cgi?id=2296

TEST CASE: Scan an affected file using clamdscan <filename> (please contact the author of the bug if you need a test file - I have one, but it has private information in it, so I'm not attaching it to the bug). You should see in the results something like:

<path/filename>: Unknown error code ERROR

Upgrade to the maverick-proposed package and scan again. This time you should get something like:

<path/filename>: OK

This means the fix has worked.

Changed in clamav (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Scott Kitterman (kitterman)
milestone: none → maverick-updates
tags: added: regression-release
description: updated
Changed in clamav (Debian):
status: Unknown → New
Martin Pitt (pitti) on 2010-10-12
Changed in clamav (Ubuntu Maverick):
milestone: none → maverick-updates
Changed in clamav (Ubuntu Natty):
milestone: maverick-updates → natty-alpha-1

Accepted clamav into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Imre Gergely (cemc) wrote :

Tested and NOT working on Maverick (x86_64, desktop). I get the same error after upgrading from -proposed.

gimre@ximi:/var/lib/clamav$ apt-cache policy clamav-daemon
clamav-daemon:
  Installed: 0.96.3+dfsg-2ubuntu1.1
  Candidate: 0.96.3+dfsg-2ubuntu1.1
  Version table:
 *** 0.96.3+dfsg-2ubuntu1.1 0
        500 http://ro.archive.ubuntu.com/ubuntu/ maverick-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     0.96.3+dfsg-2ubuntu1 0
        500 http://ro.archive.ubuntu.com/ubuntu/ maverick/main amd64 Packages

gimre@ximi:/var/lib/clamav$ sudo /etc/init.d/clamav-daemon restart
 * Stopping ClamAV daemon clamd [ OK ]
 * Starting ClamAV daemon clamd [ OK ]
gimre@ximi:/var/lib/clamav$ clamdscan /tmp/test.pdf
/tmp/test.pdf: Unknown error code ERROR

----------- SCAN SUMMARY -----------
Infected files: 0
Total errors: 1
Time: 0.089 sec (0 m 0 s)

gimre@ximi:/var/lib/clamav$ ls -la /tmp/test.pdf
-rw-r--r-- 1 gimre gimre 1458176 2010-10-10 18:31 /tmp/test.pdf
gimre@ximi:/var/lib/clamav$

Imre Gergely (cemc) wrote :

Ignore the above comment. I did the upgrade wrong. I was still using libclamav6 from -main. Redid the test on Maverick (both i386 and x86_64) and the package from -proposed is working OK. The fix works in Maverick.

Jean-Baptiste Lallement (jibel) wrote :

@Imre, Thanks for testing. Are you able to test the version in lucid too with a chroot or a VM ? Alternatively, send me a PDF triggering that failure with no confidential informations. Thanks in advance

tags: added: verification-done
removed: verification-needed
Jean-Baptiste Lallement (jibel) wrote :

I'm leaving the verification-needed for lucid-proposed.

Changed in clamav (Ubuntu Maverick):
status: New → Fix Committed
Changed in clamav (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Scott Kitterman (kitterman) wrote :

Imre told me he had checked Lucid as well and it is fine. This bug never existed in Lucid, just in Lucid proposed.

tags: removed: verification-needed
Imre Gergely (cemc) wrote :

Exactly, I've tested on Lucid 64bit, and it seems to work fine.

Jean-Baptiste Lallement (jibel) wrote :

Thank you for testing, that's much appreciated.

Changed in karmic-backports:
status: New → Fix Released
Changed in hardy-backports:
status: New → Fix Released
Changed in jaunty-backports:
status: New → Fix Released
Changed in dapper-backports:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package clamav - 0.96.3+dfsg-2ubuntu2

---------------
clamav (0.96.3+dfsg-2ubuntu2) natty; urgency=low

  * PDF clamdscan crash fix (LP: #658341) - Cherry pick from Clamav git commit
    e142504b07d7f81435f6ac99ec1eedf6c08f2188, will be part of 0.96.4
 -- Scott Kitterman <email address hidden> Fri, 15 Oct 2010 08:13:38 -0400

Changed in clamav (Ubuntu Natty):
status: In Progress → Fix Released
Scott Kitterman (kitterman) wrote :

Marking Lucid fix released since this bug only ever existed in lucid-proposed for 10.04.

Changed in clamav (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in clamav (Ubuntu Maverick):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package clamav - 0.96.3+dfsg-2ubuntu1.1

---------------
clamav (0.96.3+dfsg-2ubuntu1.1) maverick-proposed; urgency=low

  * PDF clamdscan crash fix (LP: #658341) - Cherry pick from Clamav git commit
    e142504b07d7f81435f6ac99ec1eedf6c08f2188, will be part of 0.96.4
 -- Scott Kitterman <email address hidden> Sun, 10 Oct 2010 22:21:12 -0400

Changed in clamav (Ubuntu Maverick):
status: Fix Committed → Fix Released
Changed in clamav (Debian):
status: New → Fix Committed
Changed in clamav (Debian):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.