Ubuntu

clamd: can't initialize the internal logger

Reported by dino99 on 2010-03-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
clamav (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: clamav

Lucid B1 updated

just installed clamav-daemon and run it into console:

clamd:

ERROR: Can't open /var/log/clamav/clamav.log in append mode (check permissions!).
ERROR: Can't initialize the internal logger

ProblemType: Bug
Architecture: i386
Date: Fri Mar 19 14:01:37 2010
DistroRelease: Ubuntu 10.04
NonfreeKernelModules: nvidia
Package: clamav-daemon 0.96~rc1+dfsg-0ubuntu2
ProcEnviron:
 LANG=fr_FR.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic-pae
SourcePackage: clamav
Uname: Linux 2.6.32-16-generic-pae i686

dino99 (9d9) wrote :
Chuck Short (zulcss) wrote :

Can you attach the output of the following:

ls -alh /var/log/clamav/clamav.log

Thanks
chuck

Changed in clamav (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Scott Kitterman (kitterman) wrote :

This is not a bug. You are running clamd as your user and it does not have write permission in /var/log. You can change the logfile location in /etc/clamav/clams.conf or specify an alternative config file with the -c option.

Changed in clamav (Ubuntu):
importance: Low → Undecided
status: Incomplete → Invalid
dino99 (9d9) wrote :

looking at /var/log/clamav/

clamav.log exist and is owned by clamav, group adm ( -rw-r----- )
a freshclam.log is there too with the same rights

at first glance, i was thinking that it was because of the first time this command was run, but running a second time into console: clamd return the same error

i've checked that clamav group have admin enable, and still the same errors.

dino99 (9d9) wrote :
dino99 (9d9) wrote :
dino99 (9d9) wrote :

oem@dub:~$ ls -alh /var/log/clamav/clamav.log
-rw-r----- 1 clamav adm 1,3K 2010-03-19 14:00 /var/log/clamav/clamav.log

dino99 (9d9) wrote :

So, if it's not a bug, those errors are not welcome and are confusing. How to configure this daemon ?

Scott Kitterman (kitterman) wrote :

Did you actually read the text that came with the status change?

RaSca (rasca) wrote :

It's not a Clamav bug. It's an apparmor issue.
freshclam and clamd must be set in complain mode:

# aa-complain freshclam
Setting /etc/apparmor.d/usr.bin.freshclam to complain mode.

# aa-complain clamd
Setting /etc/apparmor.d/usr.sbin.clamd to complain mode.

In this way you can start your daemons without errors.

SeanBoran (sean-boran) wrote :

So apparmor is not correctly configured then? What apparmor config change is needed?

By settings into complain mode, presumably after a reboot, apparmor will log errors again?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers