clam-chordata: ftbfs with GCC-4.8

Bug #1171269 reported by Logan Rosen on 2013-04-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
clam-chordata (Debian)
Fix Released
Unknown
clam-chordata (Ubuntu)
High
Unassigned

Bug Description

Imported from Debian bug http://bugs.debian.org/701258:

Package: src:clam-chordata
Version: 1.0.0-2
Severity: important
Tags: sid jessie
User: <email address hidden>
Usertags: ftbfs-gcc-4.8

The package fails to build in a test rebuild on at least amd64 with
gcc-4.8/g++-4.8, but succeeds to build with gcc-4.7/g++-4.7. The
severity of this report may be raised before the jessie release.

  xtime.hxx:38:3: error: expected identifier before numeric constant

The full build log can be found at:
http://people.debian.org/~doko/logs-20130217/gcc48/clam-chordata_1.0.0-2_unstable_gcc48.log
The last lines of the build log are at the end of this report.

To build with GCC 4.8, either set CC=gcc-4.8 CXX=g++-4.8 explicitly,
or install the gcc, g++, gfortran, ... packages from experimental.

  apt-get -t experimental install g++ g++-4.7 g++-4.8 libc6-dev

The test rebuild was done with eglibc-2.17 and GCC-4.8, so some issues
might be caused by the updated glibc.

[...]
scons: Building targets ...
== Compiling interface src/MainWindow.ui
== Compiling C++ src/main.cxx
== Compiling C++ src/ChordataVersion.cxx
== Compiling C++ src/FloatVectorStorage.cxx
== Compiling C++ src/PoolSegmentationDataSource.cxx
== Compiling C++ src/FloatPairVectorStorage.cxx
== Compiling C++ src/PoolPeakDataSource.cxx
== Compiling interface src/About.ui
src/About.ui: Warning: The name 'tab' (QWidget) is already in use, defaulting to 'tab1'.
src/About.ui: Warning: The name 'TabPage' (QWidget) is already in use, defaulting to 'TabPage1'.
src/About.ui: Warning: An invalid icon property 'windowIcon' was encountered.
src/About.ui: Warning: An invalid pixmap property 'pixmap' was encountered.
src/About.ui: Warning: An invalid pixmap property 'pixmap' was encountered.
src/About.ui: Warning: An invalid pixmap property 'pixmap' was encountered.
src/About.ui: Warning: An invalid pixmap property 'pixmap' was encountered.
== Compiling C++ src/MainWindow.cxx
In file included from /usr/include/pthread.h:24:0,
                 from /usr/include/x86_64-linux-gnu/c++/4.8/bits/gthr-default.h:35,
                 from /usr/include/x86_64-linux-gnu/c++/4.8/bits/gthr.h:148,
                 from /usr/include/c++/4.8/ext/atomicity.h:33,
                 from /usr/include/c++/4.8/bits/ios_base.h:39,
                 from /usr/include/c++/4.8/ios:42,
                 from /usr/include/c++/4.8/ostream:38,
                 from /usr/include/c++/4.8/iterator:64,
                 from /usr/include/qt4/QtCore/qlist.h:50,
                 from /usr/include/qt4/QtCore/qvariant.h:47,
                 from /usr/include/qt4/QtCore/QVariant:1,
                 from src/generated/ui_MainWindow.hxx:13,
                 from src/MainWindow.hxx:20,
                 from src/MainWindow.cxx:17:
/usr/include/CLAM/xtime.hxx:38:3: error: expected identifier before numeric constant
   TIME_UTC=1,
   ^
/usr/include/CLAM/xtime.hxx:38:3: error: expected '}' before numeric constant
/usr/include/CLAM/xtime.hxx:38:3: error: expected unqualified-id before numeric constant
In file included from /usr/include/CLAM/Lock.hxx:26:0,
                 from /usr/include/CLAM/Mutex.hxx:26,
                 from /usr/include/CLAM/PortMonitor.hxx:6,
                 from /usr/include/CLAM/qtmonitors/PolarChromaPeaks.hxx:9,
                 from src/MainWindow.cxx:47:
/usr/include/CLAM/xtime.hxx:156:1: error: expected declaration before '}' token
 } // end of namespace CLAM
 ^
scons: *** [src/generated/MainWindow.o] Error 1
scons: building terminated because of errors.
make[1]: *** [override_dh_auto_build] Error 2
make[1]: Leaving directory `/«PKGBUILDDIR»'
make: *** [build-arch] Error 2
dpkg-buildpackage: error: debian/rules build-arch gave error exit status 2

Logan Rosen (logan) on 2013-04-22
Changed in clam-chordata (Ubuntu):
importance: Undecided → High
status: New → Triaged
tags: added: ftbfs
Changed in clam-chordata (Debian):
importance: Undecided → Unknown
Changed in clam-chordata (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.