Ubuntu

[12.04] citadel-server is producing errors every second in syslog (DB: not a restored transaction DB: PANIC: Invalid argument citadel: bdb(): PANIC: Invalid argument citadel: bdb(): txn_commit: DB_RUNRECOVERY: Fatal error, run database recover)

Reported by Michael Basse on 2012-01-04
50
This bug affects 10 people
Affects Status Importance Assigned to Milestone
citadel (Ubuntu)
Undecided
Unassigned

Bug Description

citael server (installed because of https://bugs.launchpad.net/ubuntu/+source/quilt/+bug/911631)

is producing this every second in syslog

Jan 4 07:35:18 eeebuntu citadel: DB: not a restored transaction
Jan 4 07:35:18 eeebuntu citadel: DB: PANIC: Invalid argument
Jan 4 07:35:18 eeebuntu citadel: bdb(): PANIC: Invalid argument
Jan 4 07:35:18 eeebuntu citadel: bdb(): txn_commit: DB_RUNRECOVERY: Fatal error, run database recover

the load of the system is 1.7 (2 cores)

also apport is running like crazy in top about that issue

steps to reproduce: just install citadel-server and restart.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: citadel-server 7.86-1
ProcVersionSignature: Ubuntu 3.2.0-7.13-generic 3.2.0-rc7
Uname: Linux 3.2.0-7-generic i686
ApportVersion: 1.90-0ubuntu1
Architecture: i386
Date: Wed Jan 4 13:23:49 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110426)
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: citadel
UpgradeStatus: Upgraded to precise on 2011-12-04 (31 days ago)
modified.conffile..etc.citadel.messages.aideopt: [deleted]
modified.conffile..etc.citadel.messages.changepw: [deleted]
modified.conffile..etc.citadel.messages.dotopt: [deleted]
modified.conffile..etc.citadel.messages.entermsg: [deleted]
modified.conffile..etc.citadel.messages.entopt: [deleted]
modified.conffile..etc.citadel.messages.goodbye: [deleted]
modified.conffile..etc.citadel.messages.hello: [deleted]
modified.conffile..etc.citadel.messages.help: [deleted]
modified.conffile..etc.citadel.messages.mainmenu: [deleted]
modified.conffile..etc.citadel.messages.newuser: [deleted]
modified.conffile..etc.citadel.messages.readopt: [deleted]
modified.conffile..etc.citadel.messages.register: [deleted]
modified.conffile..etc.citadel.messages.roomaccess: [deleted]
modified.conffile..etc.citadel.messages.unlisted: [deleted]

here is the log from apport

ERROR: apport (pid 24638) Wed Jan 4 13:29:55 2012: is_closing_session(): no DBUS_SESSION_BUS_ADDRESS in environment
ERROR: apport (pid 24638) Wed Jan 4 13:29:55 2012: apport: report /var/crash/_usr_sbin_citserver.0.crash already exists and unseen, doing nothing to avoid disk usage DoS

cant be reproduced on other systems, so i will mark it as "invalid"

Changed in citadel (Ubuntu):
status: New → Invalid

as it seems it was not my fault, found another person facing the same

Changed in citadel (Ubuntu):
status: Invalid → New
Tormod Volden (tormodvolden) wrote :

Seeing the same here on today's Precise. Whether or not quilt pulls it in, it should not blow up like this.

Changed in citadel (Ubuntu):
status: New → Confirmed
Ben64 (ben64) wrote :

I experienced the same in Precise. CPU usage was about 50% on each core on a dual core laptop. No application could actually show which process was using the CPU.

Jan 5 00:45:02 ben12 citadel: DB: not a restored transaction
Jan 5 00:45:02 ben12 citadel: DB: PANIC: Invalid argument
Jan 5 00:45:02 ben12 citadel: bdb(): PANIC: Invalid argument
Jan 5 00:45:02 ben12 citadel: bdb(): txn_commit: DB_RUNRECOVERY: Fatal error, run database recovery

putting ubuntu-sponsors on cc because the package citadel-server belongs to universe

Evan Broder (broder) wrote :

ubuntu-sponsors should only be subscribed to a bug once there's a patch or debdiff or some sort of fix that needs sponsorship; it's not for bugs that still need diagnosis. I'm going to unsubscribe the list.

Changed in citadel (Ubuntu):
status: Confirmed → Triaged
Jori Gel (jorigel) wrote :

 . . . running into the same problem on precise. So this still exists and happens in july.

Why are only a few users come across this error? Could it have something to do with the fact that I'm trying to use the host-authenticatuion?

Jori Gel (jorigel) wrote :

it's me again . . . so I had a closer look at the whole thing. I tried to install on two different hardware environments (different installations) and had no other reaction. Also the authentication-method doesn't make any difference. I cleaned up the data-base -> no reaction.

It is like one of my predecessors said: You run into the error as soon as You installed citadel on precise and start it.

Beside the upper error-messages in the syslog the webcit says it is not able to find or hold a connection to the citadel-server.

So @Michael Basse it is reproducible on other systems . . .

Deinstalling on ubuntu precise looks weired, because as far as I'm informed about it an <apt-get purge citadel-suite> is supposed to clean the system completely including configurations. Even an <apt-get autoremove> afterwards that wipes the software obviously doesn't clean totally, because a new installation after that is different to the first one. It don't ask for basic-configuration anymore. So there must be something kept.

Lukas Sabota (punkrockguy318) wrote :

I am able to reproduce this on a fresh Ubuntu 12.04 32bit installation running as a Xen guest. However, when performing the exact same installation procedure on Ubuntu 12.04 64bit (running as a Xen guest), citadel fails to run successfully. Webcit runs, but when accessing port 80 in a web browser I get the following error message:

This program was unable to connect or stay connected to the Citadel server. Please report this problem to your system administrator.Read More...

I've attached the "/var/crash/_usr_sbin_citserver.0.crash" file to this ticket. Let me know if I can be of further assistance in diagnosing and triaging this bug.

wirelessbit (romm) wrote :

This bug is also affecting my installation. It seems that one common factor is that all are fresh installs, or at least my was.

Sep 20 09:48:25 tckkeeper citadel: DB: PANIC: Invalid argument
Sep 20 09:48:25 tckkeeper citadel: bdb(): PANIC: Invalid argument
Sep 20 09:48:25 tckkeeper citadel: bdb(): txn_commit: DB_RUNRECOVERY: Fatal erro r, run database recovery
Sep 20 09:48:26 tckkeeper citadel: DB: not a restored transaction

That is what I am showing in /var/log/email.err log and on the WebCit I am getting:

This program was unable to connect or stay connected to the Citadel server. Please report this problem to your system administrator.Read More...

Intel i386

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu 12.04.1 LTS"

Citadel Installation:
sudo apt-get install citadel-suite

I am not sure about the version as I didn't notated the package release version but it should be the latest as the package it is installing using the universe repo. This issue can be reproduced by installing Citadel from the shell.

Is there any ETA on resolution or it would be recommendable to move a different email server package?

wirelessbit (romm) wrote :

@ Jori Gel:

Uninstalling the package using either:

sudo apt-get remove citadel-suite
sudo apt-get purge citadel-suite

It leave some config files behind. You will have to use the command:

whereis citadel

To find the left overs, I had couple of config files left in /etc that I had to go and delete manually in order to do a fresh install. Otherwise, as you mention, it will use those config files and bypass the first step in the configuration process that it is to collect pertinent information.

Robert Simmons (rsimmons0) wrote :

I'm unable to reproduce this bug with Kubuntu 12.10.

Rob van der Linde (robvdl) wrote :

Anyone have an ETA on this bug, because now I am forced to put 12.10 on my VPS, even though 12.04 is supposed to be an LTS release and I would much rather use that.

leogeo (lo-launchpad) wrote :

I am having the same issue,
Fresh install of Ubuntu 12.04.1 LTS on x86 arch.

Update packages: apt-get upgrade
Install Citalde: apt-get install citadel-suite
Listening address: 0.0.0.0
Authentication: Internal
Intergration with Apache webservers: Internal

Webcit says "This program was unable to connect or stay connected to the Citadel server. Please report this problem to your system administrator.Read More..."

var/log/syslog reports "DB: not a restored transaction DB: PANIC: Invalid argument citadel: bdb(): PANIC: Invalid argument citadel: bdb(): txn_commit: DB_RUNRECOVERY: Fatal error, run database recover"
over and over.

top shows that citserver is running.
top also shows that apport is running now.

Uninstall citadel as per: http://www.citadel.org/doku.php/faq:installation:how_do_i_uninstall_citadel
dpkg -r citadel-server citadel-webcit ...
dpkg --purge citadel-server citadel-webcit ...

Reinstall of citadel yeilds the Same results.

Simon-thum (simon-thum) wrote :

Wasted half the day on this! FWIW,

chown citadel.citadel -R /var/lib/citadel

works for me.

Simon-thum (simon-thum) wrote :

Sorry, not really. It successfully appeared to do so for some time and seems to be TRTTD.

Anyway, an interseting observation:

(root) citserver -D
...
DB: PANIC etc.

but

sudo -u citadel citserver -D

looks much better.

Simon-thum (simon-thum) wrote :

When additionally issuing

cd /etc/ssl
chown citadel.citadel -R webcit citadel

the beast growls more before it dies...

pablo Guzman (pguzman) wrote :

Hi to all , I work very hard triying to solve this problem. ifound this dirning my test :
If I intall it from sctach using ubuntu 12.04.1 32 bits and ubuntu repositories, I recieve the problem
If I install Ubuntu 32 from Scratch and then install Berceley DB (5.3.21) from oracle repositories and Citadel from UBuntu ones, the same problem is present.
If I install Ubuntu 32 from scratch and citadel from citaldel repositorie (curl http://easyinstall.citadel.org/install | bash) works well but have an issue when a user is created. If someone send a mail to the new user, comes back ot it rejected saying @newusername doesent exist as email user
I test installing it from scratch using Ubuntu 64 and works OK (in a VBox machine)
No idea where can i folow with the problem and is imposible for me install the 64 bit version
If is necesari i have the vbox machin with the Ubuntu 32 version having the problem to share.
I apreciate any help
regards!!!

Victor Bargoff (johnwu) wrote :

I am having exactly the same problem with errors:

Aug 9 13:02:28 preciseinfo citadel: DB: not a restored transaction
Aug 9 13:02:28 preciseinfo citadel: DB: PANIC: Invalid argument
Aug 9 13:02:28 preciseinfo citadel: bdb(): PANIC: Invalid argument
Aug 9 13:02:28 preciseinfo citadel: bdb(): txn_commit: DB_RUNRECOVERY: Fatal error, run database recovery

I tried to cleanup database. Didn't help.

I tried:

chown citadel.citadel -R /var/lib/citadel

- did not help, still crashing the same exact way

i tried:

sudo -u citadel citserver -D

get msg: in /var/log/syslog:
Aug 9 13:04:47 preciseinfo kernel: citserver[9722]: segfault at 93a1562c ip b75ae948 sp bfa34fd0 error 4 in libcrypto.so.1.0.0[b7542000+192000

Any help or pointer would be appreciated.

Victor Bargoff (johnwu) wrote :

Btw, anybody knows how to run the database recovery exctpt from examples directory?

I'd be willing to wipe out the entire database need be.

Is there any way to do the fresh install?

Victor Bargoff (johnwu) wrote :

The solution that works for me on ubuntu 12.04 is installing the citadel 8.14.
Everything installs and runs fine.

Installing citadel 8.14 on Ubuntu 12.04 LTS

Go to this page first:

http://packages.debian.org/wheezy/allpackages

Then you add these packages:
citadel-client, citadel-mta, citadel-server and citadel-webcit

You can download them to your PC in case this is how you are doing it, and then upload them to your host, making some subdirectory at your home dir for example.
Then, if we take citadel client package for example: http://packages.debian.org/wheezy/citadel-client, scroll down the web page and see the platform you are running and download that one.

Then just try to install that package. It will complain about dependencies.
So, scroll up that web page and download each of those deps one at at time and then trying to install the citadel client again.
If it complains that it is still missing some deps, do the same for those, each time trying to install the main package (citadel-client in our case).

Once the client is installed, go to the next major package on this page:
http://packages.debian.org/wheezy/allpackages

Then install citadel-mta for example
the same thing will happen with deps, so install them.

So you do the same thing with citadel-webcit and citadel-suite major packages, installing all the dependencies.
You should have total of 13 packages to download for citadel (but that depends on other things you have installed on your system).

To do the package (debian) installation do: (on ubuntu):

sudo dpkg -i citadel-webcit_8.14-dfsg-1_i386.deb

==========================

But some people say that this is a horrible idea because other things may break, if, for example, there is a security release for the Citadel.

Does anyone have any comments on this problem?

Victor Bargoff (johnwu) wrote :

You can also install Citadel 8.16 Ubuntu package(s) from this link:

http://packages.ubuntu.com/saucy/mail/citadel-suite

The same thing, install the following packages:

citadel-client
citadel-mta
citadel-server
citadel-webcit

It is verified to work on Ubuntu 12.04 LTS 32 bit.

The question now: will citadel 8.20 run on ubuntu 12.04?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers