[SRU Patch Available] Cinnamon custom keyboard shortcuts don't work until logout

Bug #1882375 reported by Daniel Pirch on 2020-06-06
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cinnamon (Ubuntu)
Status tracked in Groovy
Focal
Low
Joshua Peisach
Groovy
Low
Joshua Peisach

Bug Description

[Impact]

 * The users who manually set their own Keyboard Shortcuts will not have them applied until a full
 reset of Cinnamon occurs.
 * This can be very annoying and the code insertion is adding a reverse trigger to the custom list keybinding, and then adding a dummy string in case it can't (if there is only one keybind).

[Test Case]

 * The bug is simply reproducable by changing a Keyboard Shortcut and testing it. It will likely
 not work until you log out and log in again.

[Regression Potential]

 * Through this change it looks like there won't be any regression. Later on I will backport more
 patches added to cinnamon.

 * Two commits were made on this-another one was a revisit that fixed one so it looks like we are stable enough to not have to worry about regressions.

 * The updated version of this patch actually fixes a regression-we should be okay.

[Other Info]

 * Backporting patch from Linux Mint upstream, solved a few other issues
 * This is a FIXED patch to not mess up other patches and it also fixes a (probably) regression.
 * This is my 3rd attempt, fixed changelog and version

[Original Description]

Description: Ubuntu 20.04 LTS
Release: 20.04
cinnamon: 4.4.8-4
cinnamon-settings-daemon: 4.4.0-3

Steps to Reproduce:
- on Cinnamon desktop, run cinnamon-settings
- go to Keyboard > Shortcuts > Custom Shortcuts
- add a custom shortcut, or edit the command or shortcut of an existing custom shortcut

Expected behavior:
the shortcut should become active immediately

Actual behavior:
the shortcut does not work until you log out and log in again

This seems similar to bug #1243532, but I'm reporting this as a new bug now because it is cinnamon-specific. Other shortcuts (e.g. Close Window) are updated immediately, this only affects custom shortcuts. I think this bug appeared in 20.04.

Daniel Pirch (dpirch) on 2020-06-07
affects: gnome-settings-daemon (Ubuntu) → cinnamon (Ubuntu)
Daniel Pirch (dpirch) wrote :
Daniel Pirch (dpirch) wrote :

Fixed upstream in Cinnamon 4.6.6.

A workaround to not have to logout completely is to restart cinnamon via Alt+F2 > "r".

Joshua Peisach (itzswirlz) wrote :

I will SRU this and let you know when it's ready.

Changed in cinnamon (Ubuntu):
assignee: nobody → Joshua Peisach (itzswirlz)
status: New → Incomplete
status: Incomplete → In Progress
Changed in cinnamon (Ubuntu):
status: In Progress → Fix Committed
Joshua Peisach (itzswirlz) wrote :

A SRU is now available.

[Impact]

 * The users who manually set their own Keyboard Shortcuts will not have them applied until a full
 reset of Cinnamon occurs.
 * This can be very annoying and the code insertion is a line that will trigger Cinnamon to
 rebuild for the user.

[Test Case]

 * The bug is simply reproducable by changing a Keyboard Shortcut and testing it. It will likely
 not work until you log out and log in again.

[Regression Potential]

 * Through this change it looks like there won't be any regression. Later on I will backport more
 patches added to cinnamon.

 * Regression will probably happen, or will only happen later on when this version of Cinnamon becomes ancient.

[Other Info]

 * Backporting patch from Linux Mint upstream, solved a few other issues

Requesting sponsorship.

The attachment "1-4.4.8-4ubuntu1.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Joshua Peisach (itzswirlz) wrote :

The patch is actually a little broken and causes a small regression... so I'll be fixing the patch. I also messed up other patches in the process so I will fix it

Joshua Peisach (itzswirlz) wrote :

[Impact]

 * The users who manually set their own Keyboard Shortcuts will not have them applied until a full
 reset of Cinnamon occurs.
 * This can be very annoying and the code insertion is a line that will trigger Cinnamon to
 rebuild for the user.

[Test Case]

 * The bug is simply reproducable by changing a Keyboard Shortcut and testing it. It will likely
 not work until you log out and log in again.

[Regression Potential]

 * Through this change it looks like there won't be any regression. Later on I will backport more
 patches added to cinnamon.

 * Regression will EVENTUALLY probably happen, or will only happen later on when this version of Cinnamon becomes ancient, but not in the anytime future

 * The updated version of this patch actually fixes a regression-we should be okay.

[Other Info]

 * Backporting patch from Linux Mint upstream, solved a few other issues
 * This is a FIXED patch to not mess up other patches and it also fixes a (probably) regression.

Requesting sponsorship.

Joshua Peisach (itzswirlz) wrote :

I love when I mess up the versions. I fixed it and another small issue

SRU template is the same (mostly)

[Impact]

 * The users who manually set their own Keyboard Shortcuts will not have them applied until a full
 reset of Cinnamon occurs.
 * This can be very annoying and the code insertion is adding a reverse trigger to the custom list keybinding, and then adding a dummy string in case it can't (if there is only one keybind).

[Test Case]

 * The bug is simply reproducable by changing a Keyboard Shortcut and testing it. It will likely
 not work until you log out and log in again.

[Regression Potential]

 * Through this change it looks like there won't be any regression. Later on I will backport more
 patches added to cinnamon.

 * Two commits were made on this-another one was a revisit that fixed one so it looks like we are stable enough to not have to worry about regressions.

 * The updated version of this patch actually fixes a regression-we should be okay.

[Other Info]

 * Backporting patch from Linux Mint upstream, solved a few other issues
 * This is a FIXED patch to not mess up other patches and it also fixes a (probably) regression.
 * This is my 3rd attempt, fixed changelog and version

Mathew Hodson (mhodson) on 2020-07-30
Changed in cinnamon (Ubuntu):
importance: Undecided → Low
tags: added: sru
Joshua Peisach (itzswirlz) wrote :

Fix was released in 20.10 groovy-need to mark it for 20.04

Changed in cinnamon (Ubuntu):
status: Fix Committed → Fix Released
Rik Mills (rikmills) on 2020-09-01
Changed in cinnamon (Ubuntu):
status: Fix Released → Triaged
Changed in cinnamon (Ubuntu Groovy):
status: Triaged → Fix Released
Changed in cinnamon (Ubuntu Focal):
assignee: nobody → Joshua Peisach (itzswirlz)
status: New → In Progress
summary: - Cinnamon custom keyboard shortcuts don't work until logout
+ [SRU Patch Available] Cinnamon custom keyboard shortcuts don't work
+ until logout
description: updated
Łukasz Zemczak (sil2100) wrote :

Usually we try to only consider SRUs for issues that have a high impact on users, as every SRU can potentially introduce regressions. Usually we wait to bunch up more changes in one SRU for lower priority changes too - but seeing that cinnamon doesn't have much movement from the SRU POV, I think we can just do it.

Anyway, I think it's good to go as an SRU. With my SRU-member hat on though, I'd like you to work a bit more on the Regression Potential field. Since as-is, the information there is not enough and the SRU might get rejected during review in the queue.

Could you do an exercise of looking at the change and trying to think: "if there's a bug in this code modification, what could potentially break?". This field is quite crucial to our SRU process, because it gives additional context on which things could be tested 'just to be sure' to check if there are regressions - and if there are regressions, it's easier to identify which change might have caused it. Could you write up something like that?

I could sponsor the package for you right now, but I'd prefer for us to have all the paperwork 'shiny'! Please poke me once this is done. Thanks!

Mathew Hodson (mhodson) on 2020-10-03
Changed in cinnamon (Ubuntu Focal):
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.