Request for including an upstream fix for emc vnx volume driver (Newton)

Bug #1677982 reported by Denny Zhao on 2017-03-31
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cinder (Ubuntu)
Undecided
Unassigned
Yakkety
Undecided
Unassigned
Zesty
Undecided
Unassigned

Bug Description

Issue:

Detaching a volume from a nova instance sometimes not removing it from VNX storage group. It is caused by out-of-date cache for in VNX volume driver. Cache needs to be updated with correct info after creating a storage group.
This fix was applied to Ocata and back ported to Newton upstream:
https://review.openstack.org/#/c/429439/
This ticket is a request for merge the upstream fix above to Ubuntu 16.10 (Newton package).

How to Reproduce:
1.Detach a volume from nova instance
2.Use nova and cinder command to confirm the volume is detached.
3.Use NaviSecCli to confirm the LUN is removed from the corresponding storage group.

Actual results:
The LUN is still in the Storage Group after detaching.

Expected results:
The LUN is removed from the Storage Group after detaching.

Chuck Short (zulcss) wrote :

Hi,

Thanks for the bug report this looks resonable to me for a future SRU point release into Ubuntu.

chuck

tags: added: openstack-sru
Changed in cinder (Ubuntu Zesty):
status: New → Fix Released
Changed in cinder (Ubuntu Yakkety):
status: New → Fix Committed

Hello Denny, or anyone else affected,

Accepted cinder into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cinder/2:9.1.4-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Denny Zhao (denny-zhao) wrote :

Thanks for taking this fix. Since a lot of customers are using xenial release. Is it possible to backport this fix to 16.04 as well? Thanks.

James Page (james-page) wrote :

This bug is still pending verification for yakkety (and the Ubuntu Cloud Archive for Newton).

Denny Zhao (denny-zhao) wrote :

Sorry for the delayed response and thanks for the reminder. I will try to verify it this week.
If the fix is merged, is there a way for 16.04 customer to apply this fix on their system?

James Page (james-page) wrote :

@Denny

The fix is in the Cloud Archive for Ocata which targets 16.04; if this is required in Mitaka, then we'll have to look at cherry-picking the fix back to that series as well (not currently in scope for this bug).

Denny Zhao (denny-zhao) wrote :

This fix has been verified in EMC's test environment on 16.04. Thanks.

tags: added: verification-done
removed: verification-needed
Denny Zhao (denny-zhao) wrote :

The package tested is cinder_9.1.5.

tags: added: verification-needed
removed: verification-done
James Page (james-page) wrote :

@Denny

This bug needs to be verified on Ubuntu Yakkety and Ubuntu Xenial using the packages in the proposed pocket as described in #2.

Brian Murray (brian-murray) wrote :

Given that bug 1688557 is about a point release update of packages in OpenStack Newton and that James Page indicates that the fix for this bug is included in cinder 9.1.4, were this bug not explicitly referenced in the changelog this fix would have been released given the testing in bug 1688557.

Subsequently, even though the verification for this specific bug was not completed, the release and package version tested do not match the release task here, I am going to go ahead and release cinder to -updates.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cinder - 2:9.1.4-0ubuntu1

---------------
cinder (2:9.1.4-0ubuntu1) yakkety; urgency=medium

  [ Chuck Short ]
  * d/p/fix-emx-driver.patch: VNX: Update sg cache if it already existed.
    (LP: #1677982)

  [ Corey Bryant ]
  * New upstream point release for OpenStack Newton (LP: #1688557).
  * d/p/fix-emx-driver.patch: Dropped. Included in upstream point release.

 -- Corey Bryant <email address hidden> Fri, 05 May 2017 15:06:45 -0400

Changed in cinder (Ubuntu Yakkety):
status: Fix Committed → Fix Released
James Page (james-page) wrote :

Thanks Brian!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers