[SRU] liberty point releases

Bug #1530913 reported by James Page on 2016-01-04
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ceilometer (Ubuntu)
Undecided
Unassigned
Wily
Undecided
Unassigned
cinder (Ubuntu)
Undecided
Unassigned
Wily
Undecided
Unassigned
glance (Ubuntu)
Undecided
Unassigned
Wily
Undecided
Unassigned
heat (Ubuntu)
Undecided
Unassigned
Wily
Undecided
Unassigned
horizon (Ubuntu)
Undecided
Unassigned
Wily
Undecided
Unassigned
keystone (Ubuntu)
Undecided
Unassigned
Wily
Undecided
Unassigned
neutron (Ubuntu)
Undecided
Unassigned
Wily
Undecided
Unassigned
nova (Ubuntu)
Undecided
Unassigned
Wily
Undecided
Unassigned

Bug Description

New point releases for misc openstack components for the liberty release:

ceilometer 5.0.1
glance 11.0.1
keystone 8.0.1
neutron 7.0.1
nova 12.0.1
cinder 7.0.1

James Page (james-page) on 2016-01-04
no longer affects: ceilometer (Ubuntu Xenial)
no longer affects: cinder (Ubuntu Xenial)
no longer affects: glance (Ubuntu Xenial)
no longer affects: keystone (Ubuntu Xenial)
no longer affects: neutron (Ubuntu Xenial)
no longer affects: nova (Ubuntu Xenial)
Changed in ceilometer (Ubuntu):
status: New → Invalid
James Page (james-page) wrote :

No nova point release as yet.

Changed in cinder (Ubuntu):
status: New → Invalid
Changed in glance (Ubuntu):
status: New → Invalid
Changed in keystone (Ubuntu):
status: New → Invalid
Changed in neutron (Ubuntu):
status: New → Invalid
Changed in nova (Ubuntu):
status: New → Invalid
James Page (james-page) wrote :

Uploads in proposed for all packages apart from nova, which appears to be lagging on release upstream; I've cherry picked a critical fix for nova under a different bug, we'll follow up with that later.

description: updated
Brian Murray (brian-murray) wrote :

Closing the nova task for now.

Changed in nova (Ubuntu Wily):
status: New → Won't Fix
Changed in ceilometer (Ubuntu Wily):
status: New → Fix Committed
tags: added: verification-needed

Hello James, or anyone else affected,

Accepted ceilometer into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ceilometer/1:5.0.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in cinder (Ubuntu Wily):
status: New → Fix Committed
Brian Murray (brian-murray) wrote :

Hello James, or anyone else affected,

Accepted cinder into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cinder/2:7.0.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in glance (Ubuntu Wily):
status: New → Fix Committed
Brian Murray (brian-murray) wrote :

Hello James, or anyone else affected,

Accepted glance into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/glance/2:11.0.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Brian Murray (brian-murray) wrote :

Hello James, or anyone else affected,

Accepted neutron into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/neutron/2:7.0.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in neutron (Ubuntu Wily):
status: New → Fix Committed
Brian Murray (brian-murray) wrote :

Hello James, or anyone else affected,

Accepted keystone into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/keystone/2:8.0.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in keystone (Ubuntu Wily):
status: New → Fix Committed
Changed in heat (Ubuntu):
status: New → Invalid
Changed in heat (Ubuntu Wily):
status: New → In Progress
Changed in nova (Ubuntu Wily):
status: Won't Fix → In Progress
Changed in nova (Ubuntu Wily):
status: In Progress → Fix Committed
Chris J Arges (arges) wrote :

Hello James, or anyone else affected,

Accepted heat into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/heat/1:5.0.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in heat (Ubuntu Wily):
status: In Progress → Fix Committed
Chris J Arges (arges) wrote :

Hello James, or anyone else affected,

Accepted nova into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nova/2:12.0.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ceilometer (Ubuntu Wily):
milestone: none → wily-updates
Changed in cinder (Ubuntu Wily):
milestone: none → wily-updates
Changed in glance (Ubuntu Wily):
milestone: none → wily-updates
Changed in heat (Ubuntu Wily):
milestone: none → wily-updates
Changed in keystone (Ubuntu Wily):
milestone: none → wily-updates
Changed in neutron (Ubuntu Wily):
milestone: none → wily-updates
Changed in nova (Ubuntu Wily):
milestone: none → wily-updates
Corey Bryant (corey.bryant) wrote :

Hello Chris,

The packages in this SRU have been verified and are ready for promotion.

Thanks!
Corey

tags: added: verification-done
removed: verification-needed
Brian Murray (brian-murray) wrote :

It looks like there are some regressions in the autopackagetests though.

http://autopkgtest.ubuntu.com/packages/n/neutron/wily/armhf/

Bryan Quigley (bryanquigley) wrote :

Will the autopackagetests failing block it moving to updates?

James Page (james-page) wrote :

Brian

One of those tests is notoriously racy (so not a regression per say) - you can see that the same test passed on the next run - as this is on armhf, which is not a core target for OpenStack, I'd like not to hold back the release of this SRU into Wily.

Bryan - for the UCA I've moved all of these updates apart from Neutron to updates already. Neutron required a bit more poking due to a build failure prior to testing meaning that we verified the other components against neutron 7.0.0 - this should be resolved shortly.

Changed in horizon (Ubuntu):
status: New → Invalid
Changed in horizon (Ubuntu Wily):
status: New → In Progress
milestone: none → wily-updates
Chris J Arges (arges) wrote :

Hello James, or anyone else affected,

Accepted horizon into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/horizon/2:8.0.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in horizon (Ubuntu Wily):
status: In Progress → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

After a rerun the neutron test did pass, so releasing that package.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package neutron - 2:7.0.1-0ubuntu1

---------------
neutron (2:7.0.1-0ubuntu1) wily; urgency=medium

  [ Corey Bryant ]
  * d/tests/neutron-agents: Give daemon 5 seconds to start to prevent race.

  [ James Page ]
  * New upstream point release (LP: #1530913).

 -- James Page <email address hidden> Thu, 07 Jan 2016 12:03:11 +0000

Changed in neutron (Ubuntu Wily):
status: Fix Committed → Fix Released
James Page (james-page) on 2016-02-19
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glance - 2:11.0.1-0ubuntu1

---------------
glance (2:11.0.1-0ubuntu1) wily; urgency=medium

  [ Corey Bryant ]
  * d/tests/glance-daemons: Give daemon 5 seconds to start to prevent race.

  [ James Page ]
  * New upstream point release for OpenStack Liberty (LP: #1530913).

 -- James Page <email address hidden> Thu, 07 Jan 2016 11:59:49 +0000

Changed in glance (Ubuntu Wily):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for glance has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cinder - 2:7.0.1-0ubuntu1

---------------
cinder (2:7.0.1-0ubuntu1) wily; urgency=medium

  * New upstream point release for OpenStack Liberty (LP: #1530913):
    - d/p/lp1516085.patch: Dropped, included upstream.

 -- James Page <email address hidden> Thu, 07 Jan 2016 11:57:52 +0000

Changed in cinder (Ubuntu Wily):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package keystone - 2:8.0.1-0ubuntu1

---------------
keystone (2:8.0.1-0ubuntu1) wily; urgency=medium

  * New upstream point release for OpenStack Liberty (LP: #1530913).

 -- James Page <email address hidden> Thu, 07 Jan 2016 12:02:10 +0000

Changed in keystone (Ubuntu Wily):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nova - 2:12.0.1-0ubuntu1

---------------
nova (2:12.0.1-0ubuntu1) wily; urgency=medium

  * New upstream point release for OpenStack Liberty (LP: #1530913):
    - d/p/lp1508230.patch: Dropped. Fixed upstream.

 -- Corey Bryant <email address hidden> Thu, 21 Jan 2016 11:02:52 -0500

Changed in nova (Ubuntu Wily):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package heat - 1:5.0.1-0ubuntu1

---------------
heat (1:5.0.1-0ubuntu1) wily; urgency=medium

  * New upstream point release for OpenStack Liberty (LP: #1530913):
    - d/control: Add python-testresources to build-depends.
    - d/p/skip-online-tests: Skip tests that require network
      connectivity during Ubuntu package builds.
    - d/p/revert_endpoint_override.patch: Revert test update that would
      require new version of python-magnumclient.

 -- Corey Bryant <email address hidden> Thu, 21 Jan 2016 12:34:57 -0500

Changed in heat (Ubuntu Wily):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package horizon - 2:8.0.1-0ubuntu1

---------------
horizon (2:8.0.1-0ubuntu1) wily; urgency=medium

  * New upstream point release for OpenStack Liberty (LP: #1530913).

 -- Corey Bryant <email address hidden> Tue, 09 Feb 2016 10:19:12 -0500

Changed in horizon (Ubuntu Wily):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers