python-cinder has a dependency on python-glance, this is no longer required

Bug #1175600 reported by Cian O'Driscoll on 2013-05-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cinder (Ubuntu)
Low
James Page
Saucy
Low
James Page

Bug Description

the code packaged in python-cinder no longer imports anything from glance. It now only uses glanceclient.
The dependency on python-glance should be removed from python-cinder

Related branches

James Page (james-page) on 2013-05-03
Changed in cinder (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in cinder (Ubuntu Saucy):
assignee: nobody → James Page (james-page)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cinder - 1:2013.2~b1-0ubuntu1

---------------
cinder (1:2013.2~b1-0ubuntu1) saucy; urgency=low

  [ Chuck Short ]
  * New upstream version.
  * debian/patches/fix_cinder_dependencies.patch: Dropped.
  * debian/control: Bump standards version to 3.9.4.
  * debian/control: Add python-pbr and python-d2to1 to build-depends.
  * debian/control: Add python-testtools and python-fixtures to build-depends
  * debian/rules: Add work around to remove wonky setup.py setup
  * debian/cinder-common.install: Add cinder-rpc-zmq-receiver binary.

  [ James Page ]
  * debian/control: Drop surplus dependency on python-glance (LP: #1175600).
  * debian/control,rules: Drop dependency on pep8, don't run pep8 tests during
    package build process (its just way to late).
  * debian/control: Drop surplus BD on python-cheetah.

  [ Adam Gandelman ]
  * debian/patches/avoid_paramiko_vers_depends.patch: Avoid version
    requirement on paramiko.
 -- Chuck Short <email address hidden> Fri, 31 May 2013 10:01:03 -0500

Changed in cinder (Ubuntu Saucy):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers