cinder-common fails to install

Bug #1036240 reported by Jamie Strandboge on 2012-08-13
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
cinder (Ubuntu)
High
Unassigned

Bug Description

$ sudo apt-get install python-cinder
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  cinder-api cinder-common cinder-scheduler cinder-volume
The following packages will be upgraded:
  cinder-api cinder-common cinder-scheduler cinder-volume python-cinder
5 upgraded, 0 newly installed, 0 to remove and 99 not upgraded.
Need to get 1,027 kB of archives.
After this operation, 358 kB disk space will be freed.
Do you want to continue [Y/n]? y
Get:1 http://debmirror.strandboge.com/ubuntu/ quantal/universe cinder-volume all 2012.2~f3~20120809.102-0ubuntu1 [3,450 B]
Get:2 http://debmirror.strandboge.com/ubuntu/ quantal/universe cinder-scheduler all 2012.2~f3~20120809.102-0ubuntu1 [3,650 B]
Get:3 http://debmirror.strandboge.com/ubuntu/ quantal/universe cinder-api all 2012.2~f3~20120809.102-0ubuntu1 [3,336 B]
Get:4 http://debmirror.strandboge.com/ubuntu/ quantal/universe cinder-common all 2012.2~f3~20120809.102-0ubuntu1 [11.1 kB]
Get:5 http://debmirror.strandboge.com/ubuntu/ quantal/universe python-cinder all 2012.2~f3~20120809.102-0ubuntu1 [1,006 kB]
Fetched 1,027 kB in 0s (10.2 MB/s)
(Reading database ... 78874 files and directories currently installed.)
Preparing to replace cinder-volume 2012.2~f1~20120503.2-0ubuntu1 (using .../cinder-volume_2012.2~f3~20120809.102-0ubuntu1_all.deb) ...
initctl: Unknown job: cinder-volume
Unpacking replacement cinder-volume ...
Preparing to replace cinder-scheduler 2012.2~f1~20120503.2-0ubuntu1 (using .../cinder-scheduler_2012.2~f3~20120809.102-0ubuntu1_all.deb) ...
initctl: Unknown job: cinder-scheduler
Unpacking replacement cinder-scheduler ...
Preparing to replace cinder-api 2012.2~f1~20120503.2-0ubuntu1 (using .../cinder-api_2012.2~f3~20120809.102-0ubuntu1_all.deb) ...
initctl: Unknown job: cinder-api
Unpacking replacement cinder-api ...
Preparing to replace cinder-common 2012.2~f1~20120503.2-0ubuntu1 (using .../cinder-common_2012.2~f3~20120809.102-0ubuntu1_all.deb) ...
Unpacking replacement cinder-common ...
Preparing to replace python-cinder 2012.2~f1~20120503.2-0ubuntu1 (using .../python-cinder_2012.2~f3~20120809.102-0ubuntu1_all.deb) ...
Unpacking replacement python-cinder ...
Processing triggers for man-db ...
Processing triggers for ureadahead ...
ureadahead will be reprofiled on next reboot
Setting up python-cinder (2012.2~f3~20120809.102-0ubuntu1) ...
Setting up cinder-common (2012.2~f3~20120809.102-0ubuntu1) ...
Installing new version of config file /etc/cinder/cinder.conf ...
Installing new version of config file /etc/cinder/policy.json ...
Adding system user `cinder' (UID 116) ...
Adding new user `cinder' (UID 116) with group `cinder' ...
Not creating home directory `/var/lib/cinder'.
The root_helper option (which lets you specify a root wrapper different from cinder-rootwrap, and defaults to using sudo) is now deprecated. You should use the rootwrap_config option instead.
2012-08-13 10:09:06 DEBUG cinder.utils [-] backend <module 'cinder.db.sqlalchemy.migration' from '/usr/lib/python2.7/dist-packages/cinder/db/sqlalchemy/migration.pyc'> from (pid=3216) __get_backend /usr/lib/python2.7/dist-packages/cinder/utils.py:516
Command failed, please check log for more info
dpkg: error processing cinder-common (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of cinder-volume:
 cinder-volume depends on cinder-common (= 2012.2~f3~20120809.102-0ubuntu1); however:
  Package cinder-common is not configured yet.

dpkg: error processing cinder-volume (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of cinder-scheduler:
 cinder-scheduler depends on cinder-common (= 2012.2~f3~20120809.102-0ubuntu1); however:
  Package cinder-common is not configured yet.

dpkg: error processing cinder-scheduler (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of cinder-api:
 cinder-api depends on cinder-common (= 2012.2~f3~20120809.102-0ubuntu1); however:
  Package cinder-common is not configured yet.

dpkg: error processing cinder-api (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 cinder-common
 cinder-volume
 cinder-scheduler
 cinder-api
E: Sub-process /usr/bin/dpkg returned an error code (1)

Changed in cinder (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cinder - 2012.2~f3~20120809.102-0ubuntu2

---------------
cinder (2012.2~f3~20120809.102-0ubuntu2) quantal; urgency=low

  * debian/cinder.conf, cinder-common.install: Use rootwrap.conf. (LP: #1036240)
  * debian/control: Drop python-babel.
 -- Chuck Short <email address hidden> Mon, 13 Aug 2012 14:14:31 -0500

Changed in cinder (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers