Mounting CIFS share intermittent failure (CIFS error code -5)

Bug #1430259 reported by Kelvin Middleton on 2015-03-10
50
This bug affects 9 people
Affects Status Importance Assigned to Milestone
cifs-utils (Ubuntu)
Undecided
Unassigned

Bug Description

I run a samba server on an Ubuntu 14.10 host and have several ubuntu clients as VM as well as separate device for media streaming. On reboot for the VM's and media streamer sometimes the samba share connects without issue, sometimes it errors. In all cases I can reconnect the share with a manual mount command or a 'mount -a'.

Server process log never shows any errors, server client process logs never show error, only errors through are on the client which are either in dmesg output...

Status code returned 0xc0000001 NT_STATUS_UNSUCCESSFUL
CIFS VFS: Send error in SessSetup = -5
CIFS VFS: cifs_mount failed w/return code = -5

or on the cli directly after the mount command...

mount error(5): Input/output error
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I've had this issue for many months and believed it to be a bad config somewhere as I could never find many other people with the similar symptoms (google). Today I've found a bug report on debian (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=746229) with the same problems.

I've tried lots of different parameters for the mount command to see if any generate a different error or less frequent error but cannot see any differents. My current mount command for a VM which demonstrates persistent issues is...

//blackserver.273below.co.uk/share /mnt/share cifs username=XXXXX,password=XXXXX,sec=ntlm,hard 0 0

I've tried appending workgroup parameters into the mount etc and nothing seems to resolve.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: cifs-utils 2:6.0-1ubuntu2
ProcVersionSignature: Ubuntu 3.13.0-46.77-generic 3.13.11-ckt15
Uname: Linux 3.13.0-46-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.7
Architecture: amd64
Date: Tue Mar 10 11:06:04 2015
InstallationDate: Installed on 2014-09-18 (172 days ago)
InstallationMedia: Ubuntu-Server 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.3)
SourcePackage: cifs-utils
UpgradeStatus: No upgrade log present (probably fresh install)

summary: - Mounting CIFS share intermittent failure
+ Mounting CIFS share intermittent failure (CIFS error code -5)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cifs-utils (Ubuntu):
status: New → Confirmed
Stephen Arnold (stephen-2) wrote :

I have the same error messages on 15.04 clients running against a 15.04 server. All have been upgraded through earlier releases. I first noticed the problem in 14.10.

As per the Debian bug report, stopping winbind on the server is a workaround in a simple SOHO type environment that has worked for me.

Carlos Damken (carlos-damken) wrote :

Same error with 16.04, fresh installed and up2date.

2 moths worked without problem and does not work anymore.

WM in a QNAP server.

same as Stephen commended, removing the winbind works for me as workaround.

Alexander Fieroch (fieroch) wrote :

Hi, I have the same problem with 16.04 and 17.10 but unfortunately I do not use winbind which I could remove as a workaround. I joined my PCs to AD using realm and SSSD, so no winbind is installed.
Does anyone know another workaround? Maybe you did not uninstall only winbind but a broken library too, which I could try to remove?

KaiLuo (luokai1103) wrote :

Same error message. My laptop is running Ubuntu 16.04. It worked before but suddenly stopped working after running updates. The same setup of fstab in other linux distros works.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers