ciborium crashes on rc-proposed

Bug #1592421 reported by Jean-Baptiste Lallement
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Fix Released
Critical
Pat McGowan
ciborium (Ubuntu)
Fix Released
Critical
Larry Price

Bug Description

current build number: 357
device name: krillin
channel: ubuntu-touch/rc-proposed/bq-aquaris.en

Just start the disk utility, there is a spinner then it crashes

https://errors.ubuntu.com/oops/90936874-3235-11e6-b825-fa163e30221b

Related branches

Changed in canonical-devices-system-image:
importance: Undecided → Critical
milestone: none → 12
tags: added: lt-blocker regression-proposed
Changed in canonical-devices-system-image:
status: New → Confirmed
assignee: nobody → Pat McGowan (pat-mcgowan)
summary: - cibrorium crashes on rc-proposed
+ ciborium crashes on rc-proposed
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ciborium (Ubuntu):
status: New → Confirmed
Stephen M. Webb (bregma)
Changed in ciborium (Ubuntu):
assignee: nobody → Larry Price (larryprice)
Revision history for this message
Larry Price (larryprice) wrote :

Not a lot to go off in that whoopsie log. After a short debugging session, I believe this is caused by the upgrade to go 1.6 and the following error:

panic: runtime error: cgo argument has Go pointer to Go pointer

Which is an error because the garbage collector won't be able to deal with that situation. A temporary fix is to set the environment variables GODEBUG=cgocheck=0, but this is just a workaround for whatever situation we've gotten ourselves in. I'll see if I can chase down where we are passing this go pointer illegally.

Revision history for this message
Larry Price (larryprice) wrote :

Some more digging and I found this bug in go-qml: https://github.com/go-qml/qml/issues/170. I'll try pulling in the branch to see if that fixes things.

Stephen M. Webb (bregma)
Changed in ciborium (Ubuntu):
importance: Undecided → Critical
status: Confirmed → Triaged
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in ciborium (Ubuntu):
status: Triaged → In Progress
Rex Tsai (chihchun)
tags: added: ydt2307
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ciborium - 0.2.12+16.10.20160618-0ubuntu1

---------------
ciborium (0.2.12+16.10.20160618-0ubuntu1) yakkety; urgency=medium

  [ Larry Price ]
  * Fix crash on startup hopefully related to bug #1592421. (LP:
    #1592421)

 -- <email address hidden> (Stephen M. Webb) Sat, 18 Jun 2016 23:07:25 +0000

Changed in ciborium (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers