Chromium unsets preferred webbrowser

Bug #902661 reported by Maarten Jacobs on 2011-12-11
38
This bug affects 9 people
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
Undecided
Unassigned

Bug Description

I'm running XUbuntu 11.10 (actually Ubuntu 11.10 with the xubuntu packages installed on top).

When I select Chromium to be my preferred web browser from settings->setting manager->preferred application, Chromium will be launched when I select Web Browser from the main pull-down menu.

However, when Chromium starts, it produces a message stating "Chromium is not your default browser" (or words of that nature). When I select "yes", and then reopen preferred applications, Chromium is no longer selected as the default web browser.

It would seem that Chromium doesn't understand how to interpret the default settings in xfce4 - or muddles them up when it tries to make itself the default browser.

The work-around is easy - tell Chromium not to ask anymore, and don't allow it to set itself as the default browser (use preferred applications instead to select the preferred browser).

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: chromium-browser 15.0.874.106~r107270-0ubuntu0.11.10.1
ProcVersionSignature: Ubuntu 3.0.0-13.22-generic 3.0.6
Uname: Linux 3.0.0-13-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Sat Dec 10 19:44:50 2011
Desktop-Session:
 DESKTOP_SESSION = xubuntu
 XDG_CONFIG_DIRS = /etc/xdg/xdg-xubuntu:/etc/xdg:/etc/xdg
 XDG_DATA_DIRS = /usr/share/xubuntu:/usr/local/share/:/usr/share/:/usr/share
Env:
 MOZ_PLUGIN_PATH = None
 LD_LIBRARY_PATH = None
ExecutablePath: /usr/lib/chromium-browser/chromium-browser
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
ProcEnviron:

SourcePackage: chromium-browser
UpgradeStatus: Upgraded to oneiric on 2011-12-03 (7 days ago)
chromium-default: CHROMIUM_FLAGS=""

Maarten Jacobs (maarten256) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in chromium-browser (Ubuntu):
status: New → Confirmed
Joshua O'Leary (jmoleary) wrote :

This probably down to the fact that the Xubuntu Settings Manager sets xfconf values, whereas chromium uses gconf settings, which of course may not even be present in Xubuntu since it is not gnome-based.

Dolph Mathews (dolph) wrote :

Another discussion of this issue: http://askubuntu.com/a/628111/22414

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers