Ubuntu

chromium doesn't see system proxy config

Reported by seraus on 2011-09-24
84
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Chromium Browser
Unknown
Unknown
chromium-browser (Ubuntu)
High
Unassigned

Bug Description

Hello,

I upgraded my ubuntu 11.04 to the latest 11.10 beta and installed mozilla and chromium yesterday. I need to use a http proxy at work: no problem with Mozilla (preferences-->proxy settings) but Chromium doesn't seem to see the proxy settings defined from gnome-shell -->network settings -->networkproxy. In the gconf tree settings seem OK.
Any other way to set the proxy for chromium?

Thanks, bye

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: chromium-browser 13.0.782.215~r97094-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic i686
ApportVersion: 1.23-0ubuntu1
Architecture: i386
Date: Sat Sep 24 16:13:51 2011
Desktop-Session:
 DESKTOP_SESSION = gnome-shell
 XDG_CONFIG_DIRS = /etc/xdg/xdg-gnome-shell:/etc/xdg
 XDG_DATA_DIRS = /usr/share/gnome-shell:/usr/share/gnome:/usr/local/share/:/usr/share/
Env:
 MOZ_PLUGIN_PATH = None
 LD_LIBRARY_PATH = None
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Release i386 (20100429.4)
ProcEnviron:
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: chromium-browser
UpgradeStatus: Upgraded to oneiric on 2011-09-24 (0 days ago)
chromium-default: CHROMIUM_FLAGS=""

seraus (seraus) wrote :
Reinhard Tartler (siretart) wrote :

I can confirm this bug. It has been reported upstream as well here:
http://code.google.com/p/chromium/issues/detail?id=80453

It seems that chromium in oneric opens the gnome3 proxy settings, which sets the knobs in "gsettings", but reacts only to the old 'gconf' settings. You can change the proxy settings in gconf manually with gconf-editor. See this blogpost for explanation how:
http://www.gnomeshell.com/2011/04/29/old-network-proxy-settings-not-working-in-gnome3/

Changed in chromium-browser (Ubuntu):
importance: Undecided → High
status: New → Triaged
Andrey Zaytsev (andzaytsev) wrote :

The same under Ubuntu 11.10 Release.
Desktop - Unity.

Changed in chromium-browser (Ubuntu):
status: Triaged → Confirmed
Reinhard Tartler (siretart) wrote :

andrey, please do not 'downgrade' bugs from triaged to confirmed without explanation.

Changed in chromium-browser (Ubuntu):
status: Confirmed → Triaged
Bogdan Vasiliev (b-vasiliev) wrote :

'http_proxy' enviroment and '--proxy-server' option are ignored as well.

jkyamog (jkyamog) wrote :

--proxy-server for me works fine they are slightly different syntax

chromium-browser --proxy-server="proxyhost:proxyport"

environment is

http_proxy="http://proxyhost:proxyport"

I have the similar problem on Firefox. However firefox allows you to set via gui a manual proxy for it.

Bogdan Vasiliev (b-vasiliev) wrote :

Сonfirmed. "--proxy-server" option works with the correct syntax, system proxy setting is also ignored by Firefox.

Hence bug somewhere in another library.

Bogdan Vasiliev (b-vasiliev) wrote :

The temporary solution is manual set proxy in gconf:

gconftool-2 -t string -s /system/http_proxy/host "proxyhost"
gconftool-2 -t int -s /system/http_proxy/port proxyport
gconftool-2 -t bool -s /system/http_proxy/use_http_proxy true

Abhay Rana (capt-n3m0) wrote :

I'm running Chromium 15.0.865.0 (Developer Build 98568 Linux) Ubuntu 11.10 and it reacts perfectly well to the gnome 3 proxy settings.

jkyamog (jkyamog) wrote :

Just reporting:

gconf work around works for Chrome, not for Firefox.

Benjamin Kerensa (bkerensa) wrote :

This has been affecting me to it seems to be across the boad regardless of what browser you use:
http://ubuntuforums.org/showthread.php?p=11370018#post11370018

Christian Dywan (kalikiana) wrote :

Chromium 17 as in the archives has been fixed.

Changed in chromium-browser (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.