Can't make Chromium my default web browser

Bug #776393 reported by Mark Sheppard on 2011-05-03
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Chromium Browser
Unknown
Unknown
chromium-browser (Ubuntu)
Medium
Unassigned
Natty
Medium
Unassigned
Oneiric
Medium
Unassigned

Bug Description

Binary package hint: chromium-browser

Every time I start Chromium it says it's not the default browser and asks if I want to make it so, and every time I say "yes", but that has no effect. Neither does going to Preferences -> Basic -> Default Browser and clicking on the "Make Chromium My Default Browser" button. My default browser remains set to Firefox :-(.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: chromium-browser 11.0.696.57~r82915-0ubuntu0.11.04.1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Tue May 3 14:33:00 2011
Desktop-Session:
 DESKTOP_SESSION = gnome
 XDG_CONFIG_DIRS = /etc/xdg/xdg-gnome:/etc/xdg
 XDG_DATA_DIRS = /usr/share/gnome:/usr/local/share/:/usr/share/
Env:
 MOZ_PLUGIN_PATH = None
 LD_LIBRARY_PATH = None
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/usr/bin/tcsh
SourcePackage: chromium-browser
UpgradeStatus: Upgraded to natty on 2011-05-03 (0 days ago)
chromium-default: CHROMIUM_FLAGS=""

Mark Sheppard (mark-ddf) wrote :
Aaron Murray (xornot) wrote :

This is not a bug, but rather a question on how to do it.

Changed in chromium-browser (Ubuntu):
status: New → Invalid
Mark Sheppard (mark-ddf) wrote :

No, this isn't a question on how to do it. It's a bug report saying that the method provided for doing it doesn't work. Steps to reproduce:

1. Start Chromium
2. Observe the yellow bar saying "Chromium isn't your default browser." and the two buttons "Don't ask again" and "Set as default"
3. Click "Set as default"
4. Exit Chromium
5. Start Chromium again and observe that the yellow bar reappears

The bug is that clicking on "Set as default" doesn't work.

Micah Gersten (micahg) wrote :

This is actually a regression over maverick. It is a real bug.

Micah Gersten (micahg) wrote :

I can confirm this in a clean install. Marking confirmed until I can search for duplicates.

Changed in chromium-browser (Ubuntu):
importance: Undecided → Medium
status: Invalid → Confirmed
Dario Panico (dariopan) wrote :

i set it using update-alternatives, but it behaves like it isn't set:
- every link is opened in firefox (except those in chromium :D)
- the dash shows firefox icon (and launches firefox) in Shorcuts->Explore the Web (or smth like that I use localized ubuntu 11.04)

Dario Panico (dariopan) wrote :

setting it from Preferred Applications worked fine to solve the issue.

Micah Gersten (micahg) wrote :

The other bugs were about the system not opening links in Chromium when set as default, this one is about using Chromium to set itself as the default.

Changed in chromium-browser (Ubuntu):
status: Confirmed → Triaged
tags: added: regression-release
Changed in chromium-browser (Ubuntu Natty):
importance: Undecided → Medium
status: New → Triaged
tags: added: oneiric
jc00ke (jesse-jc00ke) wrote :

Setting it in Preferred Applications worked for me, but that setting is still not registered in Preferences. 13.0.759.0 (84563) Ubuntu 11.04

Joe Giampaoli (joegiampaoli) wrote :

Same here, removed firefox from repos and installed the one from mozilla, going to preferred applications will not show me firefox in the list now, and yes, I did create a link to (usr/bin) (/usr/local/bin) or (/usr/local/share/bin), then run ldconfig and still no go.....

Setting it in Preferred Applications does *not* work for me. Upon opening Preferred Applications again, Firefox is again the default browser.

this error appears when running gnome-default-applications-properties, upon setting the default browser to chromium:

(gnome-default-applications-properties:28940): default-applications-properties-WARNING **: Error setting default browser: Failed to create file '/home/michael/.local/share/applications/mimeapps.list.GGETVV': Permission denied

and for some reason, ~/.local/share/applications and ~/.local/share/applications/mimeapps.list are both owned by root? seems like this may be an unrelated bug... changing ownership of the directory and file seems to solve the issue.

Mykro (mykro76) wrote :

Had this problem with latest Natty as of 24 May. Chromium was unable to set itself as the preferred browser. Using Preferred Applications did not seem to work initially, I suspect this is because Chromium was open at the time. At some point I closed Chromium, set the option in Preferred Applications, opened Chromium again and noted it was now correctly the default browser.

What was interesting was that once I had successfully got Chromium set as the default browser, Chromium can now set itself as the default browser henceforth - ie. this problem can perhaps only be seen on a freshly installed system.

sameh (mfaroukg) wrote :

i have the same problem with the Dell latitude D505

James Cuzella (trinitronx) wrote :

I was able to fix this issue by adding 'google-chrome.desktop' to the cooresponding file associations in this file: ~.local/share/applications/mimeapps.list

More detailed information on how to edit this file can be found here: http://www.johannes-eva.net/change-the-default-application-ubuntu-linux

Here is my version:

--------------------BEGIN FILE-----------------------------

[Added Associations]
application/xml=gedit.desktop;
application/x-php=gedit.desktop;
x-scheme-handler/http=google-chrome.desktop;firefox.desktop;
x-scheme-handler/https=google-chrome.desktop;firefox.desktop;

[Default Applications]
x-scheme-handler/http=google-chrome.desktop
x-scheme-handler/https=google-chrome.desktop
x-scheme-handler/ftp=firefox.desktop
x-scheme-handler/chrome=firefox.desktop
text/html=google-chrome.desktop;firefox.desktop;
application/x-extension-htm=google-chrome.desktop;firefox.desktop;
application/x-extension-html=google-chrome.desktop;firefox.desktop;
application/x-extension-shtml=google-chrome.desktop;firefox.desktop;
application/xhtml+xml=google-chrome.desktop;firefox.desktop;
application/x-extension-xhtml=google-chrome.desktop;firefox.desktop;
application/x-extension-xht=google-chrome.desktop;firefox.desktop;
-------------------- END FILE-----------------------------

Christian Dywan (kalikiana) wrote :

This appears to have been fixed with Chromium 17 which is now in the archives.

Changed in chromium-browser (Ubuntu):
status: Triaged → Fix Released
Changed in chromium-browser (Ubuntu Oneiric):
status: Triaged → Fix Released
Mark Sheppard (mark-ddf) wrote :

I just upgraded from 11.04 to 12.04 and it works in Chromium 18, which is the version included in that. Thanks for the fix!

dino99 (9d9) on 2013-05-18
Changed in chromium-browser (Ubuntu Natty):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.