NaCl not working on Ubuntu 10.04 in Chromium 10.0.648.133

Bug #738331 reported by Bjarke Walling on 2011-03-19
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
Low
Fabien Tassin

Bug Description

Binary package hint: chromium-browser

Look at the bug filed at Google Native Client <http://code.google.com/p/nativeclient/issues/detail?id=1538>. It is suggested that the problem is a missing file (libppGoogleNaClPluginChrome.so) in the chromium-browser package.

What steps will reproduce the problem?
1. Open Chromium.
2. Go to about:flags.
3. Enable Native Client.
4. Restart Chromium.
5. Go to:
5. a. http://code.google.com/intl/da/chrome/nativeclient/docs/examples.html
5. b. http://nacl-gallery.appspot.com/life/life.html
7. Also try the above, just starting browser from command line: chromium-browser --no-sandbox --enable-nacl

What is the expected output? What do you see instead?
a. Examples page displays a red box “WARNING: Native Client is not enabled in Google Chrome. [...]”. Expected that NaCl was enabled.
b. Life page displays a grey area “Missing Plug-In”. Expected to see Conway's Life Demo, ie. NaCl was working.

Operating system:
Ubuntu 10.04.2 LTS
Linux 2.6.32-30-generic #59-Ubuntu SMP i686 GNU/Linux

Browser package:
chromium-browser 10.0.648.133~r77742-0ubuntu0.10.04.1

Browser specs:
Chromium 10.0.648.133 (Developer Build 77742) Ubuntu 10.04
WebKit 534.16 (trunk@76408)
V8 3.0.12.30
User Agent Mozilla/5.0 (X11; U; Linux i686; en-US) AppleWebKit/534.16 (KHTML, like Gecko) Ubuntu/10.04 Chromium/10.0.648.133 Chrome/10.0.648.133 Safari/534.16
Command Line /usr/lib/chromium-browser/chromium-browser --flag-switches-begin --enable-nacl --flag-switches-end

Fabien Tassin (fta) wrote :

Was blacklisted a while ago when it was not needed.
Fix committed in the main packaging branch (used by the dailies). Will land in stable next time there's an (upstream) update.

Changed in chromium-browser (Ubuntu):
assignee: nobody → Fabien Tassin (fta)
importance: Undecided → Low
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package chromium-browser - 10.0.648.204~r79063-0ubuntu1

---------------
chromium-browser (10.0.648.204~r79063-0ubuntu1) natty; urgency=high

  * New upstream minor release from the Stable Channel (LP: #742118)
    This release fixes the following security issues:
    + Webkit bugs:
      - [73216] High, CVE-2011-1292: Use-after-free in the frame loader. Credit
        to Sławomir Błażek.
      - [73595] High, CVE-2011-1293: Use-after-free in HTMLCollection. Credit
        to Sergey Glazunov.
      - [74562] High, CVE-2011-1294: Stale pointer in CSS handling. Credit to
        Sergey Glazunov.
      - [74991] High, CVE-2011-1295: DOM tree corruption with broken node
        parentage. Credit to Sergey Glazunov.
      - [75170] High, CVE-2011-1296: Stale pointer in SVG text handling. Credit
        to Sergey Glazunov.
    + Chromium bugs:
      - [72517] High, CVE-2011-1291: Buffer error in base string handling.
        Credit to Alex Turpin.
  Packaging changes:
  * Set arm_fpu=vfpv3-d16 on arm (less restrictive than the default vfpv3)
    preventing a SIGILL crash on some boards (LP: #735877)
    - update debian/control
  * Install libppGoogleNaClPluginChrome.so (LP: #738331)
    - update debian/rules
    - update debian/chromium-browser.install
 -- Fabien Tassin <email address hidden> Thu, 24 Mar 2011 23:05:14 +0100

Changed in chromium-browser (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers