Activity log for bug #692462

Date Who What changed Old value New value Message
2010-12-20 07:46:08 Fabien Tassin bug added bug
2010-12-20 16:50:00 Alex Launi bug task added bamf
2010-12-20 16:50:54 Alex Launi unity: status New Confirmed
2011-02-09 02:57:38 Jorge Castro bug added subscriber Jorge O. Castro
2011-02-21 16:58:46 Didier Roche bamf: status New Confirmed
2011-02-21 16:58:48 Didier Roche bamf (Ubuntu): status New Confirmed
2011-03-06 06:20:24 hrhnick bug added subscriber hrhnick
2011-03-07 20:47:23 Steve Baker bug watch added http://code.google.com/p/chromium/issues/detail?id=42587
2011-03-08 09:08:22 David Barth bamf: status Confirmed Invalid
2011-03-08 09:08:29 David Barth bamf (Ubuntu): status Confirmed Invalid
2011-03-08 09:08:35 David Barth unity: importance Undecided Wishlist
2011-03-09 19:48:11 Steve Baker bug watch added http://code.google.com/p/chromium/issues/detail?id=20587
2011-03-09 19:59:25 Jorge Castro bug added subscriber Pete Goodall
2011-03-09 20:01:51 Jorge Castro bug task added chromium
2011-03-11 13:54:47 Didier Roche unity (Ubuntu): status New Confirmed
2011-03-15 23:24:32 Marco Trevisan (Treviño) unity: assignee Treviño (Marco Trevisan) (3v1n0)
2011-03-15 23:24:34 Marco Trevisan (Treviño) bamf: assignee Treviño (Marco Trevisan) (3v1n0)
2011-03-22 16:55:50 Yann Dìnendal bug added subscriber Yann Dìnendal
2011-03-22 17:00:35 fosk bug added subscriber fosk
2011-03-23 23:55:47 Marco Trevisan (Treviño) bamf: status Invalid In Progress
2011-03-23 23:56:16 Marco Trevisan (Treviño) bug added subscriber Treviño (Marco Trevisan)
2011-03-24 00:13:26 Jorge Castro unity: status Confirmed Invalid
2011-03-24 00:13:36 Jorge Castro unity (Ubuntu): status Confirmed Invalid
2011-03-24 12:36:23 Didier Roche bamf (Ubuntu): status Invalid In Progress
2011-03-26 03:14:54 Marco Trevisan (Treviño) branch linked lp:~3v1n0/bamf/wmclass-matching
2011-03-26 03:28:42 Marco Trevisan (Treviño) bamf: status In Progress Fix Committed
2011-03-29 09:13:31 Didier Roche bamf (Ubuntu): status In Progress Fix Committed
2011-04-04 09:41:24 Marco Trevisan (Treviño) bamf: status Fix Committed Fix Released
2011-04-11 12:49:13 Launchpad Janitor branch linked lp:~chromium-team/chromium-browser/chromium-browser.natty
2011-04-11 12:52:13 Launchpad Janitor branch linked lp:~chromium-team/chromium-browser/chromium-browser.stable
2011-04-11 12:56:51 Fabien Tassin bug task added chromium-browser (Ubuntu)
2011-04-11 12:57:01 Fabien Tassin chromium-browser (Ubuntu): status New Fix Committed
2011-04-11 12:57:12 Fabien Tassin chromium-browser (Ubuntu): assignee Fabien Tassin (fta)
2011-04-11 12:57:20 Fabien Tassin chromium-browser (Ubuntu): importance Undecided Medium
2011-04-15 23:52:08 Launchpad Janitor chromium-browser (Ubuntu): status Fix Committed Fix Released
2011-04-15 23:52:08 Launchpad Janitor cve linked 2011-1301
2011-04-15 23:52:08 Launchpad Janitor cve linked 2011-1302
2011-04-26 13:01:28 Launchpad Janitor branch linked lp:~chromium-team/chromium-browser/chromium-browser.dev
2011-04-26 22:21:26 Launchpad Janitor branch linked lp:~chromium-team/chromium-browser/chromium-browser.beta
2011-04-26 22:27:07 Fabien Tassin chromium-browser (Ubuntu): status Fix Released Fix Committed
2011-05-02 07:05:04 Launchpad Janitor chromium-browser (Ubuntu): status Fix Committed Fix Released
2011-05-02 07:05:04 Launchpad Janitor cve linked 2011-1303
2011-05-02 07:05:04 Launchpad Janitor cve linked 2011-1304
2011-05-02 07:05:04 Launchpad Janitor cve linked 2011-1305
2011-05-02 07:05:04 Launchpad Janitor cve linked 2011-1434
2011-05-02 07:05:04 Launchpad Janitor cve linked 2011-1435
2011-05-02 07:05:04 Launchpad Janitor cve linked 2011-1436
2011-05-02 07:05:04 Launchpad Janitor cve linked 2011-1437
2011-05-02 07:05:04 Launchpad Janitor cve linked 2011-1438
2011-05-02 07:05:04 Launchpad Janitor cve linked 2011-1439
2011-05-02 07:05:04 Launchpad Janitor cve linked 2011-1440
2011-05-02 07:05:04 Launchpad Janitor cve linked 2011-1441
2011-05-02 07:05:04 Launchpad Janitor cve linked 2011-1442
2011-05-02 07:05:04 Launchpad Janitor cve linked 2011-1443
2011-05-02 07:05:04 Launchpad Janitor cve linked 2011-1444
2011-05-02 07:05:04 Launchpad Janitor cve linked 2011-1445
2011-05-02 07:05:04 Launchpad Janitor cve linked 2011-1446
2011-05-02 07:05:04 Launchpad Janitor cve linked 2011-1447
2011-05-02 07:05:04 Launchpad Janitor cve linked 2011-1448
2011-05-02 07:05:04 Launchpad Janitor cve linked 2011-1449
2011-05-02 07:05:04 Launchpad Janitor cve linked 2011-1450
2011-05-02 07:05:04 Launchpad Janitor cve linked 2011-1451
2011-05-02 07:05:04 Launchpad Janitor cve linked 2011-1452
2011-05-02 07:05:04 Launchpad Janitor cve linked 2011-1454
2011-05-04 22:08:57 centy bug added subscriber centy
2011-05-13 16:40:03 Fabien Tassin cve unlinked 2011-1436
2011-05-20 07:14:23 Elmar Zeeb bug added subscriber Elmar Zeeb
2011-05-20 07:15:23 Elmar Zeeb removed subscriber Elmar Zeeb
2011-05-20 07:19:27 Elmar Zeeb bug added subscriber Elmar Zeeb
2011-05-20 20:04:10 Dylan McCall bug added subscriber Dylan McCall
2011-05-31 20:24:36 Didier Roche unity-2d: status New Fix Released
2011-05-31 22:40:44 Br. Juniper Barlett. fbp bug added subscriber Matthew Barlett
2011-06-02 22:19:40 Jorge Castro bamf (Ubuntu): status Fix Committed Confirmed
2011-06-06 19:04:46 Jorge Castro unity: assignee Treviño (Marco Trevisan) (3v1n0) Unity Community Hackers (unity-community-hackers)
2011-06-06 19:04:56 Jorge Castro unity: status Invalid Confirmed
2011-06-06 19:05:24 Jorge Castro bamf (Ubuntu): assignee Unity Community Hackers (unity-community-hackers)
2011-06-06 19:25:18 Jason Smith description On my classic desktop panel, i have 2 webapps launchers in the gnome-panel. Basically, they are just "chromium-browser --app=http://some.web.site --some-other-flags ..." + a nice icon Chromium is my default browser. In the new unity based desktop mode, those webapps now appear nicely. The problem is that when i start my default web browser, unity highlights on the left one of my webapp launchers, instead of creating one for the browser itself. And worse.. once the browser is running, i can't start this webapp anymore as unity keeps raising the main browser instead. For the other webapp, it works as expected. ii libunity-misc0 0.1.1-0ubuntu3 Miscellaneous functions for Unity - shared library ii libunity0 0.2.46-0ubuntu5 binding to get places into the launcher - shared library ii libunity3 3.2.8-0ubuntu1 binding to get places into the launcher - shared library ii unity 3.2.8-0ubuntu1 Interface for Ubuntu Desktop Edition ii unity-asset-pool 0.8.18-0ubuntu2 Unity Assets Pool ii unity-common 3.2.8-0ubuntu1 Common files for the interface for Ubuntu Desktop Edition ii unity-place-applications 0.2.26-0ubuntu2 Application place for unity ii unity-place-files 0.5.32-0ubuntu1 File place for unity On my classic desktop panel, i have 2 webapps launchers in the gnome-panel. Basically, they are just "chromium-browser --app=http://some.web.site --some-other-flags ..." + a nice icon Chromium is my default browser. In the new unity based desktop mode, those webapps now appear nicely. The problem is that when i start my default web browser, unity highlights on the left one of my webapp launchers, instead of creating one for the browser itself. And worse.. once the browser is running, i can't start this webapp anymore as unity keeps raising the main browser instead. For the other webapp, it works as expected. ii libunity-misc0 0.1.1-0ubuntu3 Miscellaneous functions for Unity - shared library ii libunity0 0.2.46-0ubuntu5 binding to get places into the launcher - shared library ii libunity3 3.2.8-0ubuntu1 binding to get places into the launcher - shared library ii unity 3.2.8-0ubuntu1 Interface for Ubuntu Desktop Edition ii unity-asset-pool 0.8.18-0ubuntu2 Unity Assets Pool ii unity-common 3.2.8-0ubuntu1 Common files for the interface for Ubuntu Desktop Edition ii unity-place-applications 0.2.26-0ubuntu2 Application place for unity ii unity-place-files 0.5.32-0ubuntu1 File place for unity ========================================================================= This bug would be an ideal bug for someone to get started hacking on Unity, here's some information: * Time to fix: unknown but large * Difficulty: brutal * Implementation: This is a complex issue to solve correctly. The most correct implementation associates URI's with windows inside of bamf. Such that bamf's exported tree becomes BamfApplication -> BamfWindow ->BamfUri (currently called BamfTab and incomplete in source). To achieve this goal there are three primary components. The first is a BamfUriSource. This source is a class used by an application to export its known URI's over dbus to BAMF. The implementation details are not that important, however it is important that it be trackable (so if it crashes we can eliminate references to it) and that it provide two way communication. In short, it needs to tell the bamf daemon about all the uri's it has, and the bamf daemon needs to in turn be able to ask a bamf uri source to "show" a specific uri in its window. Bamf Daemon will then convert the BamfUriSource into many BamfUri's for exporting over the bus. A bamf uri should look something like and inherit from BamfView: char * bamf_uri_get_uri (BamfUri *self) char * bamf_uri_get_icon (BamfUri *self) char * bamf_uri_get_title (BamfUri *self) void bamf_uri_show (BamfUri *self) In short: that part sucks The second part is making web browsers export tab uri information over dbus using BamfUriSource. This should be somewhat simple if you know the browser plugin API's using a standard NPAPI plugin. The C potion of the plugin can consume bamf and pass data along, while the javascript can communicate with the browser to get relevant information about the state of the system. The third and final task is to hook this all into unity. This is relatively straightforward to do. By making a launcher shortcut that points to a uri rather than an application, unity can associate an BamfUri with it, watching when it opens and closes. When clicked, unity can call bamf_uri_show () on the proper uri, which will result in the window raising itself and flipping to the appropriate tab. Excellent. The most clarifying thing I can think to say here is that when you call bamf_uri_show, what should happen is libbamf will call Show on the correct dbus object that was exported by bamfdaemon. Bamfdaemon will then find the associated BamfUriSource for that BamfUri object, can call show back on it, passing along the id of the uri it wishes to have shown. The NPAPI plugin will receive this call, and pass the information up to the javascript layer, which should then raise the window and switch tabs. Like a boss. * Where to look: lp:bamf and lp:unity are the primary consumers. -lp:bamf requires the most work. BamfTabSource and BamfTab need to be converted, exported, and consumed in libbamf -lp:unity would simply consume the newly exported information * Workflow information: http://unity.ubuntu.com/getinvolved/
2011-06-07 08:09:48 Didier Roche unity (Ubuntu): status Invalid Confirmed
2011-06-07 11:32:33 Joey-Elijah Sneddon bug added subscriber d0od
2011-06-08 07:24:26 Pi Delport bug added subscriber Piet Delport
2011-06-09 22:01:12 Ian W Scott bug added subscriber Ian W Scott
2011-06-10 14:12:19 Matteo Pagliazzi bug added subscriber Matteo Pagliazzi
2011-06-10 14:54:12 benji.ijneb bug added subscriber benji.ijneb
2011-06-13 10:16:30 Florian Boucault unity-2d: importance Undecided Wishlist
2011-06-13 10:16:33 Florian Boucault unity-2d: status Fix Released Confirmed
2011-06-14 13:44:19 Didier Roche unity-2d: status Confirmed Fix Released
2011-06-15 15:15:02 David Barth unity: milestone iteration-2
2011-06-21 17:41:05 Marco Trevisan (Treviño) bug watch added https://bugzilla.gnome.org/show_bug.cgi?id=168718
2011-06-21 17:41:05 Marco Trevisan (Treviño) bug task added libwnck
2011-06-21 18:44:13 Bug Watch Updater libwnck: status Unknown New
2011-06-21 18:44:13 Bug Watch Updater libwnck: importance Unknown Medium
2011-06-22 00:01:05 Filipe Aguiar bug added subscriber Filipe Aguiar
2011-07-04 09:29:33 Florian Boucault unity-2d: status Fix Released Confirmed
2011-07-05 13:38:13 Didier Roche unity: milestone 4.2.0 4.4.0
2011-07-14 14:19:46 Jan Ericsen bug added subscriber Jan Ericsen
2011-07-21 16:31:47 Didier Roche unity: milestone 4.4.0 4.6.0
2011-07-22 14:14:03 Didier Roche unity-2d: status Confirmed Fix Released
2011-08-01 16:32:20 Didier Roche unity: milestone 4.6.0 4.8.0
2011-08-12 16:33:04 Bug Watch Updater libwnck: status New Fix Released
2011-08-30 20:12:02 David Barth unity: milestone 4.8.0 4.12.0
2011-08-31 08:11:56 Philipp Meier bug added subscriber Philipp Meier
2011-08-31 21:56:55 Jakub 'Livio' Rusinek bug added subscriber Jakub 'Livio' Rusinek
2011-09-01 15:27:32 Didier Roche unity: milestone 4.12.0 4.14.0
2011-09-02 17:26:53 David Barth unity: assignee Unity Community Hackers (unity-community-hackers) Jason Smith (jassmith)
2011-09-08 15:58:53 Didier Roche unity: milestone 4.14.0 4.16.0
2011-09-08 16:37:50 Tom bug added subscriber Tom
2011-09-15 16:42:59 Didier Roche unity: milestone 4.16.0 4.18.0
2011-09-22 06:16:47 Jason Smith unity: status Confirmed Fix Committed
2011-09-22 08:28:45 Didier Roche unity: status Fix Committed Fix Released
2011-09-22 08:28:50 Didier Roche unity (Ubuntu): status Confirmed Fix Released
2011-09-22 13:40:20 Didier Roche chromium-browser (Ubuntu): status Fix Released Triaged
2011-09-22 14:54:25 Launchpad Janitor bamf (Ubuntu): status Confirmed Fix Released
2011-09-22 19:45:01 Sebastien Bacher unity: status Fix Released New
2011-09-22 19:45:04 Sebastien Bacher unity (Ubuntu): status Fix Released New
2011-09-22 20:17:13 Jorge Castro attachment added chrome-https___bugs.launchpad.net_bamf_+bug_692462.desktop https://bugs.launchpad.net/unity/+bug/692462/+attachment/2442711/+files/chrome-https___bugs.launchpad.net_bamf_%2Bbug_692462.desktop
2011-09-23 16:51:40 Launchpad Janitor branch linked lp:ubuntu/bamf
2011-09-23 17:09:22 Launchpad Janitor unity (Ubuntu): status New Confirmed
2011-09-23 21:13:44 Alex Launi unity: status New Confirmed
2011-09-24 00:04:22 Jason Smith unity: status Confirmed Fix Committed
2011-09-24 00:04:27 Jason Smith unity (Ubuntu): status Confirmed Fix Committed
2011-09-24 00:04:30 Jason Smith chromium-browser (Ubuntu): status Triaged Fix Released
2011-09-26 10:23:10 Didier Roche unity: status Fix Committed Fix Released
2011-09-26 10:57:57 Didier Roche unity (Ubuntu): status Fix Committed Fix Released
2011-09-26 10:58:02 Didier Roche bamf (Ubuntu): status Fix Released Triaged
2011-09-26 11:52:22 Launchpad Janitor branch linked lp:~ubuntu-desktop/bamf/ubuntu
2011-09-26 12:22:20 Launchpad Janitor bamf (Ubuntu): status Triaged Fix Released
2011-09-26 12:44:25 Launchpad Janitor branch linked lp:~ubuntu-desktop/unity/ubuntu
2011-09-26 14:10:30 Launchpad Janitor branch linked lp:ubuntu/unity
2011-10-26 07:07:36 Launchpad Janitor branch linked lp:ubuntu/chromium-browser
2011-10-28 19:07:03 phillamg attachment added Screenshot of problem again in Unity 4.24 and Chrome >14 https://bugs.launchpad.net/unity/+bug/692462/+attachment/2577017/+files/chrome15.png
2011-10-28 19:07:21 phillamg bug added subscriber phillamg
2011-11-02 03:50:06 Flugsio bug added subscriber Flugsio
2011-11-03 14:35:58 Marcantonio bug added subscriber Marcantonio
2011-11-03 18:38:21 scottku bug added subscriber scottku
2011-11-09 01:45:09 Jorge Castro unity (Ubuntu): status Fix Released Confirmed
2011-11-09 01:45:13 Jorge Castro bamf (Ubuntu): status Fix Released Confirmed
2011-11-10 19:12:28 Collin Peters bug added subscriber Collin Peters
2011-11-14 17:35:52 Didier Roche bug task added unity-distro-priority
2011-11-14 17:36:04 Didier Roche unity-distro-priority: status New Fix Committed
2011-11-14 17:36:15 Didier Roche unity: status Fix Released Confirmed
2011-11-14 17:36:18 Didier Roche unity: importance Wishlist Medium
2011-11-14 17:36:22 Didier Roche unity: milestone 4.18.0 4.26.0
2011-11-17 11:14:08 Launchpad Janitor unity-2d (Ubuntu): status New Confirmed
2011-11-25 19:23:34 Colin Jia Zheng bug added subscriber Colin Jia Zheng
2011-12-13 15:41:39 Marco Trevisan (Treviño) bamf: importance Undecided Medium
2011-12-13 15:41:39 Marco Trevisan (Treviño) bamf: status Fix Released Confirmed
2011-12-16 11:52:55 David Barth unity: importance Medium High
2011-12-16 11:52:55 David Barth unity: milestone 4.26.0 4.28.0
2012-01-05 17:02:02 Omer Akram unity: milestone 4.28.0 4.30.0
2012-02-01 16:53:32 David Barth unity: milestone 4.30.0 5.4.0
2012-02-01 16:54:04 David Barth unity: assignee Jason Smith (jassmith) Marco Trevisan (Treviño) (3v1n0)
2012-02-02 11:08:12 Mark Howard bug added subscriber Mark Howard
2012-02-09 23:17:44 Fodi69 bug added subscriber Fodi69
2012-02-13 14:41:15 Omer Akram bamf: importance Medium High
2012-02-13 14:41:15 Omer Akram bamf: status Confirmed Triaged
2012-02-13 14:41:30 Omer Akram unity: importance High Medium
2012-02-13 14:41:30 Omer Akram unity: status Confirmed Triaged
2012-02-13 16:28:02 Ivar Abrahamsen bug added subscriber Ivar Abrahamsen
2012-02-17 12:31:50 Didier Roche unity: milestone 5.4.0 5.6.0
2012-02-20 02:34:12 Tim Penhey tags distro-priority
2012-02-20 12:50:25 Didier Roche unity-2d: status Fix Released Invalid
2012-02-20 12:50:43 Didier Roche unity-2d (Ubuntu): status Confirmed Invalid
2012-03-02 16:39:17 Rich Renomeron bug added subscriber Rich Renomeron
2012-03-12 10:45:12 Didier Roche unity: milestone 5.6.0 5.8.0
2012-03-14 14:01:55 Didier Roche summary unity confused with chromium web apps unity confused with chrome/chromium web apps
2012-03-19 04:36:37 Jason Warner tags distro-priority distro-priority rls-p-tracking
2012-03-23 13:37:42 Didier Roche unity: milestone 5.8.0 5.10.0
2012-03-26 14:01:13 David Barth tags distro-priority rls-p-tracking distro-priority hitlist rls-p-tracking
2012-03-27 02:43:09 Jason Warner tags distro-priority hitlist rls-p-tracking distro-priority hitlist
2012-03-28 10:22:46 Jan Visser bug added subscriber Jan Visser
2012-04-12 09:28:53 Didier Roche unity: milestone 5.10.0 5.12.0
2012-04-18 19:45:38 Marco Trevisan (Treviño) unity: status Triaged In Progress
2012-04-18 19:45:57 Marco Trevisan (Treviño) bamf: status Triaged In Progress
2012-04-19 18:41:09 Marco Trevisan (Treviño) branch linked lp:~3v1n0/bamf/desktop-class-matching-improved
2012-04-20 02:25:32 Marco Trevisan (Treviño) bamf: milestone 0.2.116
2012-04-20 02:26:05 Marco Trevisan (Treviño) unity (Ubuntu): status Confirmed In Progress
2012-04-20 02:26:05 Marco Trevisan (Treviño) unity (Ubuntu): assignee Marco Trevisan (Treviño) (3v1n0)
2012-04-20 02:26:27 Marco Trevisan (Treviño) bamf (Ubuntu): status Confirmed In Progress
2012-04-20 02:26:27 Marco Trevisan (Treviño) bamf (Ubuntu): assignee Unity Community Hackers (unity-community-hackers) Marco Trevisan (Treviño) (3v1n0)
2012-04-20 19:23:25 Kevin Mehall bug added subscriber Kevin Mehall
2012-04-20 21:13:38 Alexandre Abreu bug added subscriber Alexandre Abreu
2012-04-21 09:44:34 transamazonian bug added subscriber transamazonian
2012-04-24 21:17:36 Marco Trevisan (Treviño) bamf: status In Progress Fix Committed
2012-04-24 21:18:06 Marco Trevisan (Treviño) bamf (Ubuntu): status In Progress Fix Committed
2012-04-24 21:18:24 Marco Trevisan (Treviño) unity: status In Progress Fix Committed
2012-04-24 21:18:48 Marco Trevisan (Treviño) unity (Ubuntu): status In Progress Fix Committed
2012-04-26 09:38:47 Omer Akram description On my classic desktop panel, i have 2 webapps launchers in the gnome-panel. Basically, they are just "chromium-browser --app=http://some.web.site --some-other-flags ..." + a nice icon Chromium is my default browser. In the new unity based desktop mode, those webapps now appear nicely. The problem is that when i start my default web browser, unity highlights on the left one of my webapp launchers, instead of creating one for the browser itself. And worse.. once the browser is running, i can't start this webapp anymore as unity keeps raising the main browser instead. For the other webapp, it works as expected. ii libunity-misc0 0.1.1-0ubuntu3 Miscellaneous functions for Unity - shared library ii libunity0 0.2.46-0ubuntu5 binding to get places into the launcher - shared library ii libunity3 3.2.8-0ubuntu1 binding to get places into the launcher - shared library ii unity 3.2.8-0ubuntu1 Interface for Ubuntu Desktop Edition ii unity-asset-pool 0.8.18-0ubuntu2 Unity Assets Pool ii unity-common 3.2.8-0ubuntu1 Common files for the interface for Ubuntu Desktop Edition ii unity-place-applications 0.2.26-0ubuntu2 Application place for unity ii unity-place-files 0.5.32-0ubuntu1 File place for unity ========================================================================= This bug would be an ideal bug for someone to get started hacking on Unity, here's some information: * Time to fix: unknown but large * Difficulty: brutal * Implementation: This is a complex issue to solve correctly. The most correct implementation associates URI's with windows inside of bamf. Such that bamf's exported tree becomes BamfApplication -> BamfWindow ->BamfUri (currently called BamfTab and incomplete in source). To achieve this goal there are three primary components. The first is a BamfUriSource. This source is a class used by an application to export its known URI's over dbus to BAMF. The implementation details are not that important, however it is important that it be trackable (so if it crashes we can eliminate references to it) and that it provide two way communication. In short, it needs to tell the bamf daemon about all the uri's it has, and the bamf daemon needs to in turn be able to ask a bamf uri source to "show" a specific uri in its window. Bamf Daemon will then convert the BamfUriSource into many BamfUri's for exporting over the bus. A bamf uri should look something like and inherit from BamfView: char * bamf_uri_get_uri (BamfUri *self) char * bamf_uri_get_icon (BamfUri *self) char * bamf_uri_get_title (BamfUri *self) void bamf_uri_show (BamfUri *self) In short: that part sucks The second part is making web browsers export tab uri information over dbus using BamfUriSource. This should be somewhat simple if you know the browser plugin API's using a standard NPAPI plugin. The C potion of the plugin can consume bamf and pass data along, while the javascript can communicate with the browser to get relevant information about the state of the system. The third and final task is to hook this all into unity. This is relatively straightforward to do. By making a launcher shortcut that points to a uri rather than an application, unity can associate an BamfUri with it, watching when it opens and closes. When clicked, unity can call bamf_uri_show () on the proper uri, which will result in the window raising itself and flipping to the appropriate tab. Excellent. The most clarifying thing I can think to say here is that when you call bamf_uri_show, what should happen is libbamf will call Show on the correct dbus object that was exported by bamfdaemon. Bamfdaemon will then find the associated BamfUriSource for that BamfUri object, can call show back on it, passing along the id of the uri it wishes to have shown. The NPAPI plugin will receive this call, and pass the information up to the javascript layer, which should then raise the window and switch tabs. Like a boss. * Where to look: lp:bamf and lp:unity are the primary consumers. -lp:bamf requires the most work. BamfTabSource and BamfTab need to be converted, exported, and consumed in libbamf -lp:unity would simply consume the newly exported information * Workflow information: http://unity.ubuntu.com/getinvolved/ SRU testcase 1. start chromium-browser 2. create a webapp for twitter.com 3. drag it to launcher while chromium is already running 4. click its icon you will see twitter.com is opened in a new window but is still associated with chromium icon 5. now install Bamf from precise-proposed 6. note that twitter window is associated to the newly dropped icon in the launcher. On my classic desktop panel, i have 2 webapps launchers in the gnome-panel. Basically, they are just "chromium-browser --app=http://some.web.site --some-other-flags ..." + a nice icon Chromium is my default browser. In the new unity based desktop mode, those webapps now appear nicely. The problem is that when i start my default web browser, unity highlights on the left one of my webapp launchers, instead of creating one for the browser itself. And worse.. once the browser is running, i can't start this webapp anymore as unity keeps raising the main browser instead. For the other webapp, it works as expected. ii libunity-misc0 0.1.1-0ubuntu3 Miscellaneous functions for Unity - shared library ii libunity0 0.2.46-0ubuntu5 binding to get places into the launcher - shared library ii libunity3 3.2.8-0ubuntu1 binding to get places into the launcher - shared library ii unity 3.2.8-0ubuntu1 Interface for Ubuntu Desktop Edition ii unity-asset-pool 0.8.18-0ubuntu2 Unity Assets Pool ii unity-common 3.2.8-0ubuntu1 Common files for the interface for Ubuntu Desktop Edition ii unity-place-applications 0.2.26-0ubuntu2 Application place for unity ii unity-place-files 0.5.32-0ubuntu1 File place for unity ========================================================================= This bug would be an ideal bug for someone to get started hacking on Unity, here's some information:  * Time to fix: unknown but large  * Difficulty: brutal  * Implementation: This is a complex issue to solve correctly. The most correct implementation associates URI's with windows inside of bamf. Such that bamf's exported tree becomes BamfApplication -> BamfWindow ->BamfUri (currently called BamfTab and incomplete in source). To achieve this goal there are three primary components. The first is a BamfUriSource. This source is a class used by an application to export its known URI's over dbus to BAMF. The implementation details are not that important, however it is important that it be trackable (so if it crashes we can eliminate references to it) and that it provide two way communication. In short, it needs to tell the bamf daemon about all the uri's it has, and the bamf daemon needs to in turn be able to ask a bamf uri source to "show" a specific uri in its window. Bamf Daemon will then convert the BamfUriSource into many BamfUri's for exporting over the bus. A bamf uri should look something like and inherit from BamfView: char * bamf_uri_get_uri (BamfUri *self) char * bamf_uri_get_icon (BamfUri *self) char * bamf_uri_get_title (BamfUri *self) void bamf_uri_show (BamfUri *self) In short: that part sucks The second part is making web browsers export tab uri information over dbus using BamfUriSource. This should be somewhat simple if you know the browser plugin API's using a standard NPAPI plugin. The C potion of the plugin can consume bamf and pass data along, while the javascript can communicate with the browser to get relevant information about the state of the system. The third and final task is to hook this all into unity. This is relatively straightforward to do. By making a launcher shortcut that points to a uri rather than an application, unity can associate an BamfUri with it, watching when it opens and closes. When clicked, unity can call bamf_uri_show () on the proper uri, which will result in the window raising itself and flipping to the appropriate tab. Excellent. The most clarifying thing I can think to say here is that when you call bamf_uri_show, what should happen is libbamf will call Show on the correct dbus object that was exported by bamfdaemon. Bamfdaemon will then find the associated BamfUriSource for that BamfUri object, can call show back on it, passing along the id of the uri it wishes to have shown. The NPAPI plugin will receive this call, and pass the information up to the javascript layer, which should then raise the window and switch tabs. Like a boss.  * Where to look: lp:bamf and lp:unity are the primary consumers.    -lp:bamf requires the most work. BamfTabSource and BamfTab need to be converted, exported, and consumed in libbamf    -lp:unity would simply consume the newly exported information  * Workflow information: http://unity.ubuntu.com/getinvolved/
2012-04-26 09:39:14 Omer Akram bug task deleted unity (Ubuntu)
2012-04-26 09:40:07 Omer Akram bug added subscriber Ubuntu Stable Release Updates Team
2012-04-26 09:40:19 Omer Akram bamf (Ubuntu): status Fix Committed Confirmed
2012-04-26 09:41:16 Omer Akram nominated for series Ubuntu Precise
2012-04-26 09:41:16 Omer Akram bug task added bamf (Ubuntu Precise)
2012-04-26 09:41:16 Omer Akram bug task added chromium-browser (Ubuntu Precise)
2012-04-26 09:41:16 Omer Akram bug task added unity-2d (Ubuntu Precise)
2012-04-27 11:31:26 Didier Roche bamf: status Fix Committed Fix Released
2012-04-27 11:31:30 Didier Roche unity: status Fix Committed Fix Released
2012-04-27 13:11:29 Martin Pitt unity (Ubuntu Precise): status New Fix Committed
2012-04-27 13:11:35 Martin Pitt bug added subscriber SRU Verification
2012-04-27 13:11:40 Martin Pitt tags distro-priority hitlist distro-priority hitlist verification-needed
2012-04-30 04:28:22 Launchpad Janitor branch linked lp:ubuntu/precise-proposed/unity
2012-04-30 14:41:22 Omer Akram bug task deleted unity (Ubuntu Precise)
2012-04-30 14:41:33 Omer Akram bug task deleted unity (Ubuntu)
2012-04-30 15:53:23 Marco Trevisan (Treviño) branch linked lp:~3v1n0/bamf/desktopless-webapps-fix
2012-04-30 15:53:32 Marco Trevisan (Treviño) branch linked lp:~3v1n0/bamf/better-wmclass-filter
2012-05-04 13:03:55 Charl P. Botha bug added subscriber Charl P. Botha
2012-05-06 11:16:36 Alexander Broshevich bug added subscriber Vlad
2012-05-06 15:31:59 Launchpad Janitor unity (Ubuntu): status New Confirmed
2012-05-06 15:31:59 Launchpad Janitor unity (Ubuntu Precise): status New Confirmed
2012-05-08 00:20:15 Launchpad Janitor unity (Ubuntu): status Confirmed Fix Released
2012-05-08 00:25:13 Launchpad Janitor unity (Ubuntu Precise): status Confirmed Fix Released
2012-05-08 17:57:23 Marco Trevisan (Treviño) bamf: status Fix Released Fix Committed
2012-05-10 02:17:27 Miloš Mandarić bug added subscriber Miloš Mandarić
2012-05-23 12:24:41 Marco Trevisan (Treviño) bamf (Ubuntu): status Confirmed Fix Committed
2012-05-23 12:24:59 Marco Trevisan (Treviño) bamf (Ubuntu Precise): status Confirmed Fix Committed
2012-05-24 11:10:19 Launchpad Janitor bamf (Ubuntu): status Fix Committed Fix Released
2012-05-24 11:25:28 Launchpad Janitor branch linked lp:ubuntu/bamf
2012-05-24 15:04:39 Marco Trevisan (Treviño) bamf: status Fix Committed Fix Released
2012-05-24 15:48:36 centy removed subscriber centy
2012-05-24 20:43:19 Launchpad Janitor branch linked lp:ubuntu/precise-proposed/bamf
2012-06-05 10:10:39 Launchpad Janitor bamf (Ubuntu Precise): status Fix Committed Fix Released
2012-09-13 16:51:57 Richard Huddleston bug added subscriber Richard Huddleston
2013-01-23 13:50:55 Launchpad Janitor bamf (Ubuntu Quantal): status New Confirmed
2013-01-23 13:51:04 Andrea Amoroso bug added subscriber Andrea Amoroso
2013-01-26 01:52:53 Marco Trevisan (Treviño) bamf (Ubuntu Quantal): status Confirmed Fix Released