chromium-browser crashed with SIGSEGV in NSSRWLock_LockRead_Util()

Bug #528655 reported by Anthony Hook on 2010-02-26
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Chromium Browser
Unknown
Unknown
chromium-browser (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: chromium-browser

I closed chromium-browser and was greeted with this crash.

ProblemType: Crash
Architecture: amd64
Date: Fri Feb 26 13:27:06 2010
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
ExecutablePath: /usr/lib/chromium-browser/chromium-browser
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100226)
NonfreeKernelModules: nvidia
Package: chromium-browser 5.0.307.9~r39052-0ubuntu1
ProcCmdline: /usr/lib/chromium-browser/chromium-browser
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
SegvAnalysis:
 Segfault happened at: 0x7f311280c50e <NSSRWLock_LockRead_Util+14>: mov (%rbx),%rdi
 PC (0x7f311280c50e) ok
 source "(%rbx)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: chromium-browser
StacktraceTop:
 NSSRWLock_LockRead_Util ()
 PK11_GetAllTokens () from /usr/lib/libnss3.so
 PK11_GetBestSlotMultiple () from /usr/lib/libnss3.so
 PK11_GetBestSlot () from /usr/lib/libnss3.so
 PK11_CreateDigestContext () from /usr/lib/libnss3.so
Title: chromium-browser crashed with SIGSEGV in NSSRWLock_LockRead_Util()
Uname: Linux 2.6.32-14-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (polkit-gnome-authentication-agent-1:1649): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (Do:1650): Wnck-CRITICAL **: wnck_set_client_type got called multiple times.
 (nm-applet:1647): Gdk-CRITICAL **: gdk_window_thaw_toplevel_updates_libgtk_only: assertion `private->update_and_descendants_freeze_count > 0' failed
 (gnome-power-manager:1633): Gtk-CRITICAL **: gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed
 (gnome-terminal:2014): Gtk-CRITICAL **: gtk_accel_map_unlock_path: assertion `entry != NULL && entry->lock_count > 0' failed

Anthony Hook (anthonyhook) wrote :

StacktraceTop:
 NSSRWLock_LockRead_Util (rwlock=0x0) at nssrwlk.c:177
 PK11_GetAllTokens (type=544, needRW=0, loadCerts=1,
 PK11_GetBestSlotMultiple (type=0x7f3116028608,
 PK11_GetBestSlot (type=544, wincx=0x7f311602aa70)
 PK11_CreateDigestContext (

Changed in chromium-browser (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Omer Akram (om26er) on 2010-03-21
visibility: private → public
Brian Curtis (bcurtiswx) wrote :

Since it has 95% of the required information it can be marked as triaged. Could the reporter please give us a list of steps to reproduce the problem and/or the website you were last visiting when it crashed before close.

Changed in chromium-browser (Ubuntu):
status: New → Triaged
Daniel Hollocher (chogydan) wrote :

Since launchpad is not following upstream bug report updates, I have updated it manually.

Changed in chromium-browser (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.