[regression] Start-up page is blank after upgrading to version 88

Bug #1913069 reported by Paul White on 2021-01-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
High
Olivier Tilloy

Bug Description

I've just booted into Ubuntu 20.04 after several days or using another release and found that the Chromium snap was updated on booting from version 87.0.4280.141 to version 88.0.4324.96. I haven't changed any settings but I find that Chromium's start-up or new tab page is blank below the bookmarks bar, i.e. it doesn't contain the Google search box or my ten shortcuts to frequently used websites.

I reverted to version 87.0.4280.141 and found that the Google search box and shortcut icons are displayed when Chromium is started or a new tab is created. After manually upgrading to version 88.0.4324.96 I am again without the search box shortcut icons when starting Chromium or creating a new tab.

I can't see any change in the setting panels that inhibit their display and for what it's worth, the latest version of Google Chrome (88.0.4324.96) displays the search box and shortcut icons as expected.

An addition problem just noticed is that all of my passwords synchronised through Google seem to be incorrect. It is as if Chromium is picking up old passwords. Gmail told me that my account was currently inaccessible.

No problems accessing anything with Google Chrome.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: chromium-browser 1:85.0.4183.83-0ubuntu0.20.04.2
ProcVersionSignature: Ubuntu 5.8.0-40.45~20.04.1-generic 5.8.18
Uname: Linux 5.8.0-40-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.14
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
DRM.card0-DP-1:
 enabled: enabled
 dpms: On
 status: connected
 edid-base64: AP///////wAdZRUCAQAAACoVAQSlNB544gywoldRnycKUFS/zwDRwLMAlQCBgIGKgQCBSgEBAjqAGHE4LUBYLEUACSUhAAAeAAAA/wAwMDAwMDAwMQogICAgAAAA/QA4Sx5TDwAKICAgICAgAAAA/ABFRjIyMGEKICAgICAgAGI=
 modes: 1920x1080 1680x1050 1280x1024 1280x1024 1440x900 1280x800 1024x768 1024x768 1024x768 800x600 800x600 800x600 800x600 640x480 640x480 640x480 640x480 720x400
DRM.card0-HDMI-A-1:
 enabled: disabled
 dpms: Off
 status: disconnected
 edid-base64:
 modes:
DRM.card0-HDMI-A-2:
 enabled: disabled
 dpms: Off
 status: disconnected
 edid-base64:
 modes:
DRM.card0-HDMI-A-3:
 enabled: disabled
 dpms: Off
 status: disconnected
 edid-base64:
 modes:
DRM.card0-eDP-1:
 enabled: enabled
 dpms: On
 status: connected
 edid-base64: AP///////wANrsQVAAAAACgXAQSVIhN4Au8FkFRSkyklUFQAAAABAQEBAQEBAQEBAQEBAQEBXjWAlnA4FEAsHCQAWMEQAAAYAAAA/gBOMTU2SEdFLUVBQgogAAAA/gBDTU4KICAgICAgICAgAAAA/gBOMTU2SEdFLUVBQgogAB0=
 modes: 1920x1080
Date: Mon Jan 25 14:31:24 2021
DiskUsage:
 Filesystem Type Size Used Avail Use% Mounted on
 /dev/sda2 ext4 73G 19G 51G 27% /home
 tmpfs tmpfs 3.9G 9.2M 3.9G 1% /dev/shm
 /dev/sda2 ext4 73G 19G 51G 27% /home
InstallationDate: Installed on 2019-05-17 (619 days ago)
InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Alpha amd64 (20190517)
MachineType: Novatech N350DW
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.8.0-40-generic root=UUID=35cc812a-75e8-4a5a-83d0-bd336006d2f6 ro quiet splash vt.handoff=7
Snap.Changes:
 ID Status Spawn Ready Summary
 1148 Done 2021-01-25T11:06:47Z 2021-01-25T11:07:36Z Auto-refresh snaps "chromium", "nvim"
 1150 Done 2021-01-25T14:24:08Z 2021-01-25T14:24:33Z Revert "chromium" snap
 1151 Done 2021-01-25T14:25:34Z 2021-01-25T14:25:57Z Refresh "chromium" snap
Snap.ChromeDriverVersion: ChromeDriver 88.0.4324.96 (68dba2d8a0b149a1d3afac56fa74648032bcf46b-refs/branch-heads/4324@{#1784})
Snap.ChromiumVersion: Chromium 88.0.4324.96 snap
SourcePackage: chromium-browser
UpgradeStatus: Upgraded to focal on 2019-11-08 (443 days ago)
dmi.bios.date: 03/10/2017
dmi.bios.release: 5.12
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 5.12
dmi.board.asset.tag: Tag 12345
dmi.board.name: N350DW
dmi.board.vendor: Novatech
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Novatech
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr5.12:bd03/10/2017:br5.12:svnNovatech:pnN350DW:pvrNotApplicable:rvnNovatech:rnN350DW:rvrNotApplicable:cvnNovatech:ct10:cvrN/A:
dmi.product.family: Not Applicable
dmi.product.name: N350DW
dmi.product.sku: Not Applicable
dmi.product.version: Not Applicable
dmi.sys.vendor: Novatech

Paul White (paulw2u) wrote :
Paul White (paulw2u) on 2021-01-25
description: updated

Not just the snap, the deb packages for xenial and bionic appear to be similarly affected.

summary: - [snap] Start-up page is blank after upgrading to version 88
+ Start-up page is blank after upgrading to version 88
Changed in chromium-browser (Ubuntu):
status: New → Confirmed
importance: Undecided → High
summary: - Start-up page is blank after upgrading to version 88
+ [regression] Start-up page is blank after upgrading to version 88
Olivier Tilloy (osomon) wrote :

As suggested in https://askubuntu.com/a/1310367, disabling chrome://flags/#ntp-webui works around the issue. There must be more to it though, because the official Google Chrome package doesn't seem to be affected.

Olivier Tilloy (osomon) wrote :

I suspect a regression introduced by https://chromium.googlesource.com/chromium/src/+/5012d34829ca24488da8e768eb8bcf9e42278637 when building with optimize_webui=false, which results in the resource bundle missing a bunch of new tab page resources, including chrome://new-tab-page/modules/dummy/{module,foo_proxy}.js.

Changed in chromium-browser (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
Olivier Tilloy (osomon) wrote :
Changed in chromium-browser (Ubuntu):
status: Confirmed → In Progress
Olivier Tilloy (osomon) wrote :

This was it, the amd64 snap in the stable channel now displays the new tab page correctly.

Changed in chromium-browser (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers