Hardware GPU Compositing not working, missing libGLESV2.so in snap package

Bug #1893415 reported by Simon on 2020-08-28
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
High
Olivier Tilloy

Bug Description

chrome://gpu/

Graphics Feature Status
Canvas: Software only, hardware acceleration unavailable
Flash: Software only. Hardware acceleration disabled
Flash Stage3D: Software only. Hardware acceleration disabled
Flash Stage3D Baseline profile: Software only. Hardware acceleration disabled
Compositing: Software only. Hardware acceleration disabled
Multiple Raster Threads: Enabled
Out-of-process Rasterization: Disabled
OpenGL: Disabled
Hardware Protected Video Decode: Disabled
Rasterization: Software only. Hardware acceleration disabled
Skia Renderer: Enabled
Video Decode: Software only. Hardware acceleration disabled
Vulkan: Disabled
WebGL: Software only, hardware acceleration unavailable
WebGL2: Software only, hardware acceleration unavailable
Problems Detected
Gpu compositing has been disabled, either via blacklist, about:flags or the command line. The browser will fall back to software compositing and hardware acceleration will be unavailable.
Disabled Features: gpu_compositing

Version Information
Data exported 2020-08-28T12:43:36.316Z
Chrome version Chrome/85.0.4183.83
Operating system Linux 5.4.0-42-generic
Software rendering list URL https://chromium.googlesource.com/chromium/src/+/94abc2237ae0c9a4cb5f035431c8adfb94324633/gpu/config/software_rendering_list.json
Driver bug list URL https://chromium.googlesource.com/chromium/src/+/94abc2237ae0c9a4cb5f035431c8adfb94324633/gpu/config/gpu_driver_bug_list.json
ANGLE commit id unknown hash
2D graphics backend Skia/85 8ae885386e910cff8c543ae0d952a2c43f46e4ad
Command Line /snap/chromium/1275/usr/lib/chromium-browser/chrome --no-default-browser-check --no-first-run --password-store --flag-switches-begin --flag-switches-end --origin-trial-disabled-features=MeasureMemory

[truncated]

Problems Detected for Hardware GPU
Gpu compositing has been disabled, either via blacklist, about:flags or the command line. The browser will fall back to software compositing and hardware acceleration will be unavailable.
Disabled Features: gpu_compositing

Log Messages
[31619:31619:0828/134331.474558:ERROR:gl_implementation.cc(286)] : Failed to load /snap/chromium/1275/usr/lib/chromium-browser/libGLESv2.so: /snap/chromium/1275/usr/lib/chromium-browser/libGLESv2.so: cannot open shared object file: No such file or directory
[31619:31619:0828/134331.475780:ERROR:viz_main_impl.cc(150)] : Exiting GPU process due to errors during initialization
GpuProcessHost: The GPU process exited normally. Everything is okay.
[31627:31627:0828/134336.157808:ERROR:gles2_cmd_decoder.cc(3614)] : ContextResult::kFatalFailure: fail_if_major_perf_caveat + swiftshader
[31627:31627:0828/134336.159639:ERROR:gles2_cmd_decoder.cc(3614)] : ContextResult::kFatalFailure: fail_if_major_perf_caveat + swiftshader
[31627:31627:0828/134336.160909:ERROR:gles2_cmd_decoder.cc(3614)] : ContextResult::kFatalFailure: fail_if_major_perf_caveat + swiftshader

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in chromium-browser (Ubuntu):
status: New → Confirmed
Jose Mico (jose-mico) wrote :

The bug was introduced in rev 1275 (85.0.4183.83).

Previous rev 1269 (84.0.4147.135) was working fine.

Olivier Tilloy (osomon) wrote :
Changed in chromium-browser (Ubuntu):
status: Confirmed → Fix Released
assignee: nobody → Olivier Tilloy (osomon)
importance: Undecided → High
Simon (sbentl) wrote :

Thanks everyone, just updated on my machine and it is now working as expected.

Olivier Tilloy (osomon) wrote :

For future reference, here is the corresponding upstream commit: https://chromium.googlesource.com/chromium/src/+/991f4aabb715c027664a007f814c08cb2175674e.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers