the chromium snap takes a long time to install without visible user feedback, seems stuck

Bug #1886414 reported by dan the person on 2020-07-06
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
Medium
Olivier Tilloy

Bug Description

after an initial attemp to install where the progress got stuck at 20%, i rebooted as there were a bunch of other system updates that had been applied after a fresh isntall.

Now chromium wont install

dantheperson@danski:~$ sudo apt install chromium-browser
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
  chromium-browser
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 48.4 kB of archives.
After this operation, 164 kB of additional disk space will be used.
Get:1 http://nz.archive.ubuntu.com/ubuntu focal-updates/universe amd64 chromium-browser amd64 81.0.4044.129-0ubuntu0.20.04.1 [48.4 kB]
Fetched 48.4 kB in 0s (1,527 kB/s)
Preconfiguring packages ...
(Reading database ... 185728 files and directories currently installed.)
Preparing to unpack .../chromium-browser_81.0.4044.129-0ubuntu0.20.04.1_amd64.deb ...
=> Installing the chromium snap
==> Checking connectivity with the snap store
==> Installing the chromium snap
error: snap "chromium" has "install-snap" change in progress
dpkg: error processing archive /var/cache/apt/archives/chromium-browser_81.0.4044.129-0ubuntu0.20.04.1_amd64.deb (--unpack):
 new chromium-browser package pre-installation script subprocess returned error exit status 10
Errors were encountered while processing:
 /var/cache/apt/archives/chromium-browser_81.0.4044.129-0ubuntu0.20.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Package
DistroRelease: Ubuntu 20.04
Package: chromium-browser 81.0.4044.129-0ubuntu0.20.04.1
ProcVersionSignature: Ubuntu 5.4.0-40.44-generic 5.4.44
Uname: Linux 5.4.0-40-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.3
AptOrdering:
 chromium-browser:amd64: Install
 NULL: ConfigurePending
Architecture: amd64
CasperMD5CheckResult: skip
Date: Mon Jul 6 23:39:11 2020
Dependencies:

ErrorMessage: new chromium-browser package pre-installation script subprocess returned error exit status 10
InstallationDate: Installed on 2020-07-06 (0 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
Python3Details: /usr/bin/python3.8, Python 3.8.2, python3-minimal, 3.8.2-0ubuntu2
PythonDetails: N/A
RelatedPackageVersions:
 dpkg 1.19.7ubuntu3
 apt 2.0.2ubuntu0.1
SourcePackage: chromium-browser
Title: package chromium-browser 81.0.4044.129-0ubuntu0.20.04.1 failed to install/upgrade: new chromium-browser package pre-installation script subprocess returned error exit status 10
UpgradeStatus: No upgrade log present (probably fresh install)

dan the person (dantheperson) wrote :
dan the person (dantheperson) wrote :

ok i found 'snap changes' and did snap abort.

Now stuck on 20% again...

antheperson@danski:~$ snap changes
ID Status Spawn Ready Summary
1 Done today at 23:24 NZST today at 23:26 NZST Initialize system state
2 Done today at 23:24 NZST today at 23:24 NZST Initialize device
3 Done today at 23:26 NZST today at 23:35 NZST Install "canonical-livepatch" snap
4 Doing today at 23:28 NZST - Install "pycharm-community" snap from "latest/stable" channel
5 Doing today at 23:32 NZST - Install "chromium" snap

dantheperson@danski:~$ sudo snap abort 5
dantheperson@danski:~$ sudo snap abort 4
dantheperson@danski:~$ sudo apt install chromium-browser
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
  chromium-browser
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0 B/48.4 kB of archives.
After this operation, 164 kB of additional disk space will be used.
Preconfiguring packages ...
(Reading database ... 185728 files and directories currently installed.)
Preparing to unpack .../chromium-browser_81.0.4044.129-0ubuntu0.20.04.1_amd64.deb ...
=> Installing the chromium snap
==> Checking connectivity with the snap store
==> Installing the chromium snap

Progress: [ 20%] [#####################################....................................................................................................................................................]

dan the person (dantheperson) wrote :

ok after 20 mins i abort again. snap reports the following

==> Installing the chromium snap
error: cannot perform the following tasks:
- Download snap "chromium" (1213) from channel "stable" (context canceled)
dpkg: error processing archive /var/cache/apt/archives/chromium-browser_81.0.4044.129-0ubuntu0.20.04.1_amd64.deb (--unpack):
 new chromium-browser package pre-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/chromium-browser_81.0.4044.129-0ubuntu0.20.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
W: Operation was interrupted before it could finish

Olivier Tilloy (osomon) wrote :

Can you try installing the snap using the "snap install chromium" command?
Please let us know how this goes, and if it succeeds you should be able to safely install the deb wrapper ("apt install chromium-browser").

Changed in chromium-browser (Ubuntu):
status: New → Incomplete
dan the person (dantheperson) wrote :

ok thanks that worked a treat.

Running snap directly there was a progress indicator so i could see that snap downloads are very very very slow. 200kb/s. I'm on a a basic residential 100Mbits fibre line, so apt downloading deps from the ubuntu mirror is usually quick, 10MB/s. So the snap download is 50x slower than what i am used to.

So download 50x slower than usual, and no progress indicator, made me think it was hung when i probably should have just waited half an hour.

Normal download speed from apt upgrade straight after the snap install:

The following packages will be upgraded:
  libnss3 snapd
2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 28.4 MB of archives.
After this operation, 15.2 MB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://nz.archive.ubuntu.com/ubuntu focal-updates/main amd64 libnss3 amd64 2:3.49.1-1ubuntu1.2 [1,171 kB]
Get:2 http://nz.archive.ubuntu.com/ubuntu focal-updates/main amd64 snapd amd64 2.45.1+20.04 [27.3 MB]
Fetched 28.4 MB in 3s (10.9 MB/s)

Olivier Tilloy (osomon) wrote :

I'm glad this worked, and thanks for the feedback.
I know that the snap store uses a CDN to serve snaps, it could be that NZ isn't favoured with the current setup. This is just a blind guess, I suggest you ask about it on https://forum.snapcraft.io/.

Changed in chromium-browser (Ubuntu):
status: Incomplete → Opinion
status: Opinion → Invalid
Lloyd Blythen (lblythen) wrote :

Have a feeling this will crop up a lot. I too am in NZ and was doing a routine apt upgrade of chromium-browser on Ubuntu 20.04 LTS.

First time, it decided to install the chromium snap and appeared stuck at 14%. (There was a bug, reporting identical symptoms, back in May. It's been expired because it's more than 60 days old but I'd bet that people will still be having the same problem.)

Next attempt - after much fixing-up having bombed out of what appeared to be a hung install - is showing exactly what the OP here describes: it's chosen first to install the chromium snap, with the progress bar appearing stuck at 20% for ages.

I'm prepared to wait ... and wait, as it appears from comments above that eventually this will complete and normal apt upgrades will be restored. Doesn't change my opinion: regardless of whether this works in the end, it's badly broken.

Olivier Tilloy (osomon) wrote :

I agree this isn't a good user experience. I'll look into what can be done to report more detailed progress.

Please raise the issue with NZ being poorly served by the snap store CDN separately at https://forum.snapcraft.io/, this is something I cannot address myself but I'm sure the store team will be interested in hearing of the problem.

summary: - chromium wont install
+ the chromium snap takes a long time to install without visible user
+ feedback, seems stuck
Changed in chromium-browser (Ubuntu):
status: Invalid → Confirmed
assignee: nobody → Olivier Tilloy (osomon)
importance: Undecided → Medium
salvador liébana (salvalie) wrote :

Please put TNT on snap... This was a machine of stress on the most easy thing to do on any Linux OS, installing software.

Olivier Tilloy (osomon) wrote :

Sorry, I'm not sure what you mean with that last comment. Can you please elaborate?

Download full text (3.5 KiB)

I reckon he means get rid of snap caused it turned a trivial task into a
difficult one.

On Fri, 7 Aug 2020, 08:10 Olivier Tilloy, <email address hidden>
wrote:

> Sorry, I'm not sure what you mean with that last comment. Can you please
> elaborate?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1886414
>
> Title:
> the chromium snap takes a long time to install without visible user
> feedback, seems stuck
>
> Status in chromium-browser package in Ubuntu:
> Confirmed
>
> Bug description:
> after an initial attemp to install where the progress got stuck at
> 20%, i rebooted as there were a bunch of other system updates that had
> been applied after a fresh isntall.
>
> Now chromium wont install
>
> dantheperson@danski:~$ sudo apt install chromium-browser
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> The following packages will be upgraded:
> chromium-browser
> 1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
> 1 not fully installed or removed.
> Need to get 48.4 kB of archives.
> After this operation, 164 kB of additional disk space will be used.
> Get:1 http://nz.archive.ubuntu.com/ubuntu focal-updates/universe amd64
> chromium-browser amd64 81.0.4044.129-0ubuntu0.20.04.1 [48.4 kB]
> Fetched 48.4 kB in 0s (1,527 kB/s)
> Preconfiguring packages ...
> (Reading database ... 185728 files and directories currently installed.)
> Preparing to unpack
> .../chromium-browser_81.0.4044.129-0ubuntu0.20.04.1_amd64.deb ...
> => Installing the chromium snap
> ==> Checking connectivity with the snap store
> ==> Installing the chromium snap
> error: snap "chromium" has "install-snap" change in progress
> dpkg: error processing archive
> /var/cache/apt/archives/chromium-browser_81.0.4044.129-0ubuntu0.20.04.1_amd64.deb
> (--unpack):
> new chromium-browser package pre-installation script subprocess
> returned error exit status 10
> Errors were encountered while processing:
>
> /var/cache/apt/archives/chromium-browser_81.0.4044.129-0ubuntu0.20.04.1_amd64.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)
>
> ProblemType: Package
> DistroRelease: Ubuntu 20.04
> Package: chromium-browser 81.0.4044.129-0ubuntu0.20.04.1
> ProcVersionSignature: Ubuntu 5.4.0-40.44-generic 5.4.44
> Uname: Linux 5.4.0-40-generic x86_64
> ApportVersion: 2.20.11-0ubuntu27.3
> AptOrdering:
> chromium-browser:amd64: Install
> NULL: ConfigurePending
> Architecture: amd64
> CasperMD5CheckResult: skip
> Date: Mon Jul 6 23:39:11 2020
> Dependencies:
>
> ErrorMessage: new chromium-browser package pre-installation script
> subprocess returned error exit status 10
> InstallationDate: Installed on 2020-07-06 (0 days ago)
> InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64
> (20200423)
> Python3Details: /usr/bin/python3.8, Python 3.8.2, python3-minimal,
> 3.8.2-0ubuntu2
> PythonDetails: N/A
> RelatedPackageVersions:
> dpkg 1.19.7ubuntu3
> apt 2.0.2ubuntu0.1
> SourcePackage: chromium-browser
> Title: package chrom...

Read more...

Olivier Tilloy (osomon) wrote :

If so that kind of feedback isn't constructive, and this bug report isn't the right place for it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers