Does not register as x-www-browser alternative

Bug #1870640 reported by Daniel Richard G. on 2020-04-03
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
Low
Olivier Tilloy
Eoan
Low
Olivier Tilloy
Focal
Low
Olivier Tilloy

Bug Description

[Impact]

Low. When installing chromium-browser in eoan/focal (which is a transitional package that installs the chromium snap), update-alternatives cannot be used to set it as x-www-browser or gnome-www-browser. This is a regression compared to the version of chromium-browser in bionic.

[Test case]

# update-alternatives --set x-www-browser /usr/bin/chromium-browser
update-alternatives: error: alternative /usr/bin/chromium-browser for x-www-browser not registered; not setting

[Regression potential]

This is fixing a regression by adding back a code snippet that was in the package in bionic and previous releases. If the snippet has incorrect syntax, it could possibly prevent installation of the package. If the package installs fine, it's unlikely that anything could have regressed.

tags: added: focal
Olivier Tilloy (osomon) wrote :

Running:

    sudo update-alternatives --install /usr/bin/x-www-browser \
        x-www-browser /usr/bin/chromium-browser 40

as was done in the original postinst script for chromium-browser is enough to fix the problem.

Changed in chromium-browser (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Olivier Tilloy (osomon) wrote :

Also related (and should probably be fixed together with): bug #1815289.

Olivier Tilloy (osomon) wrote :
Changed in chromium-browser (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
status: Confirmed → Fix Committed
Changed in chromium-browser (Ubuntu Eoan):
assignee: nobody → Olivier Tilloy (osomon)
Changed in chromium-browser (Ubuntu Focal):
assignee: nobody → Olivier Tilloy (osomon)
Changed in chromium-browser (Ubuntu):
importance: Medium → Low
Changed in chromium-browser (Ubuntu Eoan):
importance: Undecided → Low
Changed in chromium-browser (Ubuntu Focal):
importance: Undecided → Low
Changed in chromium-browser (Ubuntu Eoan):
status: New → Confirmed
Changed in chromium-browser (Ubuntu Focal):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package chromium-browser - 81.0.4044.129-0ubuntu1

---------------
chromium-browser (81.0.4044.129-0ubuntu1) groovy; urgency=medium

  * New upstream release: 81.0.4044.129
  * debian/control:
    - update Vcs-Bzr URL to point to the branch for 20.10
      (codename the Groovy Gorilla)
    - add x-www-browser and gnome-www-browser to the Provides section
      (LP: #1815289)
  * debian/chromium-browser.postinst: install /usr/bin/chromium-browser as an
    alternative for x-www-browser and gnome-www-browser (LP: #1870640)

 -- Olivier Tilloy <email address hidden> Thu, 30 Apr 2020 14:48:00 +0200

Changed in chromium-browser (Ubuntu):
status: Fix Committed → Fix Released
Olivier Tilloy (osomon) on 2020-05-04
Changed in chromium-browser (Ubuntu Eoan):
status: Confirmed → In Progress
Changed in chromium-browser (Ubuntu Focal):
status: Confirmed → In Progress
Olivier Tilloy (osomon) on 2020-05-05
description: updated
Łukasz Zemczak (sil2100) wrote :

This is a relatively low-priority bug (so normally not the best candidate for an SRU), but seeing that focal is an LTS (and it was working properly in bionic) + this being a small package update, I'll accept it into focal-proposed. Thanks!

Changed in chromium-browser (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-focal

Hello Daniel, or anyone else affected,

Accepted chromium-browser into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/chromium-browser/81.0.4044.129-0ubuntu0.20.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

All autopkgtests for the newly accepted chromium-browser (81.0.4044.129-0ubuntu0.20.04.1) for focal have finished running.
The following regressions have been reported in tests triggered by the package:

libwwwbrowser-perl/2.23-3 (ppc64el)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/focal/update_excuses.html#chromium-browser

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Daniel Richard G. (skunk) wrote :

Oliver and Łukasz, thank you for following this up.

So that I understand, in focal, is the fix part of the transitional package, not in the snap?

The former is described as "This is a transitional dummy package. It can safely be removed," but would removing it then remove Chromium as an x-www-browser alternative? (Because that would arguably contradict the "safely")

Olivier Tilloy (osomon) wrote :

@Daniel: that's correct, the fix is part of the transitional package. It's transitional in a slightly different acceptance of the term though, because it installs a snap, not another deb package. And snaps don't have any mechanism to run update-alternatives as part of their install process. So this is the best we can do with what we have.

Olivier Tilloy (osomon) wrote :

Confirmed fixed with chromium-browser 81.0.4044.129-0ubuntu0.20.04.1 from focal-proposed.

I verified update-alternatives couldn't be used to set the default value of [x-www-browser|gnome-www-browser] to /usr/bin/chromium-browser in a fully up-to-date focal VM, then I enabled focal-proposed for universe, ran "apt update" and "apt dist-upgrade" to install the updated chromium-browser package, and I verified that update-alternatives now accepted to set the default x-www-browser|gnome-www-browser. I also verified that running x-www-browser|gnome-www-browser did launch chromium-browser, as expected.

tags: added: verification-done-focal
removed: verification-needed-focal
Mathew Hodson (mhodson) on 2020-05-11
tags: added: packaging
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package chromium-browser - 81.0.4044.129-0ubuntu0.20.04.1

---------------
chromium-browser (81.0.4044.129-0ubuntu0.20.04.1) focal; urgency=medium

  * New upstream release: 81.0.4044.129
  * debian/control: add x-www-browser and gnome-www-browser to the Provides
    section (LP: #1815289)
  * debian/chromium-browser.postinst: install /usr/bin/chromium-browser as an
    alternative for x-www-browser and gnome-www-browser (LP: #1870640)

 -- Olivier Tilloy <email address hidden> Thu, 30 Apr 2020 16:30:05 +0200

Changed in chromium-browser (Ubuntu Focal):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for chromium-browser has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Hello Daniel, or anyone else affected,

Accepted chromium-browser into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/chromium-browser/81.0.4044.129-0ubuntu0.19.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-eoan to verification-done-eoan. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-eoan. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in chromium-browser (Ubuntu Eoan):
status: In Progress → Fix Committed
tags: added: verification-needed-eoan
Olivier Tilloy (osomon) wrote :

Confirmed fixed with chromium-browser 81.0.4044.129-0ubuntu0.19.10.1 from focal-proposed.

I verified update-alternatives couldn't be used to set the default value of [x-www-browser|gnome-www-browser] to /usr/bin/chromium-browser in a fully up-to-date focal VM, then I enabled focal-proposed for universe, ran "apt update" and "apt dist-upgrade" to install the updated chromium-browser package, and I verified that update-alternatives now accepted to set the default x-www-browser|gnome-www-browser. I also verified that running x-www-browser|gnome-www-browser did launch chromium-browser, as expected.

Olivier Tilloy (osomon) wrote :

s/focal-proposed/eoan-proposed/ in the above comment, obviously…

tags: added: verification-done-eoan
removed: verification-needed-eoan
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package chromium-browser - 81.0.4044.129-0ubuntu0.19.10.1

---------------
chromium-browser (81.0.4044.129-0ubuntu0.19.10.1) eoan; urgency=medium

  * New upstream release: 81.0.4044.129
  * debian/control: add x-www-browser and gnome-www-browser to the Provides
    section (LP: #1815289)
  * debian/chromium-browser.postinst: install /usr/bin/chromium-browser as an
    alternative for x-www-browser and gnome-www-browser (LP: #1870640)

 -- Olivier Tilloy <email address hidden> Thu, 30 Apr 2020 16:34:30 +0200

Changed in chromium-browser (Ubuntu Eoan):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers