[Snap] Install the widevine binary upon request in Chromium

Bug #1863258 reported by Michel-Ekimia on 2020-02-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
Wishlist
Unassigned

Bug Description

Use case :

- Start a video on netflix.com ( with chrome/ubuntu user agent )
- Get a mysterious Netflix Error saying your browser is not supported
- Start Firefox and watch your video

Solution :

- Detects when browsing a website that may need widevine ( see how firefox team did )

- ask user if he wants this non-free binary plugin

- Run some script like https://gist.github.com/ruario/3c873d43eb20553d5014bd4d29fe37f1 that would copy the widevine plugin in snap user directory

Notes :

To test if Widevine Works : https://bitmovin.com/demos/drm

- Widevine versions and binary url from mozilla https://hg.mozilla.org/releases/mozilla-beta/file/default/toolkit/content/gmp-sources/widevinecdm.json

tags: added: bionic focal
Olivier Tilloy (osomon) on 2020-02-14
Changed in chromium-browser (Ubuntu):
importance: Undecided → Wishlist
description: updated
summary: - Install the widevine binary upon request in Chromium snap
+ [Snap] Install the widevine binary upon request in Chromium snap
summary: - [Snap] Install the widevine binary upon request in Chromium snap
+ [Snap] Install the widevine binary upon request in Chromium
Michel-Ekimia (michel.ekimia) wrote :

Brave have implented their own Widevine module downloader :

https://github.com/brave/brave-browser/pull/3300/files

Olivier Tilloy (osomon) on 2020-04-24
tags: added: snap
Michel-Ekimia (michel.ekimia) wrote :

For some reason , chromium 81 installed automatically the widevine component now , and only a restart of chromium is need to have Widevine working.

THis could be because in snap mode it can write on its own lib directory.

description: updated
Olivier Tilloy (osomon) wrote :

I can confirm chromium now automatically installs a local copy of Widevine (in ~/.config/chromium/WidevineCdm), and this appears to work both in the deb packages and in the snap. Only a restart is required to enable the CDM. The version of Widevine can be checked by browsing to chrome://components.

In my tests this works on amd64, but not on i386.

The UX isn't great because it's not discoverable, there's no user feedback and a manual restart is required, as opposed to the way Firefox handles it, but it's nevertheless a big step forward.

I wonder whether this might be a consequence of https://chromium.googlesource.com/chromium/src/+/b5e9a646f5ac2eee57fb0c8cc545f18aa50bd994 ?
Although Michel you said it started happening with chromium 81 ?

Olivier Tilloy (osomon) wrote :

I'm tentatively closing this bug, because despite the less-than-ideal UX, the functionality is essentially already implemented upstream now.

Changed in chromium-browser (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers