Chromium/Chrome/Electron look tiny in hidpi after gnome shell restart

Bug #1848841 reported by Carlos Pita on 2019-10-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
Undecided
Unassigned

Bug Description

(upstream bug: https://bugs.chromium.org/p/chromium/issues/detail?id=1043494)

My screen is 3000x2000. I use a scaling factor of 2x. Today I upgraded to 19.10 and chromium became a snap package. It launches at the right scaling factor, but if I restart gnome shell (Alt-F2 r) it rescales to 1x (I believe) and everything becomes absurdly tiny. Restarting chromium afterwards restores the right scaling factor.

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: chromium-browser 77.0.3865.120-0ubuntu1~snap1
ProcVersionSignature: Ubuntu 5.3.0-18.19-generic 5.3.1
Uname: Linux 5.3.0-18-generic x86_64
ApportVersion: 2.20.11-0ubuntu8
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
DRM.card0-DP-1:
 enabled: disabled
 dpms: Off
 status: disconnected
 edid-base64:
 modes:
DRM.card0-DP-2:
 enabled: disabled
 dpms: Off
 status: disconnected
 edid-base64:
 modes:
DRM.card0-HDMI-A-1:
 enabled: disabled
 dpms: Off
 status: disconnected
 edid-base64:
 modes:
DRM.card0-eDP-1:
 enabled: enabled
 dpms: On
 status: connected
 edid-base64: AP///////wBRmIgTAAAAACobAQSlHRR4Asr8pFZPnicOT1UAAAABAQEBAQEBAQEBAQEBAQEBuJi4oLDQPnAwIDUAJcQQAAAaAAAAAAAAAAAAAAAAAAAAAAAYAAAA/gBUSUFOTUEgWE0gAAAAAAAA/wBUTDEzOUdEWFAwMQAAAF8=
 modes: 3000x2000
Date: Sat Oct 19 05:11:37 2019
DiskUsage:
 Filesystem Type Size Used Avail Use% Mounted on
 /dev/nvme0n1p2 ext4 331G 62G 255G 20% /
 tmpfs tmpfs 7,8G 75M 7,7G 1% /dev/shm
 /dev/nvme0n1p2 ext4 331G 62G 255G 20% /
InstallationDate: Installed on 2019-06-13 (127 days ago)
InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 05c8:03c0 Cheng Uei Precision Industry Co., Ltd (Foxlink) HD Camera
 Bus 001 Device 002: ID 8087:0a2b Intel Corp.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: HUAWEI MACH-WX9
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-18-generic root=UUID=08b323c0-f1a9-46a9-8d2c-694dff8193f6 ro quiet splash vt.handoff=7
Snap.ChromeDriverVersion: ChromeDriver 77.0.3865.120 (416d6d8013e9adb6dd33b0c12e7614ff403d1a94-refs/branch-heads/3865@{#884})
Snap.ChromiumVersion: Chromium 77.0.3865.120 snap
SourcePackage: chromium-browser
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/28/2018
dmi.bios.vendor: HUAWEI
dmi.bios.version: 1.17
dmi.board.name: MACH-WX9-PCB
dmi.board.vendor: HUAWEI
dmi.board.version: M14
dmi.chassis.type: 10
dmi.chassis.vendor: HUAWEI
dmi.chassis.version: M14
dmi.modalias: dmi:bvnHUAWEI:bvr1.17:bd07/28/2018:svnHUAWEI:pnMACH-WX9:pvrM14:rvnHUAWEI:rnMACH-WX9-PCB:rvrM14:cvnHUAWEI:ct10:cvrM14:
dmi.product.family: HUAWEI MateBook X
dmi.product.name: MACH-WX9
dmi.product.sku: C128
dmi.product.version: M14
dmi.sys.vendor: HUAWEI

Carlos Pita (carlosjosepita) wrote :
Olivier Tilloy (osomon) wrote :

Thanks for the report Carlos. From your description, it sounds like this is a regression, i.e. restarting gnome-shell with a running instance of chromium packaged as a deb would not rescale to 1x. Is that correct?

Changed in chromium-browser (Ubuntu):
status: New → Incomplete
Carlos Pita (carlosjosepita) wrote :

Hi Olivier, sorry for the delay, I've installed Chrome from the official deb and it also happens there so it seems like a non-snap specific, upstream bug.

Do you have any idea what kind of "signal" could the app be receiving when shell restarts? It's really weird that it somehow resets to 1x scale.

summary: - Chromium snap looks tiny in hidpi after gnome shell restart
+ Chromium/Chrome looks tiny in hidpi after gnome shell restart

Not off the top of my head, but if you're familiar with GTK code, you might be able to dig it up at https://cs.chromium.org/chromium/src/chrome/browser/ui/libgtkui/?sq=package:chromium.

Would you mind filing an upstream bug report at https://bugs.chromium.org/p/chromium/issues/list and sharing the link to it here?

Changed in chromium-browser (Ubuntu):
status: Incomplete → New
Carlos Pita (carlosjosepita) wrote :

Done in https://bugs.chromium.org/p/chromium/issues/detail?id=1043494, should I also report this to Gnome Gitlab?

Btw, the problem also happens with VSCode, which is not surprising given that it's an Electron based app.

Olivier Tilloy (osomon) wrote :

Thanks for the upstream bug Carlos.
I don't think it's a bug in the GNOME stack, given that you observe it only in chrome/chromium and electron apps.

description: updated
summary: - Chromium/Chrome looks tiny in hidpi after gnome shell restart
+ Chromium/Chrome/Electron look tiny in hidpi after gnome shell restart
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers