[snap] chromium-browser accessing files outside /mnt /media

Bug #1832711 reported by Chris Guiver
This bug affects 10 people
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)

Bug Description

I tried to drag-drop a photo from `pcmanfm-qt` to chromium-browser for publishing in a mewe collection; but it wouldn't drag/drop. My photos are stored in /de2900/photos/lumix/

Next I tried to navigate to that directory for upload from chromium using the upload feature, but I was unable to navigate to my NFS storage to grab a photos (either /de2900 or /pe2900)

This was tried first on my d960 (dell 960) primary box, but also on my d780 (dell 780) both running Lubuntu 19.10 with similar results.

If I selected the HOME folder (just below Recent) I expected it to navigate to the /home/guiverc/ folder, but it would go to $HOME/snap/chromium/733/ on my d960, or $HOME/snap/chromium/750/ on my d780 box. The Home view would be the same if I clicked any NFS share (de2900, ds2900, pe2900).

The Documents, Downloads, Music, Pictures, Videos appeared to work as expected (most of those folders are empty on my boxes; all my files are on my NFS shares)

( Olivier Tilloy [oSoMoN] requested this on community.ubuntu.com)

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: chromium-browser 75.0.3770.80-0ubuntu1~snap2
ProcVersionSignature: Ubuntu 5.0.0-13.14-generic 5.0.6
Uname: Linux 5.0.0-13-generic x86_64
ApportVersion: 2.20.11-0ubuntu3
Architecture: amd64
CurrentDesktop: LXQt
 enabled: enabled
 dpms: On
 status: connected
 modes: 1280x1024 1280x1024 1152x864 1024x768 1024x768 800x600 800x600 640x480 640x480 720x400
 enabled: enabled
 dpms: On
 status: connected
 modes: 1280x1024 1280x1024 1152x864 1024x768 1024x768 800x600 800x600 640x480 640x480 720x400
 enabled: disabled
 dpms: On
 status: disconnected
Date: Thu Jun 13 20:05:24 2019
 Filesystem Type Size Used Avail Use% Mounted on
 /dev/sda2 ext4 601G 68G 503G 12% /
 tmpfs tmpfs 3.9G 89M 3.8G 3% /dev/shm
 /dev/sda2 ext4 601G 68G 503G 12% /
InstallationDate: Installed on 2019-04-17 (57 days ago)
InstallationMedia: Lubuntu 18.10 "Cosmic Cuttlefish" - Release amd64 (20181017.2)
MachineType: Dell Inc. OptiPlex 780
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.0.0-13-generic root=UUID=c9fd534a-d678-4301-8d49-760c516343f5 ro quiet splash vt.handoff=1
Snap.ChromeDriverVersion: ChromeDriver 75.0.3770.80 (9a9aa15057b6b2cc0909bdcf638c0b65ecd516f2-refs/branch-heads/3770@{#948})
Snap.ChromiumVersion: Chromium 75.0.3770.80 snap
SourcePackage: chromium-browser
UpgradeStatus: Upgraded to eoan on 2019-04-17 (57 days ago)
dmi.bios.date: 02/13/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A03
dmi.board.name: 0200DY
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 3
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA03:bd02/13/2010:svnDellInc.:pnOptiPlex780:pvr:rvnDellInc.:rn0200DY:rvrA00:cvnDellInc.:ct3:cvr:
dmi.product.name: OptiPlex 780
dmi.sys.vendor: Dell Inc.

Revision history for this message
Chris Guiver (guiverc) wrote :
Revision history for this message
Chris Guiver (guiverc) wrote :

this is the image as I uploaded to community.ubuntu.com. The primary difference on this was the lack of icons to the left in the file-open dialog window.

this image was from d960 (my primary box) and is more likely modified as I use it all the time. The prior image (which has icons in visible in this dialog window) would be less used, less modified (more defaults), and the primary issue of navigation was identical on both boxes.

-- d960 appearance settings (which lacked icons)
Qt Style: Breeze
GTK2 Theme: Radiant-MATE
GTK3 Theme: Radiant-MATE
Icons Theme: Papirus (Papirus icon theme)
LXQt Theme: Ambiance

Revision history for this message
Chris Guiver (guiverc) wrote :

Copy/Paste from https://community.ubuntu.com/t/call-for-testing-chromium-browser-deb-to-snap-transition/11179/13

As I can access these directories with Firefox and Chrome is this something that needs to be fixed or is it a consequence of using a snap?

This is indeed a feature of the snap confinement, it won’t let the application see files on the host system (save for a few exceptions, like $HOME). I’m aware this is mildly annoying when wanting to attach e.g. log files to a bug report. Not much can be done about it, though.

Which will be my primary issue in this report, ie. where I wanted to upload files from is my /de2900/ NFS share.

Revision history for this message
Olivier Tilloy (osomon) wrote :

The HOME folder shortcut is a known issue: https://github.com/ubuntu/snapcraft-desktop-helpers/issues/167.

If you connect the removable-media plug, you should be able to access files and directories mounted under /mnt and /media. That won't resolve your issue with NFS shares seamlessly, but maybe you can mount them there?

Revision history for this message
Chris Guiver (guiverc) wrote :

Yep, by running

"snap connect chromium:removable-media"

I can upload via drag&drop, plus navigation (with pcmanfm-qt) to /mnt/de2900/ on my d960 .

Revision history for this message
Chris Guiver (guiverc) wrote :

Also there were icons on the left of the navigation window this time on d960 unlike prior uploaded photo in comment #2. (I have rebooted since photo was taken)

In last comment (#5) I wrongly used `pcmanfm-qt`; drag&drop was from pcmanfm-qt, navigation was by whatever chromium called... sorry.

Lenin (gagarin)
summary: - chromium-browser snap quirks lubuntu 19.10 bookmarks
+ [snap] chromium-browser snap quirks lubuntu 19.10 bookmarks
Revision history for this message
Launchpad Janitor (janitor) wrote : Re: [snap] chromium-browser snap quirks lubuntu 19.10 bookmarks

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in chromium-browser (Ubuntu):
status: New → Confirmed
Revision history for this message
Bhabba (bhabba) wrote :

Still the same issue under Ubuntu 20.04.


snap connect chromium:removable-media

enables access to files on removable media (mounted under `/media` or `/mnt`).

Revision history for this message
Sebastien Bacher (seb128) wrote :

Could someone update the title to describe the issue better, what does 'snap quirks bookmarks' means? some comments seem about the need to connect the removable-media interface, others about NFS shares, what's the issue described there?

Changed in chromium-browser (Ubuntu):
importance: Undecided → Low
Chris Guiver (guiverc)
summary: - [snap] chromium-browser snap quirks lubuntu 19.10 bookmarks
+ [snap] chromium-browser accessing files outside /mnt /media
To post a comment you must log in.