chromium-browser deb->snap transition breaks ubuntukylin image builds

Bug #1832656 reported by Steve Langasek on 2019-06-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
Status tracked in Eoan
Eoan
High
Olivier Tilloy
livecd-rootfs (Ubuntu)
Status tracked in Eoan
Eoan
High
Unassigned
ubuntukylin-meta (Ubuntu)
Status tracked in Eoan
Eoan
High
handsome_feng

Bug Description

From https://launchpad.net/~ubuntu-cdimage/+livefs/ubuntu/eoan/ubuntukylin/+build/169881:

Preparing to unpack .../000-chromium-browser_75.0.3770.80-0ubuntu1~snap2_amd64.deb ...
=> Installing the chromium snap
==> Checking connectivity with the snap store
===> Unable to contact the store, trying every minute for the next 30 minutes
===> Still unable to contact the store, trying for another 20 minutes
===> Still unable to contact the store, trying for another 10 minutes
===> Still unable to contact the store, aborting
dpkg: error processing archive /tmp/apt-dpkg-install-43SUPL/000-chromium-browser_75.0.3770.80-0ubuntu1~snap2_amd64.deb (--unpack):
 new chromium-browser package pre-installation script subprocess returned error exit status 1

It is possible that the flavors should switch to seeding the snap instead of the deb. However, it's unclear to me why the deb is failing to talk to the Snap Store, because seeding of snaps DOES work from within image builds.

Steve Langasek (vorlon) on 2019-06-12
Changed in chromium-browser (Ubuntu Eoan):
importance: Undecided → High
Changed in ubuntukylin-meta (Ubuntu Eoan):
importance: Undecided → High
Olivier Tilloy (osomon) on 2019-06-13
Changed in chromium-browser (Ubuntu Eoan):
assignee: nobody → Olivier Tilloy (osomon)
Olivier Tilloy (osomon) wrote :

I can reproduce the problem when building a dummy package that build-depends on chromium-browser in a PPA.

Laney suggests that setting SNAPPY_STORE_NO_CDN=1 in the image build environment might help (this is done in livecd-rootfs).

In any case, it would be a good idea to update the ubuntukylin seeds to include the snap instead of the deb.

Changed in ubuntukylin-meta (Ubuntu Eoan):
assignee: nobody → handsome_feng (feng-kylin)
handsome_feng (feng-kylin) wrote :

I have updated the ubuntukylin seeds, and made a debdiff of ubuntukylin-meta, could some help to upload it? Thanks!

tags: added: patch
Steve Langasek (vorlon) wrote :

The debdiff looks fine, sponsoring.

Please note that there is a draft policy of the requirements around seeding of snaps on Ubuntu images, which applies to flavors as well https://wiki.ubuntu.com/UbuntuSeededSnaps

The UbuntuKylin team should assure themselves that these requirements are met.

Note in particular if the chromium snap does not have the set of channels required by this policy the image will still fail to build.

Steve Langasek (vorlon) wrote :

opening a task on livecd-rootfs about the question of injecting SNAPPY_STORE_NO_CDN=1 into the image build environment.

Changed in livecd-rootfs (Ubuntu Eoan):
importance: Undecided → High
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntukylin-meta - 0.37

---------------
ubuntukylin-meta (0.37) eoan; urgency=medium

  * Update update.cfg for eoan
  * disco->eoan
  * Refreshed dependencies
  * Removed chromium-browser from desktop-recommends. LP: #1832656.

 -- handsome_feng <email address hidden> Fri, 14 Jun 2019 16:32:50 +0800

Changed in ubuntukylin-meta (Ubuntu Eoan):
status: New → Fix Released
handsome_feng (feng-kylin) wrote :

Hi, Steve,

You are right, ubuntu kylin daily failed to build due to "failed to get details for 'chromium' in 'stable/ubuntu-19.10' on 'amd64': No revision was found in the Store.", So which is the correct way to seeds chromium? Should I change the seeds entry to something like "snap: chromium/stable" or just wait chromium release to the stable/ubuntu-19.10 channel?

Thanks in advance!

Olivier Tilloy (osomon) wrote :

I have opened and closed the stable/ubuntu-19.10 channel, all 4 supported architectures were published there. Please let me know if anything else is needed to make the preseeding work on Kylin.

Changed in chromium-browser (Ubuntu Eoan):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers