Can't use the extensions provided by the webext-* packages

Bug #1818549 reported by Paride Legovini on 2019-03-04
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
browserpass (Ubuntu)
Undecided
Unassigned
chromium-browser (Ubuntu)
Medium
Unassigned
ublock-origin (Ubuntu)
Undecided
Unassigned

Bug Description

chromium-browser seems to ignore the extensions installed using the webext-* packages, e.g.

webext-ublock-origin
webext-browserpass

The extensions simply do not show up anywhere in Chromium, while they work fine in Firefox. These webext packages are syncs from Debian, and on Debian systems they correctly show up both in Firefox and Chromium (installed using the 'chromium' Debian package).

I'm running an up-to-date disco, with chromium-browser 72.0.3626.96-0ubuntu1. I didn't try with any previous version, so I don't know if the problem is a regression.

Paride

Olivier Tilloy (osomon) wrote :

Confirmed, chromium doesn't list the extensions installed by those packages.
However if I go to chrome://extensions, I can click on the button to load an unpacked extension, and point the file picker to /usr/share/chromium/extensions/ublock-origin, and the extension is correctly loaded.

Changed in chromium-browser (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Andreas Schildbach (schildbach) wrote :

There is a separate package chromium-ublock-origin. Maybe try that one for Chromium?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in browserpass (Ubuntu):
status: New → Confirmed
Changed in ublock-origin (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers