[snap] core18-based snap fails to start on Solus/fedora29

Bug #1808959 reported by Girtablulu on 2018-12-18
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
snapd
Undecided
Unassigned
chromium-browser (Ubuntu)
Undecided
Unassigned

Bug Description

After installation of chromium and I try to start it I get this error inside my terminal.

fredu  ~  chromium
execv failed: No such file or directory

System:
Description: Solus
Release: 3.9999

Chromium: stable
snapd: 2.36.2

Olivier Tilloy (osomon) wrote :

It looks like this might be similar to what's being observed on Fedora 29 (https://forum.snapcraft.io/t/error-lunching-gitkraken/8524/).

Can you please test from the stable/core16 channel, and report whether this works better?

    sudo snap refresh chromium --channel=stable/core16

tags: added: snap
Girtablulu (girt) wrote :

@Olivier

yep this fixed it, by starting it with core 16

Olivier Tilloy (osomon) wrote :

Thanks for the confirmation.

summary: - [snap] Chromium errors with execv failed at start
+ [snap] core18-based snap fails to start on Solus

I'm also trying to run the Chromium snap on Solus, I get the same error.

I don't think the solution to use core 16 is right, due to the old Chromium version that comes with it.

Is it possible to maintain the core 16 version of Chromium as well?

Olivier Tilloy (osomon) wrote :

The core18 version of the chromium snap is the only supported and maintained version now.

The stable/core16 channel is provided only as a short-term workaround for a bug that should be addressed in snapd on Fedora 29 / Solus.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in chromium-browser (Ubuntu):
status: New → Confirmed
Henrik Steen (henkesteen) wrote :

FYI, this is still an issue.

Cody Hodges (cody35367) wrote :

I am experiencing this same issue on Fedora 29 after installing the Krita snap. It is using core18 also.

krita:
execl failed: No such file or directory
child exited with status 1

snap 2.37.2-1.fc29
snapd 2.37.2-1.fc29
series 16
fedora 29
kernel 4.20.8-200.fc29.x86_64

core18 18 719 stable
krita 4.1.7.101 44 stable

Olivier Tilloy (osomon) wrote :

Fully up-to-date Fedora 29 VM, the chromium snap still fails to launch with the same error.

summary: - [snap] core18-based snap fails to start on Solus
+ [snap] core18-based snap fails to start on Solus/fedora29
Girtablulu (girt) wrote :

I just found the issue with our solus snapd package, I had to build snap-exec static and after this chromium snap starts again.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers