H264 missing from WebRTC (regression)

Bug #1763662 reported by Ben on 2018-04-13
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
Medium
Olivier Tilloy

Bug Description

H264 is missing from WebRTC in Chromium 65.0.3325.181.
This is a regression. It worked in Chromium 64.0.3282.167.
According to the webrtc team it might be because of a missing flag [1].

Steps to reproduce:
1. Install Chromium on Ubuntu 16.04: sudo apt-get install -y chromium-browser chromium-codecs-ffmpeg-extra
2. open a tab with chrome://webrtc-internals
3. Create a room in https://appr.tc and join the room.
3. Check the SDP offer in webrtc-internals. Select the https://appr.tc/r/<room-id> tab and click on the createOfferOnSuccess event.

We should have H264 in the SDP offer but it's missing:
a=rtpmap:100 H264/90000

[1] https://bugs.chromium.org/p/webrtc/issues/detail?id=9096

Edgardo Gho (edgardo-g) wrote :

Same issue here.
But I don't read the webrtc team description as a missing flag.
Even with the flag I think it still does not work.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in chromium-browser (Ubuntu):
status: New → Confirmed
Edgardo Gho (edgardo-g) wrote :

Ben, you are correct, its a flag issue.
I compiled CEF (based on Chromium), branch 3359 (Chrome 66) and I used:
rtc_use_h264 = true
and I have h264 support. Without that, using the regular:
GN_DEFINES=is_official_build=true ffmpeg_branding=Chrome proprietary_codecs=true
It did not work.

Maybe the check for is_chrome_branded is bad and it always return false... or maybe the above GN defines are not properly setting it.

Olivier Tilloy (osomon) wrote :

https://webrtc.googlesource.com/src.git/+/d3070f43b19f503246be4ebad425d87568a71ce0 appears to be the cause of the regression. It was later reverted (https://webrtc.googlesource.com/src.git/+/3bb1194fff251bb63062aa1a807ee7107779f36b), but I guess that wasn't backported to branches 65 and 66.

Forcing rtc_use_h264 to true in the build flags should do the trick.

Changed in chromium-browser (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Olivier Tilloy (osomon)
Olivier Tilloy (osomon) wrote :

chromium-browser 66.0.3359.106-0ubuntu1 currently building in https://launchpad.net/~chromium-team/+archive/ubuntu/beta/+packages with rtc_use_h264=true. Once built, let's see if this fixes the problem.

Changed in chromium-browser (Ubuntu):
status: Confirmed → In Progress
Olivier Tilloy (osomon) wrote :

I tested the 66.0.3359.106-0ubuntu2 build in the beta PPA and H264 is available to WebRTC.

Olivier Tilloy (osomon) on 2018-04-17
Changed in chromium-browser (Ubuntu):
status: In Progress → Fix Committed
Ben (ben-browitt) wrote :

Chrome 66 was released on April 17th.
When Chromium 66 is planned to be released?
Any reason not to sync Chrome and Chromium releases?

Olivier Tilloy (osomon) wrote :

Packages for chromium-browser are usually published shortly after chrome is released.
In this case though, this week is release time for Ubuntu 18.04, so chromium will make its way to the updates after the dust settles (some time next week).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package chromium-browser - 66.0.3359.139-0ubuntu1

---------------
chromium-browser (66.0.3359.139-0ubuntu1) cosmic; urgency=medium

  * No-change rebuild for the Cosmic Cuttlefish (18.10)

 -- Olivier Tilloy <email address hidden> Tue, 08 May 2018 21:59:31 +0200

Changed in chromium-browser (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers