[snap] camera access doesn't work, even after connecting camera interface

Bug #1741253 reported by Olivier Tilloy on 2018-01-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
Undecided
Unassigned

Bug Description

$ snap info chromium
tracking: candidate
installed: 63.0.3239.108 (192) 164MB -
refreshed: 2017-12-18 22:08:42 +0100 CET

After connecting the camera interface (snap connect chromium:camera :camera), when browsing to e.g. https://davidwalsh.name/demo/camera.php I get prompted to allow camera usage, but the frame remains empty, it looks like the webcam is not capturing anything.

Olivier Tilloy (osomon) wrote :

Nevermind, it works if I don't have another browser tab already capturing video.

Changed in chromium-browser (Ubuntu):
status: New → Opinion
status: Opinion → Invalid
Julian Alarcon (julian-alarcon) wrote :

I guess that Oliver answer is a good workaround:
sudo snap connect chromium:camera :camera

But I think that this should be fixed, by default camera access should be granted, or when the notification appear, the permissions should be granted.

Changed in chromium-browser (Ubuntu):
status: Invalid → Confirmed
Olivier Tilloy (osomon) wrote :

A bug report is not the right place to request auto-connection of the camera interface. I have done that on the forum: https://forum.snapcraft.io/t/auto-connecting-the-camera-interface-for-the-chromium-snap/4014.

Changed in chromium-browser (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers