chromium-browser (GPU process) crashed with SIGILL in sw::Constants::Constants()

Bug #1727279 reported by alpha_command@hotmail.co.uk on 2017-10-25
74
This bug affects 7 people
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
Medium
Unassigned

Bug Description

The browser never crashed so I am assuming that it was a background service that crashed...

I am using Ubuntu 17.10, with Wayland desktop, hope that helps fix the problem.

If you need more info let me know...

Thanks

Chris

ProblemType: Crash
DistroRelease: Ubuntu 17.10
Package: chromium-browser 62.0.3202.62-0ubuntu0.17.10.1380
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Uname: Linux 4.13.0-16-generic x86_64
ApportVersion: 2.20.7-0ubuntu3
Architecture: amd64
DRM.card0-DP-1:
 enabled: disabled
 dpms: On
 status: disconnected
 edid-base64:
 modes:
DRM.card0-DVI-D-1:
 enabled: disabled
 dpms: On
 status: disconnected
 edid-base64:
 modes:
DRM.card0-DVI-I-1:
 enabled: enabled
 dpms: On
 status: connected
 edid-base64: AP///////wAebblaK7QFAAMZAQNsMBt46jE1pVVOoSYMUFSlSwBxT4GAlQCzAKnAgQCBwJBAAjqAGHE4LUBYLEUA4A4RAAAeAAAA/QA4Sx5TDwAKICAgICAgAAAA/ABMRyBGVUxMIEhECiAgAAAA/wA1MDNORENSQVo4MDMKAMI=
 modes: 1920x1080 1680x1050 1400x1050 1600x900 1280x1024 1280x1024 1440x900 1280x800 1152x864 1280x720 1024x768 1024x768 800x600 800x600 640x480 640x480 720x400
DRM.card0-HDMI-A-1:
 enabled: disabled
 dpms: On
 status: disconnected
 edid-base64:
 modes:
Date: Wed Oct 25 11:43:44 2017
Desktop-Session:
 'ubuntu'
 '/etc/xdg/xdg-ubuntu:/etc/xdg'
 '/usr/share/ubuntu:/usr/local/share:/usr/share:/var/lib/snapd/desktop'
DetectedPlugins:

EcryptfsInUse: Yes
Env:
 'None'
 'None'
ExecutablePath: /usr/lib/chromium-browser/chromium-browser
InstallationDate: Installed on 2017-05-12 (165 days ago)
InstallationMedia: Ubuntu 16.04.2 LTS "Xenial Xerus" - Release amd64 (20170215.2)
Load-Avg-1min: 2.61
Load-Processes-Running-Percent: 0.2%
MachineType: Gigabyte Technology Co., Ltd. GA-MA790FX-DQ6
ProcCmdline: /usr/lib/chromium-browser/chromium-browser\ --type=gpu-process\ --field-trial-handle=2755303059530326476,17940427599822917474,131072\ --use-gl=swiftshader-webgl\ --disable-accelerated-video-decode\ --gpu-vendor-id=0x1002\ --gpu-device-id=0x6818\ --gpu-driver-vendor=Google\ Inc.\ --gpu-driver-version=3.3.0.2\ --gpu-driver-date=2017/04/07\ --service-request-channel-token=DFA5B133C7D7F01A7E138D67C7CBE130
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.0-16-generic root=UUID=82d44741-b0c4-4470-9d35-1ca614cb42ad ro quiet splash vt.handoff=7
Signal: 4
SourcePackage: chromium-browser
StacktraceTop:
 () at /usr/lib/chromium-browser/swiftshader/libGLESv2.so
 call_init (l=<optimised out>, argc=argc@entry=11, argv=argv@entry=0x7ffc7ad71ab8, env=env@entry=0x7ffc7ad71b18) at dl-init.c:72
 call_init (env=0x7ffc7ad71b18, argv=0x7ffc7ad71ab8, argc=11, l=<optimised out>) at dl-init.c:30
 _dl_init (main_map=main_map@entry=0x559a93542e40, argc=11, argv=0x7ffc7ad71ab8, env=0x7ffc7ad71b18) at dl-init.c:120
 dl_open_worker (a=a@entry=0x7ffc7ad70540) at dl-open.c:575
Title: chromium-browser crashed with SIGILL
UpgradeStatus: Upgraded to artful on 2017-10-19 (6 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo video
dmi.bios.date: 04/29/2009
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F7b
dmi.board.name: GA-MA790FX-DQ6
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF7b:bd04/29/2009:svnGigabyteTechnologyCo.,Ltd.:pnGA-MA790FX-DQ6:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-MA790FX-DQ6:rvr:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-MA790FX-DQ6
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
modified.conffile..etc.default.chromium-browser: [deleted]

StacktraceTop:
 Constants () at ../../third_party/swiftshader/src/Shader/Constants.cpp:249
 call_init (l=<optimized out>, argc=argc@entry=11, argv=argv@entry=0x7ffc7ad71ab8, env=env@entry=0x7ffc7ad71b18) at dl-init.c:72
 call_init (env=0x7ffc7ad71b18, argv=0x7ffc7ad71ab8, argc=11, l=<optimized out>) at dl-init.c:30
 _dl_init (main_map=main_map@entry=0x559a93542e40, argc=11, argv=0x7ffc7ad71ab8, env=0x7ffc7ad71b18) at dl-init.c:120
 dl_open_worker (a=a@entry=0x7ffc7ad70540) at dl-open.c:575

Changed in chromium-browser (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in chromium-browser (Ubuntu):
status: New → Confirmed
Olivier Tilloy (osomon) wrote :

Thank you for the report Chris. It looks like what crashed is the GPU helper process, and I assume that means you don't get hardware acceleration in the browser. Did you get that crash report shortly after launching the browser? Did you get it again since then? Could you please point chromium to "chrome://gpu" (in the address bar), save the resulting page and attach it here? Thanks!

Olivier Tilloy (osomon) on 2017-11-07
summary: - chromium-browser crashed with SIGILL
+ chromium-browser crashed with SIGILL in sw::Constants::Constants()
summary: - chromium-browser crashed with SIGILL in sw::Constants::Constants()
+ chromium-browser (GPU process) crashed with SIGILL in
+ sw::Constants::Constants()
tags: added: bionic
Olivier Tilloy (osomon) on 2018-02-07
information type: Private → Public
To post a comment you must log in.