Received signal 4 ILL_ILLOPN

Bug #1669344 reported by Nick Moffitt on 2017-03-02
54
This bug affects 12 people
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
Critical
Unassigned

Bug Description

This morning chromium-browser upgraded to 56.0.2924.76-0ubuntu0.16.10.1335 and promptly stopped working for me. When trying to load any page, it dumps this traceback:

Received signal 4 ILL_ILLOPN 7f78b7a509e7
#0 0x7f78d509500e base::debug::StackTrace::StackTrace()
#1 0x7f78d5095403 <unknown>
#2 0x7f78d53aa630 <unknown>
#3 0x7f78b7a509e7 WTF::decommitSystemPages()
#4 0x7f78c3f997b0 <unknown>
#5 0x7f78c3f99f17 <unknown>
#6 0x7f78c3f97b0e blink::NormalPageArena::allocatePage()
#7 0x7f78c3f98560 blink::NormalPageArena::outOfLineAllocate()
#8 0x7f78c3987678 blink::ChromeClientImpl::create()
#9 0x7f78c3a2929a blink::WebViewImpl::WebViewImpl()
#10 0x7f78c3a2aeb3 blink::WebViewImpl::create()
#11 0x7f78cfcd8769 content::RenderViewImpl::Initialize()
#12 0x7f78cfcd9443 content::RenderViewImpl::Create()
#13 0x7f78cf5d8692 content::mojom::RendererStubDispatch::Accept()
#14 0x7f78d4bc2671 mojo::InterfaceEndpointClient::HandleValidatedMessage()
#15 0x7f78d0d17bd0 <unknown>
#16 0x7f78d0d18034 <unknown>
#17 0x7f78d5096543 base::debug::TaskAnnotator::RunTask()
#18 0x7f78c3f35f4f blink::scheduler::TaskQueueManager::ProcessTaskFromWorkQueue()
#19 0x7f78c3f36ab0 blink::scheduler::TaskQueueManager::DoWork()
#20 0x7f78d5096543 base::debug::TaskAnnotator::RunTask()
#21 0x7f78d50bc740 base::MessageLoop::RunTask()
#22 0x7f78d50be33d base::MessageLoop::DeferOrRunPendingTask()
#23 0x7f78d50bf19d base::MessageLoop::DoWork()
#24 0x7f78d50bf589 base::MessagePumpDefault::Run()
#25 0x7f78d50bbb22 base::MessageLoop::RunHandler()
#26 0x7f78d50e44b8 base::RunLoop::Run()
#27 0x7f78cfcf5629 <unknown>
#28 0x7f78cfde7048 <unknown>
#29 0x7f78cfde7444 <unknown>
#30 0x7f78cfde68c1 content::ContentMain()
#31 0x55b0046e086c <unknown>
#32 0x7f78bfec03f1 __libc_start_main
#33 0x55b0046e073a <unknown>
  r8: 0000000000000000 r9: 0000000000000000 r10: 0000000000000022 r11: 0000000000000206
 r12: 0000161139870000 r13: 0000000000000004 r14: 00007f78b7c87448 r15: 0000000000000000
  di: 00003fb7e8201000 si: 000000000001e000 bp: 000016113981c210 bx: 000016113981c218
  dx: 0000000000000008 ax: ffffffffffffffff cx: ffffffffffffff68 sp: 00007fffa09e5f30
  ip: 00007f78b7a509e7 efl: 0000000000010286 cgf: 0000000000000033 erf: 0000000000000000
 trp: 0000000000000006 msk: 0000000000000000 cr2: 0000000000000000
[end of stack trace]

Being chromium, the overall processes don't die or coredump, so apport never sends any reports here. That is why I am filing via ubuntu-bug.

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: chromium-browser 56.0.2924.76-0ubuntu0.16.10.1335
ProcVersionSignature: Ubuntu 4.4.0-24.43-generic 4.4.10
Uname: Linux 4.4.0-24-generic x86_64
NonfreeKernelModules: zfs zunicode zcommon znvpair zavl
ApportVersion: 2.20.3-0ubuntu8.2
Architecture: amd64
CurrentDesktop: Unity
DRM.card0-DP-1:
 edid-base64:
 dpms: Off
 modes:
 enabled: disabled
 status: disconnected
DRM.card0-DP-2:
 edid-base64:
 dpms: Off
 modes:
 enabled: enabled
 status: disconnected
DRM.card0-HDMI-A-1:
 edid-base64:
 dpms: Off
 modes:
 enabled: disabled
 status: disconnected
DRM.card0-HDMI-A-2:
 edid-base64:
 dpms: Off
 modes:
 enabled: disabled
 status: disconnected
DRM.card0-eDP-1:
 edid-base64: AP///////wAw5DcEAAAAAAAXAQSVHBB4Ar8FmllVjiYdUFQAAAABAQEBAQEBAQEBAQEBAQEBFjaAunA4D0AwIDUAFJwQAAAaAAAAAAAAAAAAAAAAAAAAAAAAAAAA/gBMRyBEaXNwbGF5CiAgAAAA/gBMUDEyNVdGMi1TUEIyAN0=
 dpms: On
 modes: 1920x1080
 enabled: enabled
 status: connected
Date: Thu Mar 2 10:18:41 2017
Desktop-Session:
 'ubuntu'
 '/etc/xdg/xdg-ubuntu:/usr/share/upstart/systemd-session:/usr/share/upstart/xdg:/etc/xdg'
 '/usr/share/ubuntu:/usr/local/share/:/usr/share/:/var/lib/snapd/desktop'
DetectedPlugins:

Env:
 'None'
 'None'
InstallationDate: Installed on 2014-05-29 (1007 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
InstalledPlugins:
 /usr/lib/mozilla/plugins:
   => librhythmbox-itms-detection-plugin.so
         (size: 6072 bytes, mtime: Sat Sep 10 19:28:55 2016)
Load-Avg-1min: 0.95
Load-Processes-Running-Percent: 0.2%
MachineType: LENOVO 20ALCTO1WW
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.4.0-24-generic.efi.signed root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7
SourcePackage: chromium-browser
UpgradeStatus: Upgraded to yakkety on 2016-10-01 (152 days ago)
dmi.bios.date: 08/27/2014
dmi.bios.vendor: LENOVO
dmi.bios.version: GIET76WW (2.26 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20ALCTO1WW
dmi.board.vendor: LENOVO
dmi.board.version: Not Defined
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrGIET76WW(2.26):bd08/27/2014:svnLENOVO:pn20ALCTO1WW:pvrThinkPadX240:rvnLENOVO:rn20ALCTO1WW:rvrNotDefined:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 20ALCTO1WW
dmi.product.version: ThinkPad X240
dmi.sys.vendor: LENOVO
gconf-keys: /desktop/gnome/applications/browser/exec = b'firefox\n'/desktop/gnome/url-handlers/https/command = b'sensible-browser %s\n'/desktop/gnome/url-handlers/https/enabled = b'true\n'/desktop/gnome/url-handlers/http/command = b'sensible-browser %s\n'/desktop/gnome/url-handlers/http/enabled = b'true\n'/desktop/gnome/session/required_components/windowmanager = b''/apps/metacity/general/compositing_manager = b''/desktop/gnome/interface/icon_theme = b'gnome\n'/desktop/gnome/interface/gtk_theme = b'Clearlooks\n'
modified.conffile..etc.default.chromium-browser: [deleted]

Nick Moffitt (nick-moffitt) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in chromium-browser (Ubuntu):
status: New → Confirmed
Nick Moffitt (nick-moffitt) wrote :

Lest anyone blame my configuration, this also occurs when I run it like so:

  /usr/bin/chromium-browser --user-data-dir=$(mktemp -d)

George Moutsopoulos (gmoutso) wrote :

Me too. I downgraded to release version 53.0.2785.143 and chromium works again. However, now I can't access any password and chrome:settings/passwords shows empty. Does anyone know how I can get my passwords back in chromium?

George Moutsopoulos (gmoutso) wrote :

For what it's worth, using Google Chrome 56.0.2924.87 freshly installed works fine.

Nick Moffitt (nick-moffitt) wrote :

Where did you install that from?

Tuomo Sipola (tuomosipola) wrote :

After the latest update getting stack traces and "aw snap" pages after every time a tab accesses anything, even Chromium settings page.

Received signal 4 ILL_ILLOPN 0000af84a7f4
#0 0x0000b75a0e04 base::debug::StackTrace::StackTrace()
#1 0x0000b75a12d7 <unknown>
#2 0x0000b7707c20 ([vdso]+0xc1f)
#3 0x0000af84a7f4 WTF::decommitSystemPages()
#4 0x0000b1b2e1e5 <unknown>
#5 0x0000b1b2ed9f <unknown>
#6 0x0000b1b29bdb blink::NormalPageArena::allocatePage()
#7 0x0000b1b2a792 blink::NormalPageArena::outOfLineAllocate()
#8 0x0000b16df5e7 blink::ChromeClientImpl::create()
#9 0x0000b1797fa1 blink::WebViewImpl::WebViewImpl()
#10 0x0000b1799c5d blink::WebViewImpl::create()
#11 0x0000b1799cd3 blink::WebView::create()
#12 0x0000b53bc1f8 content::RenderViewImpl::Initialize()
#13 0x0000b53bd198 content::RenderViewImpl::Create()
#14 0x0000b53a5a92 content::RenderThreadImpl::CreateView()
#15 0x0000b4bedf66 content::mojom::RendererStubDispatch::Accept()
#16 0x0000b53a6123 <unknown>
#17 0x0000b74e4299 mojo::InterfaceEndpointClient::HandleValidatedMessage()
#18 0x0000b74e4326 mojo::InterfaceEndpointClient::HandleIncomingMessageThunk::Accept()
#19 0x0000b74e23fb mojo::FilterChain::Accept()
#20 0x0000b74e4026 mojo::InterfaceEndpointClient::HandleIncomingMessage()
#21 0x0000b60492f4 <unknown>
#22 0x0000b60445af <unknown>
#23 0x0000b75a2682 base::debug::TaskAnnotator::RunTask()
#24 0x0000b1ab6d9a blink::scheduler::TaskQueueManager::ProcessTaskFromWorkQueue()
#25 0x0000b1ab79d1 blink::scheduler::TaskQueueManager::DoWork()
#26 0x0000b1ab4586 <unknown>
#27 0x0000b75a2682 base::debug::TaskAnnotator::RunTask()
#28 0x0000b75ce937 base::MessageLoop::RunTask()
#29 0x0000b75d04d4 base::MessageLoop::DeferOrRunPendingTask()
#30 0x0000b75d142b base::MessageLoop::DoWork()
#31 0x0000b75d1888 base::MessagePumpDefault::Run()
#32 0x0000b75cdd3f base::MessageLoop::RunHandler()
#33 0x0000b75faed6 base::RunLoop::Run()
#34 0x0000b53dcf03 <unknown>
#35 0x0000b54ed49d <unknown>
#36 0x0000b54ed85e <unknown>
#37 0x0000b54ecce8 content::ContentMain()
#38 0x00008023fda5 <unknown>
#39 0x00008023e0d7 <unknown>
#40 0x0000b0a25276 __libc_start_main
#41 0x00008023fc17 <unknown>
  gs: 00000033 fs: 00000000 es: 0000007b ds: 0000007b
 edi: 3ac141a0 esi: 3ac141a4 ebp: 3ac14190 esp: bfcb4d50
 ebx: af882a00 edx: ffffffa4 ecx: aca2acc0 eax: ffffffff
 trp: 00000006 err: 00000000 ip: af84a7f4 cs: 00000073
 efl: 00210286 usp: bfcb4d50 ss: 0000007b
[end of stack trace]

wieczyk (wieczyk) wrote :

Something similar here.

The chromium-browser_55.0.2883.75-0ubuntu0.16.10.1327_amd64.deb works.

Received signal 4 ILL_ILLOPN 7f8bd71d19e7
#0 0x7f8bf481500e base::debug::StackTrace::StackTrace()
#1 0x7f8bf4815403 <unknown>
#2 0x7f8bf4b2a630 <unknown>
#3 0x7f8bd71d19e7 WTF::decommitSystemPages()
#4 0x7f8be37197b0 <unknown>
#5 0x7f8be3719f17 <unknown>
#6 0x7f8be3717b0e blink::NormalPageArena::allocatePage()
#7 0x7f8be3718560 blink::NormalPageArena::outOfLineAllocate()
#8 0x7f8be3107678 blink::ChromeClientImpl::create()
#9 0x7f8be31a929a blink::WebViewImpl::WebViewImpl()
#10 0x7f8be31aaeb3 blink::WebViewImpl::create()
#11 0x7f8bef458769 content::RenderViewImpl::Initialize()
#12 0x7f8bef459443 content::RenderViewImpl::Create()
#13 0x7f8beed58692 content::mojom::RendererStubDispatch::Accept()
#14 0x7f8bf4342671 mojo::InterfaceEndpointClient::HandleValidatedMessage()
#15 0x7f8bf0497bd0 <unknown>
#16 0x7f8bf0498034 <unknown>
#17 0x7f8bf4816543 base::debug::TaskAnnotator::RunTask()
#18 0x7f8be36b5f4f blink::scheduler::TaskQueueManager::ProcessTaskFromWorkQueue()
#19 0x7f8be36b6ab0 blink::scheduler::TaskQueueManager::DoWork()
#20 0x7f8bf4816543 base::debug::TaskAnnotator::RunTask()
#21 0x7f8bf483c740 base::MessageLoop::RunTask()
#22 0x7f8bf483e33d base::MessageLoop::DeferOrRunPendingTask()
#23 0x7f8bf483f19d base::MessageLoop::DoWork()
#24 0x7f8bf483f589 base::MessagePumpDefault::Run()
#25 0x7f8bf483bb22 base::MessageLoop::RunHandler()
#26 0x7f8bf48644b8 base::RunLoop::Run()
#27 0x7f8bef475629 <unknown>
#28 0x7f8bef567048 <unknown>
#29 0x7f8bef567444 <unknown>
#30 0x7f8bef5668c1 content::ContentMain()
#31 0x559fbd9fc86c <unknown>
#32 0x7f8bdf6403f1 __libc_start_main
#33 0x559fbd9fc73a <unknown>
  r8: 0000000000000000 r9: 0000000000000000 r10: 0000000000000022 r11: 0000000000000206
 r12: 00001939cfe70000 r13: 0000000000000004 r14: 00007f8bd7408448 r15: 0000000000000000
  di: 00001aeb80821000 si: 000000000001e000 bp: 00001939cfe1c228 bx: 00001939cfe1c230
  dx: 0000000000000008 ax: ffffffffffffffff cx: ffffffffffffff68 sp: 00007ffec26643f0
  ip: 00007f8bd71d19e7 efl: 0000000000010286 cgf: 0000000000000033 erf: 0000000000000000
 trp: 0000000000000006 msk: 0000000000000000 cr2: 0000000000000000
[end of stack trace]

Nick Moffitt (nick-moffitt) wrote :

wieczyk, where did you get the older deb? I am struggling to get back to a chromium that works!

Changed in chromium-browser (Ubuntu):
importance: Undecided → Critical
Tuomo Sipola (tuomosipola) wrote :

Isn't this almost a security risk since people will be using older versions that work?

Max Beikirch (max-beikirch-3) wrote :

I don't know why, but all of a sudden, chromium is working for me again.

Nick Moffitt (nick-moffitt) wrote :

Well that's highly fortunate for you, Max, but mine's still utterly unusable!

Joachim Haga (jobh) wrote :

FWIW:

The stacktrace looks very similar to this one: https://github.com/saiarcot895/chromium-ubuntu-build/issues/5

...which was apparently caused by attempting to use MADV_FREE (which was added in kernel 4.5) on 4.4.

Khurshid Alam (khurshid-alam) wrote :

Same here. I am using kernel 4.4 (linux-lts-xenial). Did anyone try it with > 4.4?

Tuomo Sipola (tuomosipola) wrote :

Joachim Haga seems to be correct. I ran earlier 4.4 kernel (for unrelated stability problems) but now that I try with 4.8, newest Chromium works.

$ uname -a
Linux ovidius 4.8.0-41-generic #44-Ubuntu SMP Fri Mar 3 15:26:20 UTC 2017 i686 i686 i686 GNU/Linux

$ chromium-browser --version
Using PPAPI flash.
 --ppapi-flash-path=/usr/lib/adobe-flashplugin/libpepflashplayer.so --ppapi-flash-version=
Chromium 56.0.2924.76 Built on Ubuntu , running on Ubuntu 16.10

d3b null (d3b-null) wrote :

Confirmed. Updating to 4.8 (from 4.4) fixed the problem.

wvengen (wvengen) wrote :

Due to suspend/resume+wifi driver issues, I can't upgrade the kernel. Downgrading Chromium works around this problem (though not very pretty). The previous version is still available here https://launchpad.net/ubuntu/+source/chromium-browser/55.0.2883.87-0ubuntu2.1329/+build/12052688

Olivier Tilloy (osomon) wrote :

This was fixed upstream with https://chromium.googlesource.com/chromium/src/+/65180d3bfbec6fb3d0ed2ca7961094fb38452832, which presumably shipped in Cr 57.

@nick-moffitt: is this crash still affecting you?

Nick Moffitt (nick-moffitt) wrote :

I'm running 57.0.2987.98-0ubuntu1.1348 on Zesty without this error.

Olivier Tilloy (osomon) wrote :

IIUC only yakkety on kernel 4.4 was affected. yakkety now has kernel 4.8 so it should be fine regardless, and Cr 57 should have fixed the issue anyway. I’m tentatively marking the bug fixed, feel free to re-open if needed.

Changed in chromium-browser (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.