Chromium not working with SAML authentication

Bug #1637957 reported by Alberto Donato on 2016-10-31
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
High
Unassigned
Nominated for Xenial by Alberto Salvia Novella
Nominated for Yakkety by Alberto Salvia Novella

Bug Description

Sync login is failing with SAML authentication. See

https://bugs.chromium.org/p/chromium/issues/detail?id=677154

for details.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in chromium-browser (Ubuntu):
status: New → Confirmed
Changed in chromium-browser (Ubuntu):
importance: Undecided → Medium
importance: Medium → High
status: Confirmed → Triaged
Patrick Noland (pnoland7) wrote :

This broke as a result of http://bazaar.launchpad.net/~chromium-team/chromium-browser/yakkety-working/revision/1271

The solution is to change the API keys back to their previous values. The new key isn't trusted for the purposes of an endpoint used in the SAML auth flow.

Alberto Donato (ack) on 2017-01-13
description: updated
Chad Miller (cmiller) wrote :

Patrick, we're not changing the keys back. It's impossible. The old keys were abused by someone and we lost Google API access. We have to fix this another way.

Patrick Noland (pnoland7) wrote :

Alright, I'll look into updating the whitelist to reflect the new keys.

Alberto Donato (ack) on 2017-01-19
Changed in chromium-browser (Ubuntu):
status: Triaged → Fix Released
status: Fix Released → Confirmed
Alberto Donato (ack) wrote :

Sync is now working again with SAML.

Changed in chromium-browser (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers