Ubuntu 14.04 LTS freezes

Bug #1499756 reported by peterzay on 2015-09-25
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
Undecided
Unassigned

Bug Description

After the most recent system update which brought new versions of Chromium and Firefox, Chromium starts to freeze and become unresponsive.

At this point you still have mouse pointer control.

Click around on the launcher a few times, nothing gets launched, and then Ubuntu itself completely freezes up.

The only escape is to press down on the PC power button and force a hardware shutdown.

This behaviour is intermittent but has happened twice since the above mentioned system update.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: chromium-browser 45.0.2454.85-0ubuntu0.14.04.1.1097
ProcVersionSignature: Ubuntu 3.13.0-63.103-generic 3.13.11-ckt25
Uname: Linux 3.13.0-63-generic i686
ApportVersion: 2.14.1-0ubuntu3.15
Architecture: i386
CurrentDesktop: Unity
CurrentDmesg: Error: command ['sh', '-c', 'dmesg | comm -13 --nocheck-order /var/log/dmesg -'] failed with exit code 1: comm: /var/log/dmesg: Permission denied
Date: Fri Sep 25 10:26:42 2015
Desktop-Session:
 'ubuntu'
 '/etc/xdg/xdg-ubuntu:/usr/share/upstart/xdg:/etc/xdg'
 '/usr/share/ubuntu:/usr/share/gnome:/usr/local/share/:/usr/share/'
EcryptfsInUse: Yes
Env:
 'None'
 'None'
InstallationDate: Installed on 2014-04-29 (513 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386 (20140417)
Load-Avg-1min: 0.56
Load-Processes-Running-Percent: 0.6%
MachineType: Dell Inc. Inspiron 660
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-63-generic root=UUID=8cf458ab-4ff9-4505-9a16-27da1ea7ec10 ro quiet splash vt.handoff=7
SourcePackage: chromium-browser
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/14/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A11
dmi.board.name: 0XR1GT
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 3
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA11:bd10/14/2013:svnDellInc.:pnInspiron660:pvr:rvnDellInc.:rn0XR1GT:rvrA00:cvnDellInc.:ct3:cvr:
dmi.product.name: Inspiron 660
dmi.sys.vendor: Dell Inc.
gconf-keys: /desktop/gnome/applications/browser/exec = b'/usr/bin/chromium-browser\n'/desktop/gnome/url-handlers/https/command = b'/usr/bin/chromium-browser %s\n'/desktop/gnome/url-handlers/https/enabled = b'true\n'/desktop/gnome/url-handlers/http/command = b'/usr/bin/chromium-browser %s\n'/desktop/gnome/url-handlers/http/enabled = b'true\n'/desktop/gnome/session/required_components/windowmanager = b''/apps/metacity/general/compositing_manager = b''/desktop/gnome/interface/icon_theme = b''/desktop/gnome/interface/gtk_theme = b''
modified.conffile..etc.default.chromium.browser: [deleted]
mtime.conffile..etc.chromium.browser.default: 2014-04-29T13:58:11.849470

peterzay (peterzay) wrote :
peterzay (peterzay) wrote :

It just crashed again for a 3rd time, this time on the Yahoo Finance home page.

Could it be an Adobe Flash issue?

peterzay (peterzay) wrote :

It just crashed again for a 4th time, this time on the Customize and control Chromium button to the right of the URL text window.

peterzay (peterzay) wrote :

Chromium just froze again for the 5th time. By acting quickly and closing the Chromium window while I still had the OS, I was able to prevent an OS freeze up.

Hope this helps.

peterzay (peterzay) wrote :

I have disabled flash via
   chrome://plugins
and still get the issue.

One frequent manifestation of the bug is to click on the arrow of a drop down choice box. If the contents of the choice box are all greyed out, then the browser freezes up as does the OS.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in chromium-browser (Ubuntu):
status: New → Confirmed
Star Man (starman) wrote :

Linux 3.13.0-65-generic #105-Ubuntu SMP Mon Sep 21 18:50:58 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
MacBook4,1; 2GiB RAM
chromium-browser 45.0.2454.85 amd64

This thing is completely freezing my system; screen goes black and there's no way to call any of the TTYs. No error dump or anything. After a while, the only thing to do is to hard-reset the system pressing power button. After restart, no error information or any way to check what happened in the first place.

Star Man (starman) wrote :

Okey, I just managed to trace and dump the process activity into a zipped log file using 'strace' command.
I don't know if it'll help, but it's better than nothing, since the system doesn't show any process cracs warning or activity dump.

By the way, my distro is Ubuntu GNOME 14.04 LTS amd64

Chad Miller (cmiller) wrote :

Visit here and uncheck "use hardware acceleration when available", then report back in a few days as to whether things are better or worse.

chrome://settings/search#use%20hardware%20acceleration

Changed in chromium-browser (Ubuntu):
status: Confirmed → Incomplete
Star Man (starman) wrote :

I did as recommended and unchecked that option.
The browser works perfectly now. No hanging, no freezing. I can now add extensions, browse configuration menues and browse the internet without troubles.
It seems the problem is caused by the hardware acceleration routines. Hope it can be solved.

peterzay (peterzay) wrote :

I have been using Chromium intensively for 3 days since the hardware acceleration option was unchecked.

There was not even a single freeze up in that time frame.

Chad, you are onto something here.

Kudos for the deep thinking.

Changed in chromium-browser (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in chromium-browser (Ubuntu):
status: New → Confirmed

I am not certain it makes a difference (I haven't tested it yet) but I believe Chromium did not lock up until after I installed the HWE kernels in 14.04. It's also possible this started after some update to Chromium, though I am almost certain it didn't lock up my system as long ago as the bug reporter reported it. (I have seen it locked up in the past on different systems, however, and in that case it seemed to be a crash involving the video driver.)

I have found a procedure that ALWAYS locks up my system now -- if I have "use hardware acceleration" checked (turned on) and open a video in YouTube, make it full screen, then undo the full screen, the screen locks up (even while the video continues playing for a few seconds).

I have found I can switch to a virtual terminal (Ctrl-Alt-F1 for example) and see processes still running, but I have not yet found any process I can kill off or restart to unlock the screen EXCEPT to get Unity to restart. All I have to do to restart unity is issue a

unity -v

command and all the running applications will die and unity will restart, allowing me to log in.

I should add I have no idea what I'm doing; unity -v is the first command I tried and it reset things. If there's a command to restart unity without killing off the applications I would prefer it

peterzay (peterzay) wrote :

After implementing the HWE stack to diagnose another bug (Bug #1313158), my system has never been the same.

All kinds of errors have been plaguing the OS.

For example, Bug #1568425 which involves gedit (probably a red herring).

I have had launcher involved in a freeze.

Another worrisome behaviour is Bug #1561973 which involves initramfs (probably also a red herring). Sophos AV scan claims there is no problem on this machine.

There is such an overwhelming barrage of problems on this HWE enabled 14.04 that I will soon overwrite everything with Ubuntu 16.04 and never go near HWE for as long as I live.

To post a comment you must log in.