Native Client (NaCl) not working in Chromium Dev

Bug #1462647 reported by Christopher Mason on 2015-06-06
96
This bug affects 62 people
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
Medium
Unassigned

Bug Description

Native Client isn't working in Chromium Browser dev ppa. Everything that requires Native Client will either silently fail, or display a gray box with a plug icon.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: chromium-browser 45.0.2414.0-0ubuntu1~ppa1~vivid1 [origin: LP-PPA-saiarcot895-chromium-dev]
Uname: Linux 4.1.0-040100rc6-generic x86_64
ApportVersion: 2.17.2-0ubuntu1.1
Architecture: amd64
CrashDB: ubuntu
Date: Sat Jun 6 12:17:10 2015
ExecutablePath: /usr/lib/chromium-browser/chromium-browser
InstallationDate: Installed on 2015-05-02 (34 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
ProcEnviron: Error: [Errno 13] Permission denied: '/proc/18807/environ'
SourcePackage: chromium-browser
ThirdParty: True
UpgradeStatus: No upgrade log present (probably fresh install)
modified.conffile..etc.default.chromium.browser: [deleted]

Christopher Mason (cmason37) wrote :
description: updated
Chad Miller (cmiller) wrote :

Assigning to saiarcot, but I suspect it's WontFix for a while.

Changed in chromium-browser (Ubuntu):
assignee: nobody → Saikrishna Arcot (saiarcot895)
Saikrishna Arcot (saiarcot895) wrote :

Currently, this is intentional, because building the Native Client plugin into Chromium requires the use of a separate toolchain. While the toolchain is open-source, I'm having some trouble building it locally. When I do have it built successfully, I'll include Native Client using that toolchain.

Changed in chromium-browser (Ubuntu):
status: New → Confirmed
Chad Miller (cmiller) wrote :

@saiarcot895, I too am interested in this, so I'll share any progress I make.

Changed in chromium-browser (Ubuntu):
importance: Undecided → Medium
Saikrishna Arcot (saiarcot895) wrote :

Chromium with Native Client is now working for Trusty and newer on both the Chromium Beta and Dev PPAs.

https://launchpad.net/~saiarcot895/+archive/ubuntu/chromium-beta
https://launchpad.net/~saiarcot895/+archive/ubuntu/chromium-dev

Also, there is a duplicate of this bug: bug #882942. Should that be marked as a duplicate of this, or the other way around?

dnord (dnord) wrote :

Still not working for me on Trusty with ppa:saiarcot895/chromium-beta. Look like native client extension exists, but none of NaCL applications are actually working. I tested Native Client SDK and even Hello World did not worked.

dnord (dnord) wrote :

Also dmesg get spammed with
traps: nacl_helper[18399] general protection ip:7fd7f5992227 sp:7ffdfd86f100 error:0 in libc-2.19.so[7fd7f5958000+1bb000]

dnord (dnord) wrote :

Looks like this problem is specific only to trusty. I've tested wily and NaCl was working fine.

zubozrout (zubozrout) wrote :

Well, on Xenial the issue persists.

Saikrishna Arcot (saiarcot895) wrote :

Native Client is currently not being built, due to issues with the build system.

vans163 (vans-163) wrote :

This is quite unfortunate.

I am looking for NaCl support as well, javascript is just not fast enough for some things nor does it give you access to the amazing pepper api.

I will use Chrome for now but directing users to use Chrome vs chromium is really unfortunate.

Robert Orzanna (orschiro) wrote :

Can Chromium on Ubuntu please ship the Native Client?

I completely agree with @vans-163.

You are driving people from an open-source product to its proprietary alternative.

Olivier Tilloy (osomon) wrote :

Still valid. The packages are built with enable_nacl=false.

Chris Coulson (chrisccoulson) wrote :

I don't really think it's worth investing any time on this given that Native Client is deprecated and due to be removed in Q1 2018.

https://developer.chrome.com/native-client/migration#p-nacl-deprecation-announcements

Olivier Tilloy (osomon) wrote :

Oh, I had missed that announcement. It doesn't make sense to invest time in supporting a feature that will soon be removed.

Changed in chromium-browser (Ubuntu):
status: Confirmed → Won't Fix
assignee: Saikrishna Arcot (saiarcot895) → nobody
Gerv (gerv-launchpad) wrote :

NaCL will still be usable by Chrome Apps and extensions, for example Chrome Remote Desktop, which currently doesn't work with the Ubuntu version of Chromium. So there is still value in getting this working.

Rolf Leggewie (r0lf) wrote :

My issue is also with missing support for an app, called Vysor. It hasn't been ported yet and after reading through the annnouncement, it is true that NaCL support is scheduled to be dropped but *explicitly* not for apps.

Reopening.

Changed in chromium-browser (Ubuntu):
status: Won't Fix → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.