Random Chromium / Chrome slowdowns with hardware acceleration

Bug #1449607 reported by Luis Alberto Pabón on 2015-04-28
26
This bug affects 6 people
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
Medium
Unassigned

Bug Description

Since update from 14.04 --> 15.04, bot Chromium and Chrome randomly slow down to a complete halt after a while using them. There doesn't seem to be any pattern on when this starts happening. Sometimes when opening a new tab from a unity-webapp (eg Gmail) but not always.

As well as either Chrome or Chromium, this also makes Unity itself unresponsive - eg I can't act on anything on the UI be it the dash or another app. I can log into a terminal outside X (eg CTRL+ALT+F1) and this is perfectly responsive even when the whole UI is locked up. There's barely any system load - often with several gigs of ram free and very low CPU load and no usage on the swap.

After I manually kill the "--type=gpu-broker" associated with either chrome or chromium they both seem to recover, together with Unity.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: chromium-browser 41.0.2272.76-0ubuntu1.1134
ProcVersionSignature: Ubuntu 3.19.0-15.15-generic 3.19.3
Uname: Linux 3.19.0-15-generic x86_64
ApportVersion: 2.17.2-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Tue Apr 28 15:41:18 2015
InstallationDate: Installed on 2014-01-16 (467 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
SourcePackage: chromium-browser
UpgradeStatus: Upgraded to vivid on 2015-04-23 (5 days ago)
gconf-keys: /desktop/gnome/applications/browser/exec = b'/opt/google/chrome/google-chrome\n'/desktop/gnome/url-handlers/https/command = b'/opt/google/chrome/google-chrome %s\n'/desktop/gnome/url-handlers/https/enabled = b'true\n'/desktop/gnome/url-handlers/http/command = b'/opt/google/chrome/google-chrome %s\n'/desktop/gnome/url-handlers/http/enabled = b'true\n'/desktop/gnome/session/required_components/windowmanager = b''/apps/metacity/general/compositing_manager = b''/desktop/gnome/interface/icon_theme = b'gnome\n'/desktop/gnome/interface/gtk_theme = b'Clearlooks\n'
modified.conffile..etc.default.chromium.browser: [deleted]

Luis Alberto Pabón (copong) wrote :
Luis Alberto Pabón (copong) wrote :

Fujitsu Lifebook A544 - Intel Haswell:
i5-4200M
16 GB RAM
Intel built in graphics (i915 driver)

summary: - Chromium and Chrome slow downs with hardware acceleration
+ Random Chromium / Chrome slowdowns with hardware acceleration
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in chromium-browser (Ubuntu):
status: New → Confirmed
Warren Strange (warren-strange) wrote :

Chrome is unusable unless I turn off hardware acceleration

Changed in chromium-browser (Ubuntu):
importance: Undecided → High
importance: High → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers