Chromium browser 39.0.2171.65 does not load policies

Bug #1414753 reported by Esokrates on 2015-01-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
Undecided
Chad Miller

Bug Description

Following the information I gathered from

http://www.chromium.org/administrators/linux-quick-start
http://www.chromium.org/administrators/linux-quick-start
https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1373802

I tried to set a simple policy for the browser.
All I did is create a file "policy.json" in /etc/chromium-
browser/policies/managed with the following content:

{
  "HomepageLocation": "www.chromium.org"
}

However when starting chromium there is no sign of the policy: "about:policy"
does not show any policy being set. Running 'strings /usr/lib/chromium-
browser/chromium-browser|grep policies' gives me:

/etc/chromium/policies
/etc/chromium-browser/policies

so everything should be fine. To be sure I also tried setting the policy in
/etc/chromium/policies. I also tried to set the policy in "recommended" in
both paths. I also tested running chromium under a new user account, but it
did not change anything. The policy is simply not set. Either I am doing
something wrong or this is not working.
To be on the safe side I also tried a different content:

{
  "RestoreOnStartup": 4,
  "RestoreOnStartupURLs": ["http://www.chromium.org"
}

Did not work either.

Chad Miller (cmiller) on 2015-01-27
Changed in chromium-browser (Ubuntu):
assignee: nobody → Chad Miller (cmiller)
status: New → Confirmed
Chad Miller (cmiller) wrote :

This seems to be fixed in this next version. I didn't see a change that fixes it, though. Weird.

My about:policies shows items and I can set the URL that browser goes to when clicking Home.

Changed in chromium-browser (Ubuntu):
status: Confirmed → Incomplete
Esokrates (esokrarkose) wrote :

What version is "this next version"?

Esokrates (esokrarkose) wrote :

So what is the problem now? It does not work for me, why the incomplete mark? Which version fixes the problem?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package chromium-browser - 40.0.2214.94-0ubuntu1.1120

---------------
chromium-browser (40.0.2214.94-0ubuntu1.1120) vivid; urgency=medium

  * Upstream release 40.0.2214.94.
  * Upstream release 40.0.2214.93.
  * Upstream release 40.0.2214.91. (LP: #1414753)
    - CVE-2014-7923: Memory corruption in ICU.
    - CVE-2014-7924: Use-after-free in IndexedDB.
    - CVE-2014-7925: Use-after-free in WebAudio.
    - CVE-2014-7926: Memory corruption in ICU.
    - CVE-2014-7927: Memory corruption in V8.
    - CVE-2014-7928: Memory corruption in V8.
    - CVE-2014-7930: Use-after-free in DOM.
    - CVE-2014-7931: Memory corruption in V8.
    - CVE-2014-7929: Use-after-free in DOM.
    - CVE-2014-7932: Use-after-free in DOM.
    - CVE-2014-7933: Use-after-free in FFmpeg.
    - CVE-2014-7934: Use-after-free in DOM.
    - CVE-2014-7935: Use-after-free in Speech.
    - CVE-2014-7936: Use-after-free in Views.
    - CVE-2014-7937: Use-after-free in FFmpeg.
    - CVE-2014-7938: Memory corruption in Fonts.
    - CVE-2014-7939: Same-origin-bypass in V8.
    - CVE-2014-7940: Uninitialized-value in ICU.
    - CVE-2014-7941: Out-of-bounds read in UI.
    - CVE-2014-7942: Uninitialized-value in Fonts.
    - CVE-2014-7943: Out-of-bounds read in Skia.
    - CVE-2014-7944: Out-of-bounds read in PDFium.
    - CVE-2014-7945: Out-of-bounds read in PDFium.
    - CVE-2014-7946: Out-of-bounds read in Fonts.
    - CVE-2014-7947: Out-of-bounds read in PDFium.
    - CVE-2014-7948: Caching error in AppCache.
  * debian/patch/search-credit: Don't force client in GOOG suggestions search.
    (LP: #1398900)
  * debian/patches/dri3-within-sandbox: Backport V41 sandbox, fixing DRI3.
    (LP: #1378627)
  * debian/patches/macro-templates-not-match: Remove. No longer necessary.
  * debian/patches/arm-neon.patch: Kill armv7=neon assumption. Fix typos.
  * debian/rules: chrpath for all packages. (LP: #1415555)
 -- Chad MILLER <email address hidden> Fri, 30 Jan 2015 15:48:09 -0500

Changed in chromium-browser (Ubuntu):
status: Incomplete → Fix Released
Esokrates (esokrarkose) wrote :

This was an apparmor denial in my case, I proposed a fix here: https://bugs.launchpad.net/ubuntu/+source/apparmor/+bug/1419294

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers