Chromium hangs: GPU process hung

Bug #1400206 reported by Richard Eames on 2014-12-08
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
High
Unassigned

Bug Description

Starting with a recent update to either my graphics card, or to chromium, it (chromium) will seem to hang after resuming from a lock screen. By hang, I mean it seems to refuse to redraw since it still responds to mouse clicks on the close button. Here's the stderr output on console:

ATTENTION: default value of option force_s3tc_enable overridden by environment.
[11795:11795:1207/210031:ERROR:sandbox_linux.cc(305)] InitializeSandbox() called with multiple threads in process gpu-process
[11759:11806:1207/210033:ERROR:get_updates_processor.cc(240)] PostClientToServerMessage() failed during GetUpdates
[11795:11828:1207/211957:ERROR:gpu_watchdog_thread.cc(253)] The GPU process hung. Terminating after 10000 ms.
[12793:12794:1207/212007:ERROR:gpu_watchdog_thread.cc(253)] The GPU process hung. Terminating after 10000 ms.
[11759:11759:1207/212008:ERROR:gpu_process_transport_factory.cc(437)] Failed to establish GPU channel.
[11759:11759:1207/212008:ERROR:gpu_process_transport_factory.cc(461)] Lost UI shared context.
[11759:11806:1207/220155:ERROR:get_updates_processor.cc(240)] PostClientToServerMessage() failed during GetUpdates

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: chromium-browser 39.0.2171.65-0ubuntu0.14.10.1.1106
ProcVersionSignature: Ubuntu 3.16.0-26.35-generic 3.16.7-ckt1
Uname: Linux 3.16.0-26-generic x86_64
ApportVersion: 2.14.7-0ubuntu8
Architecture: amd64
CurrentDesktop: GNOME
Date: Sun Dec 7 22:21:35 2014
EcryptfsInUse: Yes
InstallationDate: Installed on 2014-08-21 (109 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Beta amd64 (20140326)
SourcePackage: chromium-browser
UpgradeStatus: Upgraded to utopic on 2014-11-05 (32 days ago)
modified.conffile..etc.default.chromium.browser: [deleted]
---
ApportVersion: 2.14.7-0ubuntu8.1
Architecture: amd64
CurrentDesktop: GNOME
DistroRelease: Ubuntu 14.10
EcryptfsInUse: Yes
InstallationDate: Installed on 2012-02-16 (1083 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
Package: chromium-browser 39.0.2171.65-0ubuntu0.14.10.1.1106
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 3.11.0-14.21-generic 3.11.7
Tags: utopic
Uname: Linux 3.11.0-14-generic x86_64
UpgradeStatus: Upgraded to utopic on 2014-11-04 (91 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
_MarkForUpload: True
modified.conffile..etc.chromium.browser.default:
 # Default settings for chromium-browser. This file is sourced by /bin/sh from
 # /usr/bin/chromium-browser
 . /usr/lib/pepflashplugin-installer/pepflashplayer.sh
 # Options to pass to chromium-browser
 CHROMIUM_FLAGS=""
modified.conffile..etc.default.chromium.browser: [deleted]
mtime.conffile..etc.chromium.browser.default: 2014-07-14T09:22:20.527190

Richard Eames (naddiseo) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in chromium-browser (Ubuntu):
status: New → Confirmed
Changed in chromium-browser (Ubuntu):
importance: Undecided → High

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

Richard Eames (naddiseo) wrote :

This is one of the most irritating bugs I've come across. At the moment it's happening nearly every day on both my work and my home computers.
I just added additional information from my work computer in case it's useful.

Richard Eames (naddiseo) wrote :

The apport window that pops up after crashes lists this bug as a duplicate of https://bugs.launchpad.net/bugs/1402523 which does not exist.

One thing I do notice that crashes it: if I hover over the tab name, the tooltip will sometimes stay and become a white rectangle, if I then try to show another tooltip on the tab name, the browser locks up.

Olivier Tilloy (osomon) wrote :

@Richard: is that bug still affecting you with recent releases of chromium?

Richard Eames (naddiseo) wrote :

@Olivier: No, I haven't seen this bug in a while since I changed my video cards. (I do still see the tooltip graphical artefacts when hovering over the tabs, but it doesn't lock my browser.)

Chris Carlin (crcarlin) wrote :

@Richard: what graphics card showed the error and what did not? Did you ever notice hard drive thrashing while the window was refusing to redraw?

I MIGHT still be seeing this bug, but I'm not positive it's the one I've been seeing.

Olivier Tilloy (osomon) wrote :

@Chris: are you seeing the same errors in stderr as reported by Richard ("The GPU process hung" and "Lost UI shared context")?

Richard Eames (naddiseo) wrote :

@Chris: I'm not 100% sure, for my home machine it was either a Radeon HD 4850 or a Radeon R7 200 series.

I think this bug was "fixed" on both machines once I upgraded to Ubuntu 15.10. (Although on my work machine 15.10 caused a different system freeze bug starting with that release that didn't fix until I changed the graphics card again.)

Olivier Tilloy (osomon) wrote :

I’ll close this bug, please file a new one if you're affected by similar issues or if you're seeing crashes.

Changed in chromium-browser (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.