[xubuntu] chromium redraw issue after switching workspaces

Bug #1309801 reported by zmpeg on 2014-04-18
232
This bug affects 49 people
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
High
Unassigned

Bug Description

When I switch between workspaces in xubuntu, the chromium windows more often than not are only partially visible or else completely transparent. Moving the window (hold alt and drag) does not always fix the issue, but resizing always does. I've taken a video I will attach to the bug.

Expected: See the chromium window and tabs I have open.
Actual: Window is invisible or partially invisible. See attached video.

% lsb_release -rd
Description: Ubuntu 14.04 LTS
Release: 14.04

% apt-cache policy chromium-browser
chromium-browser:
  Installed: 34.0.1847.116-0ubuntu2
  Candidate: 34.0.1847.116-0ubuntu2
  Version table:
 *** 34.0.1847.116-0ubuntu2 0
        500 http://ca.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: chromium-browser 34.0.1847.116-0ubuntu2
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CurrentDesktop: XFCE
Date: Fri Apr 18 17:38:04 2014
Desktop-Session:
 DESKTOP_SESSION = xubuntu
 XDG_CONFIG_DIRS = /etc/xdg/xdg-xubuntu:/usr/share/upstart/xdg:/etc/xdg:/etc/xdg
 XDG_DATA_DIRS = /usr/share/xubuntu:/usr/share/xfce4:/usr/local/share/:/usr/share/:/usr/share
DiskUsage:
 b'Filesystem Type Size Used Avail Use% Mounted on\n/dev/sda1 ext4 228G 16G 201G 8% /\nnone tmpfs 4.0K 0 4.0K 0% /sys/fs/cgroup\nudev devtmpfs 3.7G 4.0K 3.7G 1% /dev\ntmpfs tmpfs 755M 1.1M 754M 1% /run\nnone tmpfs 5.0M 0 5.0M 0% /run/lock\nnone tmpfs 3.7G 20M 3.7G 1% /run/shm\nnone tmpfs 100M 52K 100M 1% /run/user\n'

 Inodes:
 b'Filesystem Inodes IUsed IFree IUse% Mounted on\n/dev/sda1 15M 298K 15M 3% /\nnone 944K 2 944K 1% /sys/fs/cgroup\nudev 942K 500 941K 1% /dev\ntmpfs 944K 495 944K 1% /run\nnone 944K 3 944K 1% /run/lock\nnone 944K 40 944K 1% /run/shm\nnone 944K 85 944K 1% /run/user\n'
Env:
 MOZ_PLUGIN_PATH = None
 LD_LIBRARY_PATH = None
ExecutablePath: /usr/lib/chromium-browser/chromium-browser
InstallationDate: Installed on 2014-04-18 (0 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.2)
SourcePackage: chromium-browser
UpgradeStatus: No upgrade log present (probably fresh install)
chromium-default: CHROMIUM_FLAGS=""
gconf-keys: /desktop/gnome/applications/browser/exec = b'firefox\n'/desktop/gnome/url-handlers/https/command = b'sensible-browser %s\n'/desktop/gnome/url-handlers/https/enabled = b'true\n'/desktop/gnome/url-handlers/http/command = b'sensible-browser %s\n'/desktop/gnome/url-handlers/http/enabled = b'true\n'/desktop/gnome/session/required_components/windowmanager = b''/apps/metacity/general/compositing_manager = b''/desktop/gnome/interface/icon_theme = b'gnome\n'/desktop/gnome/interface/gtk_theme = b'Clearlooks\n'
modified.conffile..etc.default.chromium.browser: [deleted]

zmpeg (zmpeg) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in chromium-browser (Ubuntu):
status: New → Confirmed
David Gerard (dgerard) wrote :

Affecting me too.

I find that if I alt-tab to another window in the destination workspace (any window, Chromium or not) and back again, then Chromium redraws.

I note also that I've been running 14.04 for a couple of months now, and this only started happening with Chromium 34; so I'm presuming they optimised something and we've hit a corner case.

zmpeg (zmpeg) wrote :

David,
I see the same positive result on alt-tab. Thanks for the background on Chromium 34. With any luck this will be fixed with 35.

Michael Collette (metrol) wrote :

As I'm seeing the very same thing I decided to give the Chrome beta a shot

https://www.google.com/intl/en/chrome/browser/beta.html

When I did the download I got "Version 35.0.1916.86 beta". The redraw problems I was seeing with 34 went away, and things are solid again. It installs alongside of 34, so you don't have to replace the stable version with the beta.

zmpeg, thanks for the inspiration to go try getting a newer version.

Pavel Stano (stano-u) wrote :

same problem with latest chrome stable 35.0.1916.114
ubuntu 14.04 latest nvidia 331.79

Tejas (tejaskale27-s) wrote :

I have a a similar problem, Switching from chrome( 35.0.1916.114) to another workspace, the entire chrome window is still displayed, and moving the mouse around causes icons on the desktop to get highlighted. See attached screen shot.

Chrome-Stable ( 35.0.1916.114)
Metacity(metacity 2.34.13)
and Nvidia (NVIDIA-Linux-x86_64-331.79)
Ubuntu 14.04 LTS

Using flag `--disable-gpu-compositing` fixed this for me.

Version 34.0.1847.116 Ubuntu 14.04 aura (260972)

Update: `--disable-gpu-compositing` fixes it only for switching desktops not for swapping windows using xmonad.

There's also an upstream bug report about this topic: https://code.google.com/p/chromium/issues/detail?id=370022

Daniel Antonio (souliaq) wrote :

I'm still having such problem in Lubuntu 14.04.1 (full update today 2014-07-26), I also have NVIDIA graphics (GT 620).

Santiago Romero (sromero) wrote :

I'm having this problem as well under XFCE. I use CTRL+ALT+ARROWS to move between my 6 (3x2) workspaces, and each time I move to the desktop having chromium is only partially refreshed.

I've found that it only happens if I switch on XFCE's "Enable display composition" under Settings --> Window Manager Tweaks --> Compositor.

If I disable that option, then the refresh problem disappears (but I loose as well the fance transparency effects on terminals and windows :( ).

PS: It happens as well in Linux Mint 17.

Santiago Romero (sromero) wrote :

Forgot to say:

I don't think it's an nvidia problem. My Laptop has an Intel graphic card (Chipset: Mobile Intel GE45 Express, Card: Intel GMA 4500MHD):

Ory Band (oryband) wrote :

This happens as well on my Xubuntu 14.04 with an Intel HD Integrated graphics adapter, no nVidia.
Disabling the compositor as @sromero suggested fixes the problem (though disables all the mentioned graphic effects as well).

Changed in chromium-browser (Ubuntu):
importance: Undecided → High
Ryan Baldwin (ryanbaldwin) wrote :

I'm still experiencing this. Ubuntu LTS 14.04, Chrome 38.0.2125.111, using XMonad as a DE.

Anas (anas-mammeri) wrote :

Hello everyone.
I had the same problem on my xubuntu with Chrome 40.0.2214.94 (64-bit).
When i disabled the hardware acceleration when available on google chrome settings, the problem was gone.

Paul Winkler (slinkp) wrote :

Here too on chrome 40.0.2214.94 (64-bit) on xubuntu 14.04.1.
Disabling compositor in xfce window manager tweaks worked for me.

I started seeing this problem a few weeks ago, on two out of my three computers, all running Xubuntu 14.04.1.
Disabling compositor did get rid of that issue.

Dac Chartrand (conner-bw) wrote :

This bug happens to me too, it started a few weeks ago.

Xububtu 14.04.1, Chrome Version 40.0.2214.111 (64-bit)

I'm on a Lenovo X220 with Intel video drivers {Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)} so I'm on board the *not nvidia* train.

Regards,

Anton (anton-sivolapov) on 2015-02-10
no longer affects: chromium-browser
josvanr (josvanr) wrote :

I can confirm this Version 40.0.2214.111 Ubuntu 14.04 (64-bit)
on HP envy 17

an it goes away with --disable-gpu-compositing.........

thnx

I had this problem with my Xubuntu 14.04 installation on my T420 with Intel HD 3000 too. Ich replaced the window manager and now everything works just fine.
This might be a helpful tutorial: http://www.webupd8.org/2012/11/how-to-set-up-compiz-in-xubuntu-1210-or.html

FiReSTaRT (dlyh) wrote :

I was getting the same issue with a couple of other Blink-related browsers like Opera and Vivaldi

Joris Bierkens (jbierkens) wrote :

I have the same issue. For me this workaround was succesful:
https://code.google.com/p/chromium/issues/detail?id=370022#c13

It amounts to enabling hardware acceleration in Google chrome (instead of disabling), by typing
chrome://flags
in address bar and "Enable" the "Override software rendering list". See http://www.webupd8.org/2014/01/enable-hardware-acceleration-in-chrome.html for details.

Also starting google-chrome with the flag --disable-gpu remedies the issue.

Which of the two approaches should be preferred?

Silyus (luca.baronti) wrote :

I got the same problem (xubuntu 14.04 LTS) on both chrome and chromium.
Disabling the hardware acc on chrome settings solve the issue for me as well.

Aditya (meta1729) wrote :

The problem seems to be in the graphics driver.

For those having Intel® HD Graphics 4000, check whether this xorg.conf solves the problem:

$ cat /etc/X11/xorg.conf.d/20-intel.conf
Section "Device"
   Identifier "Intel Graphics"
   Driver "intel"
   Option "AccelMethod" "UXA"
EndSection

If it doesn't also install the kernel and X stack of Utopic.
See https://wiki.ubuntu.com/Kernel/LTSEnablementStack
That should definitely solve the problem.

Goran Janković (gogeccc) wrote :

Thank you Aditya, creating /etc/X11/xorg.conf.d/20-intel.conf file with the content you listed solved the issue for me.
I am using Linux Mint 17.1 Rebbeca XFCE.

Goran Janković (gogeccc) wrote :

There are two highly possible fixes in the comment section.

Have the same issue here:

Linux Mint 17.1 XFCE ( compositing: enabled )

When switching to Google Chrome ( from desktop ) upper part is "transparent" and when I
hover the mouse its parts are getting displayed.

oliford (oliford) wrote :

I see this in chromium-browser, but also in some of the controls in eclipse too.
The AccelMethod=UXA seems to fix it. Thanks.

Intel HD Graphics (probaly 3000, but not sure), kernel module is i915.

Ramsey D'silva (ramseydsilva) wrote :

Disabling hardware acceleration in google chrome settings also solved this for me.

I am using awesome wm with ubuntu 14.04

Paul White (paulw2u) wrote :

We are sorry that we do not always have the capacity to review all reported bugs in a timely manner. It's now been over four years since the last comment on this bug report.

The Trusty (14.04) release of (X)Ubuntu is no longer receiving maintenance updates. If this is still an issue using a maintained version of (X)Ubuntu please let us know otherwise this report can be left to expire in approximately 60 days time.

Paul White
[Ubuntu Bug Squad]

Thank you for helping make Ubuntu better.

Paul White
[Ubuntu Bug Squad]

Changed in chromium-browser (Ubuntu):
status: Confirmed → Incomplete
Paul White (paulw2u) wrote :

Bug report did not expire due to bug watch
No reply to comment #31 to says problem still exists
Upstream report is still attracting comments but there
is no reference to Ubuntu.
I've not seen the problem here on three installations of
Xubuntu 18.04 or 20.04
Last report of problem was in comment #30 over 4 years ago
on an Ubuntu release that is now EOL so closing as fixed

Changed in chromium-browser (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.