Chromium 34+ ignores ComposeKey (with xim GTK_IM_MODULE)

Bug #1309145 reported by Alex N. on 2014-04-17
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Chromium Browser
Unknown
Unknown
chromium-browser (Ubuntu)
Undecided
Unassigned

Bug Description

When entering the key combination
AltGr + [ a
in any text input field or address bar, it does not translate to ä (a umlaut) anymore. This worked in the "pre-aura" Chromium 33.

---
Ubuntu 14.04

UK International Keyboard

$ echo $GTK_IM_MODULE
xim

Chromium 34.0.1847.116 (Developer Build 260972) Ubuntu 14.04 aura
OS Linux
Blink 537.36 (@170605)
JavaScript V8 3.24.35.22
Flash 13.0.0.182
User Agent Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/34.0.1847.116 Chrome/34.0.1847.116 Safari/537.36
Command Line /usr/lib/chromium-browser/chromium-browser --ppapi-flash-path=/usr/lib/pepflashplugin-installer/libpepflashplayer.so --ppapi-flash-version=13.0.0.182 --enable-pinch --flag-switches-begin --enable-experimental-extension-apis --flag-switches-end

(See also https://code.google.com/p/chromium/issues/detail?id=351230)

Alex N. (a-nox) on 2014-04-17
description: updated
Download full text (3.8 KiB)

Are you ßure thåt yøur compose keỳ settįng survived the upgradê¿ This is
typed with compose in that version. I have seen something affect
compose-key setting on upgrade in the past.

With your help, I'd like to track it down.

On Thu, Apr 17, 2014 at 3:07 PM, ano <email address hidden> wrote:

> Public bug reported:
>
> When entering the key combination
> AltGr + [ a
> in any text input field or address bar, it does not translate to ä (a
> umlaut) anymore. This worked in the "pre-aura" Chromium 33.
>
> ---
> Ubuntu 14.04, Gnome Flashback Session
>
> UK International Keyboard
>
> $ echo $GTK_IM_MODULE
> xim
>
> Chromium 34.0.1847.116 (Developer Build 260972) Ubuntu 14.04 aura
> OS Linux
> Blink 537.36 (@170605)
> JavaScript V8 3.24.35.22
> Flash 13.0.0.182
> User Agent Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML,
> like Gecko) Ubuntu Chromium/34.0.1847.116 Chrome/34.0.1847.116 Safari/537.36
> Command Line /usr/lib/chromium-browser/chromium-browser
> --ppapi-flash-path=/usr/lib/pepflashplugin-installer/libpepflashplayer.so
> --ppapi-flash-version=13.0.0.182 --enable-pinch --flag-switches-begin
> --enable-experimental-extension-apis --flag-switches-end
>
> (See also https://code.google.com/p/chromium/issues/detail?id=351230)
>
> ** Affects: chromium-browser (Ubuntu)
> Importance: Undecided
> Status: New
>
> ** Description changed:
>
> - When entering the key combination
> + When entering the key combination
> AltGr + [ a
> in any text input field or address bar, it does not translate to ä (a
> umlaut) anymore. This worked in the "pre-aura" Chromium 33.
>
> ---
> + Ubuntu 14.04, Gnome Flashback Session
> +
> UK International Keyboard
>
> $ echo $GTK_IM_MODULE
> xim
>
> Chromium 34.0.1847.116 (Developer Build 260972) Ubuntu 14.04 aura
> - OS Linux
> + OS Linux
> Blink 537.36 (@170605)
> JavaScript V8 3.24.35.22
> Flash 13.0.0.182
> User Agent Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML,
> like Gecko) Ubuntu Chromium/34.0.1847.116 Chrome/34.0.1847.116 Safari/537.36
> Command Line /usr/lib/chromium-browser/chromium-browser
> --ppapi-flash-path=/usr/lib/pepflashplugin-installer/libpepflashplayer.so
> --ppapi-flash-version=13.0.0.182 --enable-pinch --flag-switches-begin
> --enable-experimental-extension-apis --flag-switches-end
>
> (See also https://code.google.com/p/chromium/issues/detail?id=351230)
>
> --
> You received this bug notification because you are subscribed to
> chromium-browser in Ubuntu.
> Matching subscriptions: Cr
> https://bugs.launchpad.net/bugs/1309145
>
> Title:
> Chromium 34 ignores ComposeKey
>
> Status in “chromium-browser” package in Ubuntu:
> New
>
> Bug description:
> When entering the key combination
> AltGr + [ a
> in any text input field or address bar, it does not translate to ä (a
> umlaut) anymore. This worked in the "pre-aura" Chromium 33.
>
> ---
> Ubuntu 14.04, Gnome Flashback Session
>
> UK International Keyboard
>
> $ echo $GTK_IM_MODULE
> xim
>
> Chromium 34.0.1847.116 (Developer Build 260972) Ubuntu 14.04 aura
> OS Linux
> Blink 537.36 (@170605)
> JavaScript V...

Read more...

Changed in chromium-browser (Ubuntu):
status: New → Incomplete

Compose is working anywhere except in Chromium for me.
My settings on Keyboard -> Shortcuts -> Typing:
Compose Key: Disabled

I confirm this just happens in GNOME Flashback (Metacity) session.

summary: - Chromium 34 ignores ComposeKey
+ Chromium 34 ignores ComposeKey in GNOME Flashback (Metacity)
description: updated
Chad Miller (cmiller) wrote :

ano, so, Compose key works on chromium in other environments, and it works in every other client except chromium when using Gnome Flashback?

Alex N. (a-nox) wrote :

Yes, that's correct.

I switched to Unity and it worked as expected for some time, but now i'm experiencing the same problem there. I'm renaming this again as it seems to affect all enviroments.

summary: - Chromium 34 ignores ComposeKey in GNOME Flashback (Metacity)
+ Chromium 34 ignores ComposeKey
description: updated
Changed in chromium-browser (Ubuntu):
assignee: nobody → ano (a-nox)
assignee: ano (a-nox) → nobody
Daniel Kulesz (kuleszdl) wrote :

I can report that the problem also arises in KDE and exactly as stated here - all clients work, except Chromium. I tried setting this variable here as follows (as outlined in the upstream bug):

GTK_IM_MODULE=gtk-im-context-simple

But no effect- problem still persists.

Alex N. (a-nox) wrote :

This seems to be fixed in Google Chrome 35.0.1916.114. Any sign when Chromium 35 will come out?

wdoekes (walter+ubuntu) wrote :

Confirming: I switched to xim input method yesterday (for custom compose combinations), and today I noticed that indeed the compose key does not work in Chromium.

http://code.google.com/p/chromium/issues/detail?id=351230

Browser: Version 34.0.1847.116 Ubuntu 14.04 aura (260972) [34.0.1847.116-0ubuntu2]
OS: Trusty

Daniel Kulesz (kuleszdl) wrote :

Received today's updates...

---
Preparing to replace chromium-browser-l10n 34.0.1847.116-0ubuntu~1.12.04.0~pkg884 (using .../chromium-browser-l10n_36.0.1985.125-0ubuntu1.12.04.0~pkg897_all.deb) ...
Unpacking replacement chromium-browser-l10n ...
Preparing to replace chromium-codecs-ffmpeg 34.0.1847.116-0ubuntu~1.12.04.0~pkg884 (using .../chromium-codecs-ffmpeg_36.0.1985.125-0ubuntu1.12.04.0~pkg897_amd64.deb) ...
---

and the umlauts are still broken! :-(

Daniel Kulesz (kuleszdl) wrote :

Sorry this was the log of a machine running 12.04 - but the problem persists in 14.04(.1).

wdoekes (walter+ubuntu) on 2014-08-06
summary: - Chromium 34 ignores ComposeKey
+ Chromium 34 and 36 ignores ComposeKey (with xim GTK_IM_MODULE)

This seems to be fixed for me with the latest chromium-browser 36.0.1985.125 Ubuntu 14.04 (283153). Can anyone confirm this?

wdoekes (walter+ubuntu) wrote :

I can refute it. Over here is it *not* fixed with:

  Version 36.0.1985.125 Ubuntu 14.04 (283153)

I did a full restart, to be on the safe side.

My config:

  $ tail -n1 .profile
  export GTK_IM_MODULE="xim" # Compose key stuffs

  $ cat .XCompose
  include "%L" # import the default Compose file for your locale
  <Multi_key> <slash> <question> : "⸮" U2E2E # REVERSED QUESTION MARK (IRONY PUNCTUATION)
  # and add GTK_IM_MODULE="xim" to ~/.profile

No composition works anywhere within chromium.
If I remove the GTK_IM_MODULE export and restart the X session, things work
like expected again.

Alex N. (a-nox) wrote :

For testing please change the input module with "im-config" like explained here: https://code.google.com/p/chromium/issues/detail?id=351230

My current enviroment:
GTK_IM_MODULE=xim
XMODIFIERS=@im=none
LANG=en_GB.UTF-8
LANGUAGE=en_GB:en
LC_ALL=

Apparently the chromium bug "linux-aura: Supports Compose key with XIM." has been closed, so this should be fixed, see https://codereview.chromium.org/243143002/#ps100001

wdoekes (walter+ubuntu) wrote :

Funny, but that gives me completely different broken behaviour.

im-config writes to ~/.xinputrc:

  # im-config(8) generated on Thu, 07 Aug 2014 08:26:49 +0200
  run_im xim
  # im-config signiture: 89512b7941127eeda7d3e3ac5703f05e -

And then I indeed get the same environment variables as you. (en_US)

In other applications the input works like expected, regular compose and my
extra combinations. In chromium, the following happens:
- in the address bar, regular compose works, but my extra combinations *don't*
- as soon as I press enter in the address bar, the compose key stops working
  altogether: both keys of the combination get discarded
- however, after the third attempt at reproducing, the regular compose stopped
  working: chromium now consistently silently eats all compose characters, even
  at startup.

That last behavioural change sounded like a local config issue, but removing
~/.config/chromium did not resolve anything.

Also, switching the compose key from right-alt to right-ctrl does what you'd expect:
- in all applications the compose key is changed
- in chromium, the composed keys -- now with right-ctrl -- are eaten

Alex N. (a-nox) wrote :

Fixed for me in Version 37.0.2062.94 Ubuntu 14.04 (290621) (64-bit), can anyone confirm?

wdoekes (walter+ubuntu) wrote :

Nope. Not fixed there either. I get exactly this:
https://code.google.com/p/chromium/issues/detail?id=351230#c64
(the "gdk_window_set_user_time called on non-toplevel" error)

Daniel Kulesz (kuleszdl) wrote :

Finally! Today's update for 14.04 fixed it, the Umlauts are working again! The update was:

chromium-browser_38.0.2125.111-0ubuntu0.14.04.1.1061_amd64.deb

Alex N. (a-nox) on 2014-11-10
summary: - Chromium 34 and 36 ignores ComposeKey (with xim GTK_IM_MODULE)
+ Chromium 34+ ignores ComposeKey (with xim GTK_IM_MODULE)
Alex N. (a-nox) wrote :

I can confirm this is working with Version 38.0.2125.111 Ubuntu 14.10 (290379) (64-bit)

wdoekes (walter+ubuntu) wrote :

Confirmed. No strange behaviour with 38.0.2125.111. Only expected and working behaviour.

Good.

Alex N. (a-nox) on 2014-11-11
Changed in chromium-browser (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.