Chromium password autocomplete broken for certain fields

Bug #1294325 reported by xor
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
Undecided
Unassigned

Bug Description

Used Ubuntu: Kubuntu 13.10 amd64

Today I installed the following upgrades (taken from /var/log/apt/history.log):
Start-Date: 2014-03-18 20:22:56
Upgrade: chromium-codecs-ffmpeg-extra:amd64 (32.0.1700.107-0ubuntu0.13.10.1~20140204.972.1, 33.0.1750.152-0ubuntu0.13.10.1~pkg984.1), chromium-browser-l10n:amd64 (32.0.1700.107-0ubuntu0.13.10.1~20140204.972.1, 33.0.1750.152-0ubuntu0.13.10.1~pkg984.1), chromium-browser:amd64 (32.0.1700.107-0ubuntu0.13.10.1~20140204.972.1, 33.0.1750.152-0ubuntu0.13.10.1~pkg984.1)
End-Date: 2014-03-18 20:23:19

They broke autocomplete for HTML password fields which have the "autocomplete=off" attribute set.
While this might not sound like a bug to you, it IS a regression: With previous versions, the "autocomplete=off" attribute could be temporarily disabled with a JavaScript bookmarklet [1]. Then Chromium would ask the user to store the password. Once the password was stored in the database, future visits of the site would autocomplete the field. So basically in previous versions, the "autocomplete=off" flag was only a guardian against storing the password in the database, NOT against restoring it from the database if it is already in the database.
In the current version, autocomplete does NOT restore the stored password anymore, even when manually choosing the username from the username field's drop down menu. Using the bookmarklet to set "autocomplete=on" also doesn't help. I've tried this with two different websites.

You might argue that this is intended by the website's developer. But I think it is an unacceptable restriction of my personal choice as a user of what I want to do with my computer. It wastes my time to continuously have to enter shitloads of passwords of websites which I have to visit every day. And the disabling of autocomplete form is slowly creeping into a lot of websites because it allows them to generate a false sense of security for non-expert users while obstructing anyone who trusts his machine.

[1] Store this as a bookmark, without the quotes: "javascript:(function(){var fm=document.getElementsByTagName('form');for(i=0;i<fm.length;i++){fm[i].setAttribute('autocomplete','on');}var inp=document.getElementsByTagName('input');for(i=0;i<inp.length;i++){inp[i].setAttribute('autocomplete','on');}})()"

Revision history for this message
Chad Miller (cmiller) wrote :

Hrm, I have an extension that does that. I'll look into it.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in chromium-browser (Ubuntu):
status: New → Confirmed
Revision history for this message
pcworld (pcworld) wrote :

In future versions of Chromium, the autcomplete="off" feature is disabled by default: https://groups.google.com/a/chromium.org/forum/#!topic/chromium-dev/zhhj7hCip5c

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package chromium-browser - 34.0.1847.116-0ubuntu2

---------------
chromium-browser (34.0.1847.116-0ubuntu2) trusty; urgency=medium

  * Don't recommend pepperflashplugin-nonfree, which is in multiverse. (LP:
    #1307606)
 -- Iain Lane <email address hidden> Mon, 14 Apr 2014 17:43:53 +0100

Changed in chromium-browser (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers