chromium-browser doesn't start; crashes wich SIGSEGV in libprotobuf.so

Bug #1267293 reported by Kimikazu on 2014-01-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
Undecided
Chad Miller

Bug Description

chromium-browser doesn't start at all. It crashed with SEGSIGV.
The backtrace is as follows:

---
#0 0x00007fff57d4df27 in ?? () from /usr/lib/libprotobuf.so.7
#1 0x00007ffff7de9856 in call_init (
    l=<error reading variable: Cannot access memory at address 0x7fffffffaf28>, argc=1, argv=0x7fffffffdd58, env=0x55555717b890) at dl-init.c:84
---

This symptom started some months ago after a certain upgrade.
---
ApportVersion: 2.12.5-0ubuntu2.2
Architecture: amd64
ChromiumPrefs: can't open profile /home/kato/.config/chromium/Default/Preferences
Desktop-Session:
 DESKTOP_SESSION = ubuntu
 XDG_CONFIG_DIRS = /etc/xdg/xdg-ubuntu:/usr/share/upstart/xdg:/etc/xdg
 XDG_DATA_DIRS = /usr/share/ubuntu:/usr/share/gnome:/usr/local/share/:/usr/share/
DistroRelease: Ubuntu 13.10
DmesgChromium:
 [ 859.445224] chromium-browse[5435]: segfault at 7f031b890f0c ip 00007f0286823f27 sp 00007fffb47b1528 error 6 in libprotobuf.so.7.0.0[7f02867e5000+ed000]
 [ 1332.395415] chromium-browse[7518]: segfault at 7f0236e9ef0c ip 00007f01a1bf0f27 sp 00007fff8245d5f8 error 6 in libprotobuf.so.7.0.0[7f01a1bb2000+ed000]
 [14067.080241] chromium-browse[11940]: segfault at 7f66dde14f0c ip 00007f664cde4f27 sp 00007fff67211e58 error 6 in libprotobuf.so.7.0.0[7f664cda6000+ed000]
 [88576.082314] chromium-browse[30534]: segfault at 7fdaf49c8f0c ip 00007fda57863f27 sp 00007fff15d6d108 error 6 in libprotobuf.so.7.0.0[7fda57825000+ed000]
 [88687.684083] chromium-browse[31394]: segfault at 7f6cd52a3f0c ip 00007f6c4449df27 sp 00007fff81b0fca8 error 6 in libprotobuf.so.7.0.0[7f6c4445f000+ed000]
Env:
 MOZ_PLUGIN_PATH = None
 LD_LIBRARY_PATH = /usr/local/lib:
InstallationDate: Installed on 2013-05-20 (234 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
Package: chromium-browser 31.0.1650.63-0ubuntu0.13.10.1~20131204.1
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 3.11.0-15.23-generic 3.11.10
Tags: saucy
Uname: Linux 3.11.0-15-generic x86_64
UpgradeStatus: Upgraded to saucy on 2013-10-22 (79 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
chromium-default: CHROMIUM_FLAGS=""

Kimikazu (kimikazu) on 2014-01-09
summary: - chromium-browser doesn't start; crashes wich SIGSEGV in libprotobug.so
+ chromium-browser doesn't start; crashes wich SIGSEGV in libprotobuf.so
description: updated
Chad Miller (cmiller) wrote :

Interesting! See the dates at the bottom of this? One of those, perhaps?

https://launchpad.net/ubuntu/+source/protobuf

I want to learn some more about your system. At a command line, please run "apport-collect 1267293"

Changed in chromium-browser (Ubuntu):
status: New → Incomplete
assignee: nobody → Chad Miller (cmiller)
Chad Miller (cmiller) wrote :

Also, "apt-cache policy chromium-browser" at attach the result.

apport information

tags: added: apport-collected saucy
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

Kimikazu (kimikazu) wrote :

This is the result of "apt-cache policy chromium-browser"

---
chromium-browser:
  Installed: 31.0.1650.63-0ubuntu0.13.10.1~20131204.1
  Candidate: 31.0.1650.63-0ubuntu0.13.10.1~20131204.1
  Version table:
 *** 31.0.1650.63-0ubuntu0.13.10.1~20131204.1 0
        500 http://jp.archive.ubuntu.com/ubuntu/ saucy-updates/universe amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ saucy-security/universe amd64 Packages
        100 /var/lib/dpkg/status
     29.0.1547.65-0ubuntu2 0
        500 http://jp.archive.ubuntu.com/ubuntu/ saucy/universe amd64 Packages

Chad Miller (cmiller) on 2014-01-10
Changed in chromium-browser (Ubuntu):
status: Incomplete → New
Chad Miller (cmiller) wrote :

Does this chromium-browser update help?

Changed in chromium-browser (Ubuntu):
status: New → Incomplete
Kimikazu (kimikazu) wrote :

No. After "apt-get upgrade," I confirmed the symptom is the same. It fails with Segment fault.

Addional information:
 This symptom happens in two different PCs (desktop and laptop). So I regard this is not very rarely reproducable.

Kimikazu (kimikazu) wrote :

The attached is the backtrace when it fails with "--debug" option.

Since there has been no response for a month, I regard this reproduces rarely in other environments.
Now I feel I should pursue the reason by myself. Could you give me any hint looking at this backtrace?

Kimikazu (kimikazu) wrote :

After updating to 14.04, this problem doesn't reproduce. I would like to close this.

Thanks, Chad.

Changed in chromium-browser (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers