URL doesn't open from other application in chromium-browser

Bug #1244884 reported by shantanu saha on 2013-10-26
60
This bug affects 12 people
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
Undecided
Unassigned

Bug Description

How to generate:

Set chromium-browser as default browser. Now open skype (an example application, you can use other). Click on any web link in skpye. A new chromium-browser will open with nothing in address bar. (Situation: someone send me a link (say youtube link), when i click on that chromium-browser open with blank address bar. No web link loaded)

Expected:
Open new chromium-browser window with link if no browser instance is running otherwise in new tab.

Note: If you click on any link in chromium-browser or in chromium-browser webapp than it works fine.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: chromium-browser 30.0.1599.114-0ubuntu1~cm0saucy [modified: usr/share/applications/chromium-browser.desktop] [origin: LP-PPA-cmiller-chromium-browser-stable-daily]
ProcVersionSignature: Ubuntu 3.11.0-13.20-generic 3.11.6
Uname: Linux 3.11.0-13-generic x86_64
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
CrashDB: ubuntu
Date: Sat Oct 26 13:14:39 2013
Desktop-Session:
 DESKTOP_SESSION = ubuntu
 XDG_CONFIG_DIRS = /etc/xdg/xdg-ubuntu:/usr/share/upstart/xdg:/etc/xdg
 XDG_DATA_DIRS = /usr/share/ubuntu:/usr/share/gnome:/usr/local/share/:/usr/share/
Env:
 MOZ_PLUGIN_PATH = None
 LD_LIBRARY_PATH = None
ExecutablePath: /usr/lib/chromium-browser/chromium-browser
MarkForUpload: True
SourcePackage: chromium-browser
ThirdParty: True
UpgradeStatus: No upgrade log present (probably fresh install)
chromium-default: CHROMIUM_FLAGS=""
gconf-keys: /desktop/gnome/applications/browser/exec = b'/usr/bin/chromium-browser\n'/desktop/gnome/url-handlers/https/command = b'firefox %s\n'/desktop/gnome/url-handlers/https/enabled = b'true\n'/desktop/gnome/url-handlers/http/command = b'firefox %s\n'/desktop/gnome/url-handlers/http/enabled = b'true\n'/desktop/gnome/session/required_components/windowmanager = b''/apps/metacity/general/compositing_manager = b''/desktop/gnome/interface/icon_theme = b'gnome\n'/desktop/gnome/interface/gtk_theme = b'Clearlooks\n'

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in chromium-browser (Ubuntu):
status: New → Confirmed
Steven Stromberg (gyozaguy-x) wrote :

In my case, when I check my default browser settings, it shows up as "Google Keep". A bit before that, my Chromium launcher would always launch the Grooveshark webapp. I purged and reinstalled Chromium several times, and now I'm getting this issue. It seems to me that somehow Chromium and the webapps/extensions are getting confused in the system. When I click a link, apparently it tries to load Google Keep, which doesn't handle the URL, so just loads a new tab page instead.

I've tried both "xdg-settings set default-web-browser chromium-browser.desktop" and "sudo update-alternatives --config x-www-browser", and the settings are fine there, but "Google Keep" is still showing up as my default web browser.

Steven Stromberg (gyozaguy-x) wrote :

I should add that links within Chromium work perfectly fine for me too, but not from any other application, as mentioned in the original comment.

Chad Miller (cmiller) wrote :

In a terminal, run
gnome-open http://launchpad.net/
. What happens?

Once chromium is running, hold Alt and hit Home button on keyboard. What happens?

Finally, when you reproduce the bug, please paste the result of this run in a terminal:

ps xauw |grep chromium

Changed in chromium-browser (Ubuntu):
assignee: nobody → Chad Miller (cmiller)
status: Confirmed → Incomplete

bug fixed in Version 30.0.1599.114 Ubuntu 13.10 (30.0.1599.114-0ubuntu0.13.10.2).

Chad Miller (cmiller) wrote :

Hrm. I know of no change that would affect this bug. Keeping as Incomplete because Steven may still see it.

Steven Stromberg (gyozaguy-x) wrote :
Download full text (4.7 KiB)

Hello,

After running "gnome-open http://launchpad.net", I still got a new tab page, and pressing Alt+Home takes me to a new tab page.

Here is the output of "ps xauw | grep chromium":

steven 2356 1.7 1.0 3132884 164252 ? SLl 08:14 1:33 chromium-browser --no-startup-window
steven 2440 0.0 0.0 427200 10592 ? S 08:14 0:02 chromium-browser --no-startup-window
steven 2441 0.0 0.0 14832 1116 ? S 08:14 0:00 /usr/lib/chromium-browser/chrome-sandbox /usr/lib/chromium-browser/chromium-browser --type=zygote
steven 2442 0.0 0.1 450052 29292 ? S 08:14 0:00 chromium-browser --type=zygote
steven 2456 0.0 0.0 523784 7872 ? S 08:14 0:00 chromium-browser --type=zygote
steven 2573 0.0 0.1 1243136 27852 ? Sl 08:14 0:00 /usr/lib/chromium-browser/chro
steven 2578 0.0 0.2 1246732 36540 ? Sl 08:14 0:00 /usr/lib/chromium-browser/chro
steven 2588 0.0 0.3 1279720 62780 ? Sl 08:14 0:03 /usr/lib/chromium-browser/chro
steven 2593 1.1 0.8 1336704 140980 ? Sl 08:14 0:58 /usr/lib/chromium-browser/chro
steven 2598 0.0 0.1 1245420 32348 ? Sl 08:14 0:04 /usr/lib/chromium-browser/chro
steven 2603 0.4 0.3 1270168 58172 ? Sl 08:14 0:21 /usr/lib/chromium-browser/chro
steven 2608 0.0 0.2 1245384 34472 ? Sl 08:14 0:01 /usr/lib/chromium-browser/chro
steven 2613 0.0 0.1 1245260 31140 ? Sl 08:14 0:00 /usr/lib/chromium-browser/chro
steven 2624 0.0 0.2 1250584 39512 ? Sl 08:14 0:01 /usr/lib/chromium-browser/chro
steven 2629 0.0 0.1 1244144 29972 ? Sl 08:14 0:00 /usr/lib/chromium-browser/chro
steven 2634 0.3 0.2 1250364 44668 ? Sl 08:14 0:17 /usr/lib/chromium-browser/chro
steven 2639 0.3 0.5 1671644 95196 ? Sl 08:14 0:19 /usr/lib/chromium-browser/chro
steven 2644 0.0 0.2 1246172 36108 ? Sl 08:14 0:00 /usr/lib/chromium-browser/chro
steven 2649 0.0 0.2 1245900 36248 ? Sl 08:14 0:00 /usr/lib/chromium-browser/chro
steven 2846 0.0 0.2 1250236 40772 ? Sl 08:15 0:02 /usr/lib/chromium-browser/chro
steven 2870 0.0 0.1 1243644 29296 ? Sl 08:15 0:00 /usr/lib/chromium-browser/chro
steven 2897 0.0 0.2 800704 35864 ? Sl 08:15 0:01 chromium-browser --type=plugin --plugin-path=/home/steven/.config/chromium/Default/Extensions/pmoflmbbcfgacopiikdcpmbiellfihdg/2.4.8_0/libunity_npapi_plugin.so --lang=en-US --channel=2356.26.20675808
steven 2994 0.0 0.2 681112 33408 ? Sl 08:15 0:00 chromium-browser --type=plugin --plugin-path=/home/steven/.config/chr...

Read more...

Gerlof Fokkema (gerlof-fokkema) wrote :

Seems like this bug is still present.

gnome-open http://launchpad.net
gives me a new Chromium screen with a blank page and no url.

chromium-browser http://launchpad.net
gives me a new tab in a present Chromium screen displaying http://launchpad.net

dconf-editor:
/desktop/gnome/url-handlers/http/command = chromium-browser %s
/desktop/gnome/url-handlers/https/command = chromium-browser %s

any logs i need to attach or commands i need to run to supply more info?

What do these show?

$ gconftool --get /desktop/gnome/url-handlers/http/command |od -x
$ dconf read /desktop/gnome/url-handlers/http/command |od -x

$ gconftool --get /desktop/gnome/url-handlers/http/command |od -x
0000000 752f 7273 622f 6e69 632f 7268 6d6f 7569
0000020 2d6d 7262 776f 6573 2072 7325 000a
0000035
$ dconf read /desktop/gnome/url-handlers/http/command |od -x
0000000

Something else worth noting:
When I go to
system-settings -> details -> default applications
and change 'web' to 'Firefox Web Browser' instead of 'Chrome'
then the Chrome option disappears...

I can only set Chromium default again by closing all Chromium windows and restarting it.
It will then ask to be default again.

Chad Miller (cmiller) wrote :

Wow, I don't know what's going on here.

How about this. Close all chromium. Use "ps x |grep chrom" to verify none are running. Attach file "cr-trace" to this bug report after this, and then closing chromium.

$ strace -f -o cr-trace -e trace=process gnome-open

Martin Gasparek (martin-gaspo) wrote :

Im using google-chrome-stable (now version 33.0.1750.152), but I have the same problem. here is requested cr-trace

shankao (shankao) wrote :

I've applied the fix in this page and now it works:

https://askubuntu.com/questions/540939/xdg-open-only-opens-a-new-tab-in-a-new-chromium-window-despite-passing-it-a-url

Summary: there is some problem with the file ~/.local/share/applications/chromium-browser.desktop that breaks the exec command. Maybe one of my installed packages modified it incorrectly (the new pepper flash plugin? I have it installed too)

Jostein (josteinaj) wrote :

I've been having this issue for the last month or so (Chromium 48.0.2564.82 Ubuntu 15.10 - not sure what the version was when I first installed Chromium).

The fix linked by shanankao works for me. Thanks shanankao! It's quite annoying having to copy-paste all URLs :)

So the issue is probably that when `~/.local/share/applications/chromium-browser.desktop` is installed, there's a missing %U in the launch command.

Steven Almeroth (stavrosian) wrote :

On my Ubuntu 16.04 I changed this file:

    ~/.local/share/applications/chromium-browser.desktop

from:

    Exec=chromium-browser --enable-pinch

to:

    Exec=chromium-browser %U --enable-pinch

Now it works as expected, opening the URL in Chromium when I click a link in an external application.

Steven Almeroth (stavrosian) wrote :

...or, what Jostein said.

On 16.04, same problem but not on recent fresh install.

I solved it removing the file ~/.local/share/applications/chromium-browser.desktop

then it takes the desktop file from /usr/share which is good.

vambo põldra (vpoldra) wrote :

I did have the same problem on a recent install, removing the .desktop file as per Olivier's comment fixed it for me.

I did the following change to get it working.

From:
Exec=/opt/google/chrome/chrome

To:
Exec=/opt/google/chrome/chrome %u

Olivier Tilloy (osomon) on 2018-03-09
Changed in chromium-browser (Ubuntu):
assignee: Chad Miller (cmiller) → nobody
Launchpad Janitor (janitor) wrote :

[Expired for chromium-browser (Ubuntu) because there has been no activity for 60 days.]

Changed in chromium-browser (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers