No search suggestions in omnibox

Bug #1244774 reported by nichtstuer on 2013-10-25
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
High
Chad Miller

Bug Description

Chromium ver. 28 and also 30.0.1599.114 (13.04 reps). When the search engine is set to Google, no suggestions are displayed while I'm typing smth in omnibox, though suggestions work fine with Bing or in Google Chrome ver. 30.

Chromium sends a slightly different client in Autocomplete request, which currently is not supported on the server side. For regular Chrome client=chrome, unlike for Chromium, where it is set to "ubuntu". (https://code.google.com/p/chromium/issues/detail?id=304560)

nichtstuer (nichtstuer) on 2013-10-25
tags: added: omnibox
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in chromium-browser (Ubuntu):
status: New → Confirmed
Flittermice (flittermice) wrote :

They seem to have found the reason @chromium:
https://code.google.com/p/chromium/issues/detail?id=304560

The problem is the Ubuntu-specific Autocomplete request sent by chromium.

nichtstuer (nichtstuer) on 2013-11-07
description: updated
tags: added: 30.0.1599.114
description: updated
Chad Miller (cmiller) on 2013-11-07
Changed in chromium-browser (Ubuntu):
assignee: nobody → Chad Miller (cmiller)
importance: Undecided → High
status: Confirmed → In Progress
Chad Miller (cmiller) on 2013-12-02
Changed in chromium-browser (Ubuntu):
status: In Progress → Fix Committed
Chad Miller (cmiller) on 2013-12-18
Changed in chromium-browser (Ubuntu):
status: Fix Committed → Fix Released
Kirill Tomarov (tomarov-kirill) wrote :

Bug occurs again in Chromium Version 39.0.2171.65 Ubuntu 14.04 (64-bit). Same description.

Please file a new bug, Kirill. $ ubuntu-bug chromium-browser .

On Wed, Dec 3, 2014 at 1:19 AM, Kirill Tomarov <email address hidden>
wrote:

> Bug occurs again in Chromium Version 39.0.2171.65 Ubuntu 14.04 (64-bit).
> Same description.
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1244774
>
> Title:
> No search suggestions in omnibox
>
> Status in chromium-browser package in Ubuntu:
> Fix Released
>
> Bug description:
> Chromium ver. 28 and also 30.0.1599.114 (13.04 reps). When the search
> engine is set to Google, no suggestions are displayed while I'm typing
> smth in omnibox, though suggestions work fine with Bing or in Google
> Chrome ver. 30.
>
> Chromium sends a slightly different client in Autocomplete request,
> which currently is not supported on the server side. For regular
> Chrome client=chrome, unlike for Chromium, where it is set to
> "ubuntu". (https://code.google.com/p/chromium/issues/detail?id=304560)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1244774/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.