Chromium reports "It's dead Jim" on Low RAM machines

Bug #1096603 reported by Phill Whiteside on 2013-01-06
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
Medium
Unassigned

Bug Description

When running certain tabs, chromium browser eventually reports the above error.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: chromium-browser 22.0.1229.94~r161065-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-21.32-generic 3.5.7.1
Uname: Linux 3.5.0-21-generic x86_64
ApportVersion: 2.6.1-0ubuntu9
Architecture: amd64
Date: Sun Jan 6 15:09:12 2013
Desktop-Session:
 DESKTOP_SESSION = Lubuntu
 XDG_CONFIG_DIRS = /etc/xdg/lubuntu/:/etc/xdg/xdg-Lubuntu:/etc/xdg
 XDG_DATA_DIRS = /etc/xdg/lubuntu:/usr/share/Lubuntu:/usr/local/share/:/usr/share/:/usr/share:/usr/share/gdm:/var/lib/menu-xdg
DiskUsage:
 b'Filesystem Type Size Used Avail Use% Mounted on\n/dev/vda1 ext4 9.4G 2.6G 6.4G 29% /\nudev devtmpfs 237M 4.0K 237M 1% /dev\ntmpfs tmpfs 99M 712K 98M 1% /run\nnone tmpfs 5.0M 0 5.0M 0% /run/lock\nnone tmpfs 246M 132K 246M 1% /run/shm\nnone tmpfs 100M 8.0K 100M 1% /run/user\n'

 Inodes:
 b'Filesystem Inodes IUsed IFree IUse% Mounted on\n/dev/vda1 608K 139K 470K 23% /\nudev 60K 425 59K 1% /dev\ntmpfs 62K 330 62K 1% /run\nnone 62K 3 62K 1% /run/lock\nnone 62K 4 62K 1% /run/shm\nnone 62K 9 62K 1% /run/user\n'
Env:
 MOZ_PLUGIN_PATH = None
 LD_LIBRARY_PATH = None
ExecutablePath: /usr/lib/chromium-browser/chromium-browser
InstallationDate: Installed on 2013-01-04 (1 days ago)
InstallationMedia: Lubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017)
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: chromium-browser
UpgradeStatus: No upgrade log present (probably fresh install)
chromium-default: CHROMIUM_FLAGS=""
gconf-keys: /desktop/gnome/applications/browser/exec = b''/desktop/gnome/url-handlers/https/command = b''/desktop/gnome/url-handlers/https/enabled = b''/desktop/gnome/url-handlers/http/command = b''/desktop/gnome/url-handlers/http/enabled = b''/desktop/gnome/session/required_components/windowmanager = b''/apps/metacity/general/compositing_manager = b''/desktop/gnome/interface/icon_theme = b''/desktop/gnome/interface/gtk_theme = b''

Phill Whiteside (phillw) wrote :
Phill Whiteside (phillw) wrote :

Chad Miller asked for the tail end of dmesg to confirm an hypothesis.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in chromium-browser (Ubuntu):
status: New → Confirmed
Chad Miller (cmiller) wrote :

Right, so it is indeed the kernel OOM reaper that's killing processes, as it should. Chromium frontend is doing what it should, in displaying the "dead" message.

What's next is deciding whether the usage of memory itself is a bug.

The internal URL

  chrome://memory-redirect/

will show what's doing what, similar to "ps", if that helps testing.

AFAIK, Chromium's memory usage is better than old Firefox, but not as good as (post MemShrink) Firefox.

Phill Whiteside (phillw) wrote :

VM restarted, with the chromium://memory-redirect & http://bbc.co.uk/news tabs open. I've taken a screen shot of it at the start, and will just leave it to run.

Phill Whiteside (phillw) wrote :
Phill Whiteside (phillw) wrote :
Phill Whiteside (phillw) wrote :
Phill Whiteside (phillw) wrote :
Phill Whiteside (phillw) wrote :

Hi Chad, please find the details I garnered using the memory-redirect

amjjawad  (amjjawad) wrote :

Two machines, one is Asus F3F Laptop - Intel Due @1.86GHz with 488MB RAM and the other is P4 @3GHz with 465MB RAM. Tested on both machines using Lubutnu 12.04 and Lubuntu 12.10 and I got the SAME result. Chromium can't handle one opened tab on facebook with Marvel Avengers Alliance Game while Firefox can do that even with 3 opened tab on the very same machine.

That makes me wonder why would we still use Chromium as the default browser for Lubuntu instead of Firefox? if I can still vote, I would recommend to replace Chromium with Firefox.

Anyway, hope this will be fixed soon :)

Chad Miller (cmiller) on 2013-05-14
Changed in chromium-browser (Ubuntu):
assignee: nobody → Chad Miller (cmiller)
amjjawad  (amjjawad) wrote :

Hi, shall we keep this bug's status as it is? do we have to close it since Lubuntu is using Firefox by default now or is there any updates like fix released or something?

Thank you :)

Chad Miller (cmiller) wrote :

amijawad, if it were filed against lubuntu, you could close that part. It's still a valid complaint. Keep it open on the cr-b package.

amjjawad  (amjjawad) wrote :

If truth to be told, since Lubuntu switched to Firefox as the default browser, I haven't checked that really but as far as I know, yes, it is still valid and I was wondering if there is any kind of progress? but judging from everything here, and your post, I can tell this issue is not yet completely solved.

Thanks a lot :)

Phill Whiteside (phillw) wrote :

Chad, I still use chromium and am more than happy to test for you. Just give me a poke in the ribs as and when you would like something testing. I have VM's we can break :D I use Chromium for my general browser usage and also have F/fox running. Do not become a stranger because lubuntu has moved to F/fox for 13.10.
Regards,
Phill.

Adolfo Jayme (fitojb) on 2013-10-23
Changed in chromium-browser (Ubuntu):
importance: Undecided → Medium
Max Wachtel (maxwachtel) wrote :

this is happening to me using lubuntu/gnome-ubuntu/kubuntu. Using a dell d610 with 1Gb of ram.

amjjawad  (amjjawad) wrote :

@Max Wachtel

You need to click on:

"This bug affects 15 people. Does this bug affect you? "

Since you have confirmed that the bug affects you but you just left a comment :)

Thanks!

amjjawad  (amjjawad) wrote :

Believe it or not, Chromium is giving me hard time even on a powerful machine - http://ubuntuforums.org/showthread.php?t=2196371

I have never ever ever ever faced any issue with Firefox and I have no idea why Chromium is doing that?

On Sun, Dec 29, 2013 at 2:53 PM, amjjawad <email address hidden>wrote:

> Believe it or not, Chromium is giving me hard time even on a powerful
> machine - http://ubuntuforums.org/showthread.php?t=2196371
>
> I have never ever ever ever faced any issue with Firefox and I have no
> idea why Chromium is doing that?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1096603
>

While, after giving it another thought, I think I can re-produce the same
bug on my Core i5 2nd generation machine with 4GB RAM. Because, I got the:
"Kill or Wait" pop-up window 3 times. I think If my SWAP partition was
full, the browser would have crashed. I will report back if I managed to
produce this.

I have no idea what is wrong with Chromium? too bad that even Google can't
do anything about it because I don't think it is an Ubuntu Problem. As
always, Firefox works perfectly but I could be wrong though :)

--
Remember: "All of us are smarter than any one of us."
Best Regards,
amjjawad <https://wiki.ubuntu.com/amjjawad>
Areas of Involvement <https://wiki.ubuntu.com/amjjawad/AreasOfInvolvement>
My Projects <https://wiki.ubuntu.com/amjjawad/Projects>

Olivier Tilloy (osomon) wrote :

Closing now, as this was affecting an old version of chromium-browser.
Please file a new bug if you're still having memory issues with chromium-browser.

Changed in chromium-browser (Ubuntu):
status: Confirmed → Won't Fix
Olivier Tilloy (osomon) on 2018-03-09
Changed in chromium-browser (Ubuntu):
assignee: Chad Miller (cmiller) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers