When clicking "yes" on any integration prompt on chromium, nothing happens

Bug #1059460 reported by Didier Roche on 2012-10-01
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
High
Alexandre Abreu

Bug Description

Ensure the corresponding integration packages are not installed
1. With chromium, go to an integrated website (like G+, launchpad…)
2. you then see the banner for installing the extra feature, answer yes.
-> nothing happens

Excpected: the integration package (available through apt) should install.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity-webapps-service 2.3.8-0ubuntu3
ProcVersionSignature: Ubuntu 3.5.0-15.23-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
ApportVersion: 2.5.3-0ubuntu1
Architecture: amd64
Date: Mon Oct 1 11:10:07 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: libunity-webapps
UpgradeStatus: No upgrade log present (probably fresh install)

Didier Roche (didrocks) wrote :
Iain Lane (laney) wrote :

I see this with Firefox too; updating accordingly (feel free to split this into two separate bugs if it is)

summary: - With chromium, when clicking "yes" on any integration feature, nothing
- happens
+ When clicking "yes" on any integration feature, nothing happens
description: updated
Changed in libunity-webapps (Ubuntu):
importance: Undecided → High
Didier Roche (didrocks) on 2012-10-01
summary: - When clicking "yes" on any integration feature, nothing happens
+ When clicking "yes" on any integration prompt, nothing happens
Didier Roche (didrocks) wrote :

@Robert: Can you please test on your setup and confirm it's fixed?

Didier Roche (didrocks) wrote :

So, I tried libunity-webapps 2.3.9-0ubuntu1, which contains the above revision. With a fresh user, having sudo rights and fresh session.
Doesn't work using chromium.

Can we have the webapps team first testing their code rather than asking the reporter "it's maybe fixed"? Thanks.

To comment #5:

There is a known issue w/ chromium that somehow prevents the installation to reach policykit or something.

As of Firefox, there is an aptdaemon branch from Michael Vogt that fixes the high-trust installations (which webapps is part of) pending to me merged that seems to fix it: https://code.launchpad.net/~mvo/aptdaemon/fix-high-trust-repo-pkcompat

And the webapps team didn't as the reporter to check that it fixed,

Didier Roche (didrocks) wrote :

Confirming it's working on firefox (but not on G+, gmail and some others… there are different bug reports for those), but not on chromium. I'm changing back the bug title to clear that up and remove the added "firefox" part.

As discussed on IRC, the "Needs information" on the spreadsheet wasn't clear about it and seems that there was some wait on the reporter to confirm it.

summary: - When clicking "yes" on any integration prompt, nothing happens
+ When clicking "yes" on any integration prompt on chromium, nothing
+ happens
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libunity-webapps (Ubuntu):
status: New → Confirmed
Robert Carr (robertcarr) wrote :

Hi! Sorry I was sort of asking for confirmation of the bug.

Obviously if I could reproduce it I wouldn't leave it as an open bug ;)

Seems we are fine in firefox, still some issue with policykit in chromium?

David Barnett (mu-mind) wrote :

If this is a policykit issue, could it be related to https://bugs.launchpad.net/ubuntu/+source/policykit-1/+bug/1021410? It may be a coincidence, but I just updated to Quantal and started seeing both problems.

David Barnett (mu-mind) wrote :

For reference, these are the errors I get in my .xsession-errors file:

(exe:11624): PackageKit-WARNING **: couldn't parse execption 'GDBus.Error:org.freedesktop.PolicyKit.Error.Failed: ('system-bus-name', {'name': ':1.540'}): org.debian.apt.install-packages.high-trust-repo', please report

** (exe:11624): WARNING **: Error installing package: GDBus.Error:org.freedesktop.PolicyKit.Error.Failed: ('system-bus-name', {'name': ':1.540'}): org.debian.apt.install-packages.high-trust-repo

affects: libunity-webapps (Ubuntu) → chromium-browser (Ubuntu)
Changed in chromium-browser (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Fix Committed
assignee: nobody → Alexandre Abreu (abreu-alexandre)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package chromium-browser - 22.0.1229.79~r158531-0ubuntu1

---------------
chromium-browser (22.0.1229.79~r158531-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release from the Stable Channel
  * debian/control
    - fixed typo in description for chromium-codecs-ffmpeg
  * debian/patches/fix-armhf-ftbfs.patch
    - Dropped, no longer needed
  * debian/chromium-browser.install
    - Install demo extension
  * debian/rules
    - Updated INSTALL_EXCLUDE_FILES
    - build with gcc 4.7
  * debian/patches/1-infobars.patch,
    debian/patches/2-get-domain-tld.patch,
    debian/patches/3-chrome-xid.patch,
    debian/patches/4-chromeless-window-launch-option.patch,
    debian/patches/5-desktop-integration-settings.patch,
    debian/patches/fix-1034541.patch
    - Updated for v22
  * debian/patches/6-passwordless-install-support.patch
    - Webapp package installation (LP: #1059460)
  * debian/patches/7-plugin-status.patch
    - Don't block npapi plugins on linux, which is required by
      unity-chromium-extension
 -- Ken VanDine <email address hidden> Fri, 12 Oct 2012 09:31:11 -0400

Changed in chromium-browser (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers