Window raises on click even if set not to raise in window manager settings (in Xfce)

Bug #1054923 reported by Jarno Suni on 2012-09-23
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Xfwm4
Confirmed
Medium
chromium-browser (Ubuntu)
Undecided
Unassigned
xfwm4 (Ubuntu)
Undecided
Unassigned

Bug Description

Steps to reproduce:
1) Disable "Raise window when clicking inside application window" in Window Manager (xfwm?) settings in Xfce (in Focus tab).
2) Move another window to partly overlap chromium browser window
3) click on the chromium browser window below title bar
Result: the window raises
Expected result: window should not raise

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: chromium-browser 20.0.1132.47~r144678-0ubuntu0.12.04.1
ProcVersionSignature: Ubuntu 3.2.0-31.50-generic 3.2.28
Uname: Linux 3.2.0-31-generic i686
ApportVersion: 2.0.1-0ubuntu13
Architecture: i386
Date: Sun Sep 23 13:03:55 2012
Desktop-Session:
 DESKTOP_SESSION = xubuntu
 XDG_CONFIG_DIRS = /etc/xdg/xdg-xubuntu:/etc/xdg:/etc/xdg
 XDG_DATA_DIRS = /usr/share/xubuntu:/usr/local/share/:/usr/share/:/usr/share
Env:
 MOZ_PLUGIN_PATH = None
 LD_LIBRARY_PATH = None
InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110901)
ProcEnviron:
 LANGUAGE=en_US:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: chromium-browser
UpgradeStatus: Upgraded to precise on 2012-09-22 (0 days ago)
chromium-default: CHROMIUM_FLAGS=""

Jarno Suni (jarnos) wrote :
Paul White (paulw2u) wrote :

Jarno,

We are sorry that we do not always have the capacity to review all reported bugs in a timely manner. You reported this bug some time ago and there have been many changes in Ubuntu and Chromium since that time.

This issue was fixed in 2016, see https://bugs.chromium.org/p/chromium/issues/detail?id=318937 but comments there suggest that there might still be an issue with Xfce.

I've tested here using Xubuntu 18.04 and Chromium 69. The issue is fixed for me but is it for you?

I'm marking this as "Incomplete" pending changing to "Fix Released".

Thank you for helping make Ubuntu better.

Paul White
[Ubuntu Bug Squad]

Changed in chromium-browser (Ubuntu):
status: New → Incomplete
Jarno Suni (jarnos) wrote :

Like told in comment
https://bugs.chromium.org/p/chromium/issues/detail?id=318937#c65
it only works, if I have set "use the system title bar and borders" in chrome / chromium settings.

Steps to reproduce:

1) Disable "Raise window when clicking inside application window" in Window Manager settings in Xfce (in Focus tab).
2) Move another window to partly overlap chromium browser window
3) Click on the chromium browser window below title bar

Actual result: the window raises

Expected result: window should not raise

This is only an issue if "use the system title bar and borders" is not set in Chromium settings

Tested with Ubuntu 18.04, Chromium 69 and xfwm 4.12.4-0ubuntu1

See also https://bugs.launchpad.net/bugs/1054923
and https://bugs.chromium.org/p/chromium/issues/detail?id=318937

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfwm4 (Ubuntu):
status: New → Confirmed
Paul White (paulw2u) wrote :

Bug reported upstream to Xfce.

Changed in chromium-browser (Ubuntu):
status: Incomplete → Confirmed
Changed in chromium-browser:
importance: Unknown → Medium
status: Unknown → Confirmed

Is that with "system title bars and borders" ?

Because if Chromium is set to use its own decorations, then xfwm4 has no idea what's the actual window content as opposed to the decorations that it doesn't draw... So that's normal.

Client side decorations and "click inside application" do not mix well.

affects: chromium-browser → xfwm4
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.