chrome-gnome-shell crashed with SIGSEGV in ffi_call_unix64()

Bug #1660063 reported by dino99 on 2017-01-28
102
This bug affects 19 people
Affects Status Importance Assigned to Milestone
chrome-gnome-shell (Ubuntu)
Medium
Unassigned
Trusty
Medium
Unassigned
Xenial
Medium
Unassigned
Yakkety
Medium
Unassigned

Bug Description

Impact
------
chrome-gnome-shell has some crash bugs.

It looks like these have stopped phased-updates from chrome-gnome-shell in yakkety
https://people.canonical.com/~ubuntu-archive/phased-updates.html

Test Case
---------
Check errors.ubuntu.com to see if there are still crashes with chrome-shell 8.2ubuntu4~

Regression Potential
--------------------
Low. These patches come from Debian Stretch and are part of the new upstream version 8.1.

Original Bug Report
-------------------
This is happening when chromium is been closed. Get that issue with all the 8 serie
---
ApportVersion: 2.20.4-0ubuntu1
Architecture: amd64
CurrentDesktop: GNOME
DistroRelease: Ubuntu 17.04
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
Package: chrome-gnome-shell 8-2ubuntu3
PackageArchitecture: all
ProcVersionSignature: Ubuntu 4.9.0-15.16-generic 4.9.5
Tags: zesty third-party-packages
Uname: Linux 4.9.0-15-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom colord dip lpadmin nvidia-persistenced plugdev sambashare sudo users
_MarkForUpload: True

dino99 (9d9) wrote :
tags: added: apport-collected third-party-packages zesty
description: updated
dino99 (9d9) wrote : Dependencies.txt

apport information

apport information

dino99 (9d9) wrote : ProcEnviron.txt

apport information

dino99 (9d9) wrote :

Looks like the problem was with the 7.x -> 8.x versions upgrade transition: I've purged the installed package, then reinstalled it, and the crash does not happen anymore.
So i let you decide if that report needs investigation or if it can be closed.

Changed in chrome-gnome-shell (Ubuntu):
status: New → Incomplete
dino99 (9d9) wrote :

The comment #5 above is still true when c-g-s is purged then reinstalled with the same session: does not get crash with that opened session.
But the crash happens again with a new session opened after a cold boot.

Changed in chrome-gnome-shell (Ubuntu):
status: Incomplete → Confirmed
dino99 (9d9) wrote :

Good news, thanks ne0sight,

maybe you also can update your ppa for testing that 8.3 version (if the upgrade is not quickly done with the ZZ archive)

dino99 (9d9) wrote :

Latest 8.1-0ubuntu5 works well , thanks. Please load it to ZZ archive.

Jeremy Bicha (jbicha) on 2017-02-24
Changed in chrome-gnome-shell (Ubuntu Yakkety):
status: New → In Progress
importance: Undecided → Medium
Changed in chrome-gnome-shell (Ubuntu Xenial):
importance: Undecided → Medium
status: New → In Progress
Changed in chrome-gnome-shell (Ubuntu Trusty):
importance: Undecided → Medium
status: New → In Progress
Changed in chrome-gnome-shell (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Fix Committed
tags: added: xenial yakkety
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package chrome-gnome-shell - 8-2ubuntu4

---------------
chrome-gnome-shell (8-2ubuntu4) zesty; urgency=medium

  * Add patches from Debian 8-3 (cherrypicked from upstream 8.1) to fix
    crashes (LP: #1660063)
    - array-duplicates.patch
    - assume-version-1.patch
    - dont-use-get_dbus_connection.patch

 -- Jeremy Bicha <email address hidden> Thu, 23 Feb 2017 23:03:57 -0500

Changed in chrome-gnome-shell (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) on 2017-02-24
description: updated

Hello dino99, or anyone else affected,

Accepted chrome-gnome-shell into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/chrome-gnome-shell/8-2ubuntu4~ubuntu16.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in chrome-gnome-shell (Ubuntu Yakkety):
status: In Progress → Fix Committed
tags: added: verification-needed
dino99 (9d9) wrote :

Set 'verification-done' as the comment made a few days back in #9 is confirmed for ZZ 64 bits at least.

tags: added: verification-done
removed: verification-needed
Jeremy Bicha (jbicha) wrote :

I don't see any error reports on errors.ubuntu.com from chrome-gnome-shell 8.2ubuntu4~ for xenial and above. So I confirm the verification-done.

Brian Murray (brian-murray) wrote :

Looking at the Errors bucket for the crashes which halted the phased update earlier, I'm still seeing one crash (https://errors.ubuntu.com/problem/59694af66f4208c0851633bc8e29fcdc7f403cda) with crashes from 8-2ubuntu4. If I understand things correctly it shouldn't be happening with that version in Zesty, right?

tags: added: verification-needed
removed: verification-done
dino99 (9d9) wrote :

Brian,

i've not got crash since many weeks now on ZZ

Jeremy Bicha (jbicha) wrote :

Brian, yes it looks like there is still a crash somewhere in chrome-gnome-shell.

It might be fixed by 8.2 which I'll go ahead and upload to zesty to try out.

I don't think the crash affects the ability to use extensions.gnome.org via a web browser.

Could we ignore the crash (for phased-updates too) and accept this SRU since it's part of bug 1652537 which will be triggered later this week when Firefox 52 is pushed as a security update to all Ubuntu releases?

Jeremy Bicha (jbicha) wrote :

As for phased-updates, the yakkety rate was already apparently low enough for the first SRU to make it through. But any crash for the trusty and xenial SRUs will stop phased-updates since the baseline there is 0.

Changed in chrome-gnome-shell (Ubuntu):
status: Fix Released → Triaged
Jeremy Bicha (jbicha) wrote :

Firefox 52 was pushed yesterday to Ubuntu.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package chrome-gnome-shell - 8-2ubuntu4~ubuntu16.10.1

---------------
chrome-gnome-shell (8-2ubuntu4~ubuntu16.10.1) yakkety; urgency=medium

  * Add patches from Debian 8-3 (cherrypicked from upstream 8.1) to fix
    crashes (LP: #1660063)
    - array-duplicates.patch
    - assume-version-1.patch
    - dont-use-get_dbus_connection.patch

 -- Jeremy Bicha <email address hidden> Thu, 23 Feb 2017 23:08:23 -0500

Changed in chrome-gnome-shell (Ubuntu Yakkety):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for chrome-gnome-shell has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers